aboutsummaryrefslogtreecommitdiffstats
path: root/misc/qt4-qtdemo/Makefile
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-12-03 03:47:17 +0800
committermakc <makc@FreeBSD.org>2010-12-03 03:47:17 +0800
commit1b9ec1582fbf2b219f611d52fca8410e3cd06973 (patch)
tree42a169743be676e050a1e903ddf771488b5da9bb /misc/qt4-qtdemo/Makefile
parent69e87da3a0f46ad0c31d376913c821cc72c51ecd (diff)
downloadfreebsd-ports-gnome-1b9ec1582fbf2b219f611d52fca8410e3cd06973.tar.gz
freebsd-ports-gnome-1b9ec1582fbf2b219f611d52fca8410e3cd06973.tar.zst
freebsd-ports-gnome-1b9ec1582fbf2b219f611d52fca8410e3cd06973.zip
KDE FreeBSD team is glad to present Qt 4.7.1 in ports.
Along with Qt4 the following ports are updated: PyQt4 ports to 4.8.1 devel/py-sip to 4.11.2 devel/qscintilla2 to 2.4.5 PyKDE3 to 3.16.7 PyQt3 tp 3.18.2-snapshot-20091119 New ports added: devel/qt4-declarative devel/py-qt4-declarative x11/qt4-graphicssystems-opengl This release has been contributed by: Thomas Abthorpe (tabthorpe) Max Brazhnikov (makc) Dima Panov (fluffy) Alberto Villa (avilla) We'd like to thank Martin Wilke (miwi) for exp-run.
Diffstat (limited to 'misc/qt4-qtdemo/Makefile')
-rw-r--r--misc/qt4-qtdemo/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/misc/qt4-qtdemo/Makefile b/misc/qt4-qtdemo/Makefile
index 64f3936ba23a..e2f724045a86 100644
--- a/misc/qt4-qtdemo/Makefile
+++ b/misc/qt4-qtdemo/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= qtdemo
-PORTVERSION= ${QT4_VERSION}
+DISTVERSION= ${QT4_VERSION}
CATEGORIES?= misc
PKGNAMEPREFIX= qt4-
@@ -15,12 +15,13 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt demonstration and example programs
USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build rcc_build uic_build assistantclient \
- corelib designer gui network opengl sql svg qtestlib xml \
- imageformats_run dbus script webkit phonon help assistant_run \
- phonon-gst scripttools xmlpatterns multimedia
+QT_COMPONENTS= qmake_build moc_build rcc_build uic_build corelib designer \
+ gui network opengl sql svg qtestlib xml imageformats_run dbus \
+ script webkit phonon help assistant_run phonon-gst scripttools \
+ xmlpatterns multimedia
QT_NONSTANDARD= yes
QT_DIST= yes
+MAKE_JOBS_SAFE= yes
HAS_CONFIGURE= yes
@@ -51,7 +52,7 @@ post-patch:
${WRKSRC}/examples/help/simpletextviewer/assistant.cpp
pre-configure:
- ${MKDIR} ${WRKSRC}/mkspecs
+ ${MKDIR} ${WRKSRC}/mkspecs/modules
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
${LN} -sf ${LOCALBASE}/bin/uic-qt4 ${WRKSRC}/bin/uic
@@ -62,5 +63,6 @@ post-build:
post-install:
cd ${WRKSRC}/examples && ${SETENV} MAKEOBJDIR=. ${MAKE} install
+ ${FIND} -E ${PREFIX}/share/examples/qt4/examples/declarative/cppextensions -regex ".*\.(moc|obj|pch|rcc)" -type d | ${XARGS} ${RM} -r
.include <bsd.port.mk>