aboutsummaryrefslogtreecommitdiffstats
path: root/misc/quotes
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-07-28 00:06:25 +0800
committeraz <az@FreeBSD.org>2013-07-28 00:06:25 +0800
commit0a9e5efb9de6b8811964b263c03b83ec89719f71 (patch)
treeaf6266e338105f6caa968f90afd0c4e98288d6f5 /misc/quotes
parent161ee4e405ddee7d6c945754c827684829ef8e90 (diff)
downloadfreebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.tar.gz
freebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.tar.zst
freebsd-ports-gnome-0a9e5efb9de6b8811964b263c03b83ec89719f71.zip
- switch simple inline replacement from perl to sed
and remove where is no need in this anymore. - trim Makefile header Approved by: bapt@ (portmrg@)
Diffstat (limited to 'misc/quotes')
-rw-r--r--misc/quotes/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/misc/quotes/Makefile b/misc/quotes/Makefile
index fac82ec18f4e..631185563f5a 100644
--- a/misc/quotes/Makefile
+++ b/misc/quotes/Makefile
@@ -14,15 +14,14 @@ COMMENT= Quote, currency, and Slashdot headline fetcher based on Perl
NO_BUILD= yes
USE_PERL5= yes
+USES= shebangfix
+SHEBANG_FILES= quotes quotesmailer QuExample.pm
.include <bsd.port.options.mk>
post-patch:
- @ ${PERL} -pi -e "s:/usr/bin/perl:${PERL}:g" ${WRKSRC}/quotes
- @ ${PERL} -pi -e "s:/usr/local/lib/Quotes:${PREFIX}/etc:g" ${WRKSRC}/quotes
- @ ${PERL} -pi -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/quotes
- @ ${PERL} -pi -e "s:/usr/bin/perl:${PERL}:g" ${WRKSRC}/quotesmailer
- @ ${PERL} -pi -e "s:/usr/bin/perl:${PERL}:g" ${WRKSRC}/QuExample.pm
+ @${REINPLACE_CMD} -i '' -e "s:/usr/local/lib/Quotes:${PREFIX}/etc:" \
+ -e "s:/usr/local:${PREFIX}:" ${WRKSRC}/quotes
do-install:
@ ${INSTALL_SCRIPT} ${WRKSRC}/quotes ${PREFIX}/bin