aboutsummaryrefslogtreecommitdiffstats
path: root/misc/rabbit/Makefile
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2010-08-07 19:49:37 +0800
committertota <tota@FreeBSD.org>2010-08-07 19:49:37 +0800
commite2a4621bdc0e79a6ec0ceb690b6d500546c4f435 (patch)
tree886dfe22837f7fed795149ec3fe8f23eb41582ef /misc/rabbit/Makefile
parent01bdaab0d200548a52666eb229022289ef5d036e (diff)
downloadfreebsd-ports-gnome-e2a4621bdc0e79a6ec0ceb690b6d500546c4f435.tar.gz
freebsd-ports-gnome-e2a4621bdc0e79a6ec0ceb690b6d500546c4f435.tar.zst
freebsd-ports-gnome-e2a4621bdc0e79a6ec0ceb690b6d500546c4f435.zip
- Add missing require
http://www.cozmixng.org/retro/projects/rabbit/changesets/1388 - Use RUBY_SHEBANG_FILES - Remove rabbit.bat which is for Windows
Diffstat (limited to 'misc/rabbit/Makefile')
-rw-r--r--misc/rabbit/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/misc/rabbit/Makefile b/misc/rabbit/Makefile
index 404fa81f56d9..35e662aaf956 100644
--- a/misc/rabbit/Makefile
+++ b/misc/rabbit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rabbit
PORTVERSION= 0.6.5
+PORTREVISION= 1
CATEGORIES= misc ruby
MASTER_SITES= http://www.cozmixng.org/~kou/download/ \
${MASTER_SITE_LOCAL:S|%SUBDIR%|tota/rabbit|}
@@ -20,9 +21,15 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2 \
USE_RUBY= yes
USE_RUBY_SETUP= yes
+RUBY_SHEBANG_FILES= bin/rabbirc bin/rabbit bin/rabbit-command \
+ bin/rabbit-theme-manager bin/rabbitter bin/rabrick
+
DOCS_EN= NEWS.en README.en
DOCS_JA= NEWS.ja README.ja
+pre-install:
+ ${RM} -f ${WRKSRC}/bin/rabbit.bat
+
post-install:
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
d class='commitgraph'>* Release 1.4.7:bapt2015-01-232-3/+3 * Remove pkg_install support.mat2015-01-195-250/+21 * Update to 1.4.99.6bapt2015-01-182-3/+3 * Release 1.4.6bapt2015-01-182-3/+3 * Update to 1.4.99.5bapt2015-01-182-3/+3 * Release 1.4.5bapt2015-01-182-3/+3 * Extend the deadline while I work on a pkgng-aware rewrite.des2015-01-131-1/+1 * Mark ports-mgmt/portbuilder as depreciated.dbn2015-01-111-0/+3 * Remove expired ports:rene2015-01-0733-1410/+0 * Move MASTER_SITES from CRITICAL to LOCAL/ehauptehaupt2015-01-061-1/+1 * Update to 1.4.99.4bapt2015-01-022-3/+3 * Release 1.4.4bapt2015-01-022-3/+3 * Update to upstream version 3.2.0riggs2014-12-302-4/+4 * Update to 1.4.3 and 1.4.99.3bapt2014-12-304-6/+6 * ports-mgmt/portshaker: Support Subversion 1.7 or 1.8 depending on make.confpi2014-12-271-2/+6 * Update pkg to 1.4.2 and pkg-devel to 1.4.99.2:bapt2014-12-274-6/+6 * Update to 1.01gblach2014-12-262-4/+3 * - Add LICENSEsunpoet2014-12-261-0/+3 * Get rid of gnomehierbapt2014-12-231-2/+2 * Release pkg 1.4.1 and 1.4.99.1bapt2014-12-234-6/+6 * Remove useless USESbapt2014-12-221-2/+0 * cleanup plistbapt2014-12-212-3/+0 * Update to version 20141218pawel2014-12-202-3/+3 * - Deprecate and set expiration date to 2015-01-12: Does not support pkgngak2014-12-121-0/+3 * Disable Werror to calm down gccbapt2014-12-092-1/+2 * Update pkg to 1.4.0bapt2014-12-097-81/+7 * - Update to 3.1.1 which fixes pkg(8) crashing in 8.4 jails.bdrewery2014-12-094-8/+8 * Update to 1.4.0 rc3bapt2014-12-082-3/+3 * Update "BSD" license in ports-mgmt categoryfeld2014-12-072-2/+2 * Update "BSD" license.feld2014-12-071-1/+4 * Canonicalize a few licensesantoine2014-12-072-2/+2 * - Deprecate ports and set expiration date to 2015-01-06:ak2014-12-078-0/+24 * Allow building WITH_PKG=develantoine2014-12-062-2/+2 * Update to 1.4.0 rc2bapt2014-12-062-3/+3 * Remove expired port:rene2014-12-068-161/+0 * Update to 1.4.0 rc1bapt2014-12-062-3/+3 * - Resurrect ports-mgmt/pkg-plist, update to 1.4amdmi32014-12-064-0/+49 * Sort subdir listamdmi32014-12-061-1/+1 * Update to 3.1.0.bdrewery2014-12-046-64/+85 * - Update to 3.1.0bdrewery2014-12-042-4/+4 * - Update to 3.1-RC3bdrewery2014-12-022-4/+4 * Remove expired ports:rene2014-12-024-34/+0 * Mark a few ports BROKEN after GNOME 2 removalantoine2014-11-281-0/+2 * Change the way Perl modules are installed, update the default Perl to 5.18.mat2014-11-2616-45/+19 * Finally retire USE_PGSQLcrees2014-11-233-3/+3 * - Update to 20141117danilo2014-11-232-3/+3 * - Update to checkin e3445da which is 3.1-RC2bdrewery2014-11-202-4/+4 * The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.kwm2014-11-191-0/+2 * Cleanup the @dirrmbapt2014-11-191-7/+0 * Reroll the tarball I was mising some dfly only commits:bapt2014-11-191-2/+2 * Update to 1.4.0.b2bapt2014-11-192-3/+3 * Update to 1.4.0.b1bapt2014-11-182-3/+3 * - Update to checkin 7851588, which is 3.1-RC1bdrewery2014-11-182-4/+5 * - Update to checkin 8d28349bdrewery2014-11-182-4/+4 * Cleanup plistantoine2014-11-1314-147/+4 * Cleanup plistantoine2014-11-121-4/+1 * - update to 1.79dinoex2014-11-114-15/+45 * Remove unneeded @dir entriesbdrewery2014-11-071-6/+0 * - Deprecate and set expiration date to 2014-12-06: Does not work with tcl/tk ...ak2014-11-071-0/+3 * Deprecate.mat2014-11-051-0/+3 * Simplify plistbapt2014-10-311-3/+1 * Simplify plistbapt2014-10-311-4/+1 * Update to 1.4.0.a4bapt2014-10-302-3/+3 * ports-mgmt/portsearch: Update the distfile checksum after thevd2014-10-302-4/+4 * Fix segfault caused by passing a string literal pointer to mkstemp()shurd2014-10-302-2/+2 * Update to 1.4.0 alpha3:bapt2014-10-292-3/+3 * - new port pkgcompareohauer2014-10-295-0/+69 * Sorry I didn't checksum the right filebapt2014-10-291-2/+2 * Update to checkin d2f5c83bdrewery2014-10-292-4/+4 * Update to 1.4.0.alpha2bapt2014-10-292-3/+3 * Update to 2.16.1.marcus2014-10-282-7/+7 * ports-mgmt/porttools: upgrade to 1.03xmj2014-10-272-4/+5 * Update to pkg 1.4.0.alpha1bapt2014-10-272-3/+3 * Update to 2.16.0marcus2014-10-272-390/+136 * - Update to 20141022 [1]ak2014-10-242-4/+3 * Upgrade ports-mgmt/portsearch from 1.3.3 to 1.3.4vd2014-10-244-18/+16 * - Convert ports from german/, java/, japanese/ and ports-mgmt/ to newmva2014-10-207-13/+8 * Update port to version 0.5rodrigo2014-10-164-24/+7 * - Add dependency back for ruby-bdb for Ruby 2.0.bdrewery2014-10-132-8/+3 * Retire ports-mgmt/portaudit, it stopped working a month ago when pkg_toolsmat2014-10-1329-3116/+1 * Update to 1.4.0.pre-alpha16bapt2014-10-132-3/+3 * Update to 2.15.6.marcus2014-10-132-8/+10 * Update to 2.15.5.marcus2014-10-092-26/+81 * Remove @dirrm, @dirrmtryehaupt2014-10-081-5/+0 * Fix a regression that made some plist errors non fatalbapt2014-10-072-1/+32 * - Update to 1.17ak2014-10-072-3/+3 * - Update to 2.4.13bdrewery2014-10-075-39/+5 * - Plist fixes. No need for @exec and use @sample.bdrewery2014-10-072-5/+2 * - Update to checkin 2161660, which matches 2.4.13bdrewery2014-10-074-25/+6 * - Update to checkin caf0bb9bdrewery2014-09-273-23/+4 * Fix an important regresion preventing pkg2ng to work properlybapt2014-09-262-1/+15 * Add a way to work around the pkg2ng gate for now.bdrewery2014-09-261-1/+2 * - Fix crash when overriding repo configs.bdrewery2014-09-252-0/+29 * Hand back my ports to the pool.eadler2014-09-241-1/+1 * - Update to checkin 96b7698bdrewery2014-09-232-4/+4 * If not built with WITH_PKG=devel, depend on ports-mgmt/pkg. This will usebdrewery2014-09-231-2/+2 * Simplify plistbapt2014-09-221-41/+3 * Update to 1.3.8 Changes:bapt2014-09-223-11/+4 * - Update to checkin 4555dff [now a git hash]bdrewery2014-09-193-7/+11 * Add a minimal version testing for the installed pkg to enforce people to go t...bapt2014-09-181-0/+1 * Retire MANCOMPRESSED.mat2014-09-181-1/+0 * - Update to 3.0.19bdrewery2014-09-172-3/+3 * - Update to checkin d7e95d9102bdrewery2014-09-173-4/+6 * - Update to 3.0.18bdrewery2014-09-172-3/+3 * Update to 1.4.0-alpha15bapt2014-09-152-3/+3 * Allow staging as a regular userantoine2014-09-131-0/+1 * Update the default version of GCC in the Ports Collection from GCC 4.7.4gerald2014-09-11