aboutsummaryrefslogtreecommitdiffstats
path: root/misc/sword
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2012-07-01 11:46:01 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2012-07-01 11:46:01 +0800
commit5dc8c8b3081d56ba230a3770d0c96f4c832ae435 (patch)
treee6369bdd8ebdffc47516a4ec025bb08504d6df53 /misc/sword
parentc91d99ae2fff6b32cc212209bef4d2c5307405ed (diff)
downloadfreebsd-ports-gnome-5dc8c8b3081d56ba230a3770d0c96f4c832ae435.tar.gz
freebsd-ports-gnome-5dc8c8b3081d56ba230a3770d0c96f4c832ae435.tar.zst
freebsd-ports-gnome-5dc8c8b3081d56ba230a3770d0c96f4c832ae435.zip
- Depend on clucene for indexing, turned on by default
- Bump PORTREVISION PR: ports/169510 Submitted by: John Marshall <john.marshall riverwillow.com.au>
Diffstat (limited to 'misc/sword')
-rw-r--r--misc/sword/Makefile18
-rw-r--r--misc/sword/pkg-plist11
2 files changed, 26 insertions, 3 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index ed65b7636553..ca2996e246ba 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sword
PORTVERSION= 1.6.2
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= ftp://ftp.crosswire.org/pub/sword/source/v1.6/ \
http://crosswire.org/ftpmirror/pub/sword/source/v1.6/ \
@@ -26,15 +27,16 @@ USE_GNOME= pkgconfig
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake autoconf
-CONFIGURE_ARGS+= --without-conf --without-clucene --with-zlib --without-icu
+CONFIGURE_ARGS+= --without-conf --with-zlib
USE_LDCONFIG= yes
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST_SUB= PORTVERSION=${PORTVERSION}
-OPTIONS_DEFINE= CURL
-OPTIONS_DEFAULT=CURL
+OPTIONS_DEFINE= CURL CLUCENE
+CLUCENE_DESC= Include indexing capability
+OPTIONS_DEFAULT=CURL CLUCENE
.include <bsd.port.options.mk>
@@ -45,6 +47,16 @@ CONFIGURE_ARGS+= --with-curl
CONFIGURE_ARGS+= --without-curl
.endif
+.if ${PORT_OPTIONS:MCLUCENE}
+LIB_DEPENDS+= clucene:${PORTSDIR}/textproc/clucene \
+ icudata:${PORTSDIR}/devel/icu
+CONFIGURE_ARGS+= --with-clucene --with-icu
+PLIST_SUB+= ICU=""
+.else
+CONFIGURE_ARGS+= --without-clucene --without-icu
+PLIST_SUB+= ICU="@comment "
+.endif
+
run-autotools:: run-autotools-aclocal
post-patch:
diff --git a/misc/sword/pkg-plist b/misc/sword/pkg-plist
index c520debfd6e3..d3410be894b6 100644
--- a/misc/sword/pkg-plist
+++ b/misc/sword/pkg-plist
@@ -182,6 +182,16 @@ lib/libsword-%%PORTVERSION%%.so
lib/libsword.a
lib/libsword.la
lib/libsword.so
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_4.8.1.1/translit_Any_Latex.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_4.8.1.1/translit_Any_Latin1.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_4.8.1.1/translit_BETA_Greek.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_4.8.1.1/translit_BGreek_Greek.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_4.8.1.1/translit_CCAT_Hebrew.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_4.8.1.1/translit_CCAT_Syriac.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_4.8.1.1/translit_Latin_Coptic.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_4.8.1.1/translit_Latin_Gothic.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_4.8.1.1/translit_Latin_Ugaritic.res
+%%ICU%%lib/sword/%%PORTVERSION%%_icu_4.8.1.1/translit_swordindex.res
libdata/pkgconfig/sword.pc
%%DATADIR%%/locales.d/locales.conf
%%DATADIR%%/locales.d/abbr.conf
@@ -269,5 +279,6 @@ libdata/pkgconfig/sword.pc
@dirrm %%DATADIR%%/mods.d
@dirrm %%DATADIR%%/locales.d
@dirrm %%DATADIR%%
+%%ICU%%@dirrm lib/sword/%%PORTVERSION%%_icu_4.8.1.1
@dirrm lib/sword
@dirrm include/sword