aboutsummaryrefslogtreecommitdiffstats
path: root/misc/table.el
diff options
context:
space:
mode:
authoranray <anray@FreeBSD.org>2006-08-21 05:16:16 +0800
committeranray <anray@FreeBSD.org>2006-08-21 05:16:16 +0800
commit79eeeea0a8ea25d71aaf7ce2258c872342a18f27 (patch)
tree9dce5f88aef69e072aaee29e92814bea35273b76 /misc/table.el
parent0032b6b2b3879aa604ecc5ae9dd1ffe10434bd5a (diff)
downloadfreebsd-ports-gnome-79eeeea0a8ea25d71aaf7ce2258c872342a18f27.tar.gz
freebsd-ports-gnome-79eeeea0a8ea25d71aaf7ce2258c872342a18f27.tar.zst
freebsd-ports-gnome-79eeeea0a8ea25d71aaf7ce2258c872342a18f27.zip
Table.el is an Emacs lisp package that extends Emacs and provides text
based table creation and editing feature. With this package Emacs is capable of editing tables that are embedded inside a document, the feature similar to the ones seen in modern WYSIWYG word processors. A table is a rectangular text area consisting from a surrounding frame and content inside the frame. The content is usually subdivided into multiple rectangular cells, see the actual tables used below in this document. Once a table is recognized, editing operation inside a table cell is confined into that specific cell's rectangular area. This means that typing and deleting characters inside a cell do not affect any outside text but introduces appropriate formatting only to the cell contents. If necessary for accommodating added text in the cell, the cell automatically grows vertically and/or horizontally. WWW: http://table.sourceforge.net/ PR: ports/102323 Submitted by: Denis Shaposhnikov <dsh at vlink.ru>
Diffstat (limited to 'misc/table.el')
-rw-r--r--misc/table.el/Makefile38
-rw-r--r--misc/table.el/distinfo3
-rw-r--r--misc/table.el/pkg-descr15
-rw-r--r--misc/table.el/pkg-message7
-rw-r--r--misc/table.el/pkg-plist4
5 files changed, 67 insertions, 0 deletions
diff --git a/misc/table.el/Makefile b/misc/table.el/Makefile
new file mode 100644
index 000000000000..775c9e80851a
--- /dev/null
+++ b/misc/table.el/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: table.el
+# Date created: Sun Aug 20 14:17:25 MSD 2006
+# Whom: Denis Shaposhnikov <dsh@vlink.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= table.el
+PORTVERSION= 1.5.54
+CATEGORIES= misc elisp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= table
+DISTNAME= table-${PORTVERSION}.el.gz
+EXTRACT_SUFX= # empty
+
+MAINTAINER= dsh@vlink.ru
+COMMENT= Create and edit WYSIWYG text based embedded tables in Emacs
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+EMACSLISPDIR= ${TARGETDIR}/share/emacs/site-lisp
+XEMACSLISPDIR= ${TARGETDIR}/lib/xemacs/site-lisp
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${GUNZIP_CMD} -c ${DISTDIR}/${DISTNAME} > ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${EMACSLISPDIR}
+ ${MKDIR} ${XEMACSLISPDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME} ${EMACSLISPDIR}
+ ${LN} -sf ${EMACSLISPDIR}/${PORTNAME} ${XEMACSLISPDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/misc/table.el/distinfo b/misc/table.el/distinfo
new file mode 100644
index 000000000000..625097ba9cd4
--- /dev/null
+++ b/misc/table.el/distinfo
@@ -0,0 +1,3 @@
+MD5 (table-1.5.54.el.gz) = bf610808fa37ec0c6393e841d99defd9
+SHA256 (table-1.5.54.el.gz) = af7f3337e1dc517bcb9f5683103d5e32a34dcf311f1187a02660fc3642089cba
+SIZE (table-1.5.54.el.gz) = 58136
diff --git a/misc/table.el/pkg-descr b/misc/table.el/pkg-descr
new file mode 100644
index 000000000000..b24413bdde0b
--- /dev/null
+++ b/misc/table.el/pkg-descr
@@ -0,0 +1,15 @@
+Table.el is an Emacs lisp package that extends Emacs and provides text
+based table creation and editing feature. With this package Emacs is
+capable of editing tables that are embedded inside a document, the
+feature similar to the ones seen in modern WYSIWYG word processors. A
+table is a rectangular text area consisting from a surrounding frame
+and content inside the frame. The content is usually subdivided into
+multiple rectangular cells, see the actual tables used below in this
+document. Once a table is recognized, editing operation inside a table
+cell is confined into that specific cell's rectangular area. This
+means that typing and deleting characters inside a cell do not affect
+any outside text but introduces appropriate formatting only to the
+cell contents. If necessary for accommodating added text in the cell,
+the cell automatically grows vertically and/or horizontally.
+
+WWW: http://table.sourceforge.net/
diff --git a/misc/table.el/pkg-message b/misc/table.el/pkg-message
new file mode 100644
index 000000000000..83d9c350bd05
--- /dev/null
+++ b/misc/table.el/pkg-message
@@ -0,0 +1,7 @@
+
+To use table.el in Emacs/XEmacs, add the:
+
+ (require 'table)
+
+to your ~/.emacs or init.el
+
diff --git a/misc/table.el/pkg-plist b/misc/table.el/pkg-plist
new file mode 100644
index 000000000000..eb612adbb2a3
--- /dev/null
+++ b/misc/table.el/pkg-plist
@@ -0,0 +1,4 @@
+share/emacs/site-lisp/table.el
+lib/xemacs/site-lisp/table.el
+@dirrmtry lib/xemacs/site-lisp
+@dirrmtry lib/xemacs