aboutsummaryrefslogtreecommitdiffstats
path: root/misc/teseq/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-09-23 16:07:17 +0800
committermiwi <miwi@FreeBSD.org>2008-09-23 16:07:17 +0800
commit42fef89404b4a50c0b745fd7a5535f09547a7e46 (patch)
treea286dbb70ab40acc6ceccc8ef483e578071be5d1 /misc/teseq/Makefile
parent7eb132f4c7e5407526b05c088079175d355e84f4 (diff)
downloadfreebsd-ports-gnome-42fef89404b4a50c0b745fd7a5535f09547a7e46.tar.gz
freebsd-ports-gnome-42fef89404b4a50c0b745fd7a5535f09547a7e46.tar.zst
freebsd-ports-gnome-42fef89404b4a50c0b745fd7a5535f09547a7e46.zip
GNU Teseq is a tool for translating files that contain control
characters and terminal control sequences, into human-understandable text. It is intended to aid in debugging problems in terminal emulators, software that makes use of special terminal features, and interactions between the two. Teseq is primarily targeted at individuals who possess a basic understanding of terminal control sequences, especially CSI sequences; however, by default Teseq will try to identify and describe the sequences that it encounters, and the behavior they might produce in a terminal. Teseq describes control functions as they are interpreted by VT100-compatible terminals, and/or terminals compliant with the ECMA-48 / ISO/IEC 6429 standard. Teseq does _not_ support describing control functions according to terminal-specific definitions in a database such as termcap or terminfo, though future versions may include limited support for that (*note Future Enhancements::). Therefore, the descriptions Teseq uses for control functions may not necessarily match their actual interpretation by whatever terminal device the characters were actually intended for WWW: http://www.gnu.org/software/teseq/
Diffstat (limited to 'misc/teseq/Makefile')
-rw-r--r--misc/teseq/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/misc/teseq/Makefile b/misc/teseq/Makefile
new file mode 100644
index 000000000000..18bec87f91c8
--- /dev/null
+++ b/misc/teseq/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: teseq
+# Date created: 2008-09-17
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= teseq
+PORTVERSION= 1.0.0
+CATEGORIES= misc
+MASTER_SITES= GNU
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Terminal control sequence analyzer
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+INFO= teseq
+MAN1= reseq.1 teseq.1
+
+PLIST_FILES= bin/reseq bin/teseq \
+ libexec/teseq-post.sed
+
+.include <bsd.port.mk>