aboutsummaryrefslogtreecommitdiffstats
path: root/misc/tkrunit
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2011-10-18 21:06:37 +0800
committerehaupt <ehaupt@FreeBSD.org>2011-10-18 21:06:37 +0800
commit148af5e96409a8e54392a63c46d6ccb64e315995 (patch)
tree520b2fe186b418e80226c11a7e873ccdbfe37ed5 /misc/tkrunit
parente769e72dd706e1bdb6ec1f933c54c4662000d7d0 (diff)
downloadfreebsd-ports-gnome-148af5e96409a8e54392a63c46d6ccb64e315995.tar.gz
freebsd-ports-gnome-148af5e96409a8e54392a63c46d6ccb64e315995.tar.zst
freebsd-ports-gnome-148af5e96409a8e54392a63c46d6ccb64e315995.zip
- Support USE_TK_WRAPPER
- Support ECHO_MSG - Add WWW PR: 161622 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'misc/tkrunit')
-rw-r--r--misc/tkrunit/Makefile41
-rw-r--r--misc/tkrunit/files/patch-aa10
-rw-r--r--misc/tkrunit/pkg-descr2
-rw-r--r--misc/tkrunit/pkg-plist3
4 files changed, 26 insertions, 30 deletions
diff --git a/misc/tkrunit/Makefile b/misc/tkrunit/Makefile
index adf858c54240..0e315a5c127a 100644
--- a/misc/tkrunit/Makefile
+++ b/misc/tkrunit/Makefile
@@ -7,32 +7,39 @@
PORTNAME= tkRunIt
PORTVERSION= 0.94.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
-MASTER_SITES= http://thaumaturgy.net/~etgold/software/tkRunIt/
-DISTNAME= tkRunIt-0941
+MASTER_SITES= http://thaumaturgy.net/~etgold/software/tkRunIt/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
MAINTAINER= ports@FreeBSD.org
COMMENT= GUI app launcher with completion and history
-RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
+LICENSE= GPLv2
+WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
-post-extract:
- @(cd ${WRKDIR} ; ${MV} tkRunIt ${DISTNAME})
+USE_TK_WRAPPER= yes
+
+PORTEXAMPLES= ${PORTNAME:L}
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|/usr/local/bin|${PREFIX}/bin|' ${WRKSRC}/runit.tcl
do-install:
- @(cd ${WRKSRC} ; ${INSTALL_SCRIPT} runit.tcl ${PREFIX}/bin)
-
-post-install:
- @${ECHO} " "
- @${ECHO} "-------------------------------------------------------------------"
- @${ECHO} "===> Installing runitrc.sample in ${PREFIX}/share/examples/tkrunit"
- @${ECHO} "===> Copy runitrc.sample to ~/.runitrc and modify if you wish"
- @${ECHO} "-------------------------------------------------------------------"
- @${ECHO} " "
- @${MKDIR} ${PREFIX}/share/examples/tkrunit && ${CHMOD} a+rx ${PREFIX}/share/examples/tkrunit
- @${INSTALL_DATA} ${WRKSRC}/runitrc.sample ${PREFIX}/share/examples/tkrunit
+ ${INSTALL_SCRIPT} ${WRKSRC}/runit.tcl ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/runitrc.sample ${EXAMPLESDIR}/${PORTNAME:L}
+ @${ECHO_MSG} " "
+ @${ECHO_MSG} "-------------------------------------------------------------------"
+ @${ECHO_MSG} "===> Installing runitrc.sample in ${EXAMPLESDIR}/${PORTNAME:L}"
+ @${ECHO_MSG} "===> Copy runitrc.sample to ~/.runitrc and modify if you wish"
+ @${ECHO_MSG} "-------------------------------------------------------------------"
+ @${ECHO_MSG} " "
+.endif
.include <bsd.port.mk>
diff --git a/misc/tkrunit/files/patch-aa b/misc/tkrunit/files/patch-aa
deleted file mode 100644
index d9484f6adf27..000000000000
--- a/misc/tkrunit/files/patch-aa
+++ /dev/null
@@ -1,10 +0,0 @@
---- runit.tcl.bak Tue Apr 27 11:48:06 1999
-+++ runit.tcl Tue Apr 27 11:48:06 1999
-@@ -1,6 +1,6 @@
- #!/bin/sh
- # the next line restarts using wish \
-- exec wish "$0" "$@"
-+ exec wish8.2 "$0" "$@"
-
- #!/usr/local/bin/wish
- ## runit (tkRunIt) 12/4/98
diff --git a/misc/tkrunit/pkg-descr b/misc/tkrunit/pkg-descr
index 613eb0aaf865..970a14186677 100644
--- a/misc/tkrunit/pkg-descr
+++ b/misc/tkrunit/pkg-descr
@@ -4,3 +4,5 @@ but is designed to be completely navigable from the keyboard and
to allow extreme customizablility as I often find that personal
workspace tools/shortcuts are seldom workflow compatible across
users.
+
+WWW: http://thaumaturgy.net/~etgold/software/tkRunIt/
diff --git a/misc/tkrunit/pkg-plist b/misc/tkrunit/pkg-plist
deleted file mode 100644
index e0ca87223879..000000000000
--- a/misc/tkrunit/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/runit.tcl
-share/examples/tkrunit/runitrc.sample
-@dirrm share/examples/tkrunit