aboutsummaryrefslogtreecommitdiffstats
path: root/misc/xiphos
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2015-04-08 23:05:48 +0800
committerbapt <bapt@FreeBSD.org>2015-04-08 23:05:48 +0800
commit11557d3b1ca381824ecc50f020623ed56d4ce36a (patch)
tree81627af7b0f0c701d807cb8a4046a4740517b9f9 /misc/xiphos
parent1ed12c409b16770d2cb109c7a67bf65ef1a3f27b (diff)
downloadfreebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.tar.gz
freebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.tar.zst
freebsd-ports-gnome-11557d3b1ca381824ecc50f020623ed56d4ce36a.zip
Add a new USES=waf to handle the waf building system, allowing to factorise code
Plug waf into MAKE_CMD and CONFIGURE_CMD so the regular defined targets can be reused Always define _MAKE_JOBS so that when bsd.port.mk will stop overwritting _MAKE_JOBS when parallel jobs are disabled we can enforce -j1 (which is needed to really disable parallelisation with waf WAF_CMD has been created to allow one to override the location of the waf script relatively to WRKSRC CONFIGURE_TARGET is by default defined to "configure" ALL_TARGET is by default defined to "build" INSTALL_TARGET is by default defined to "install" USES=waf is by default stagedir safe
Diffstat (limited to 'misc/xiphos')
-rw-r--r--misc/xiphos/Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/misc/xiphos/Makefile b/misc/xiphos/Makefile
index f091f1d02ec1..a6434423a47b 100644
--- a/misc/xiphos/Makefile
+++ b/misc/xiphos/Makefile
@@ -20,23 +20,14 @@ LIB_DEPENDS= libwebkitgtk-3.0.so:${PORTSDIR}/www/webkit-gtk3 \
libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libsword.so:${PORTSDIR}/misc/sword
-USES= gettext pkgconfig python:build
+USES= gettext pkgconfig waf
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_GNOME= gnomeprefix gtkhtml4 intlhack gtk30 gconf2 libgsf
OPTIONS_DEFINE= DOCS
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./waf configure \
- --prefix=${PREFIX} --destdir=${STAGEDIR} \
- ${WAF_CONFIGURE_ARGS}
-
-do-build:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./waf build --prefix=${PREFIX} --destdir=${STAGEDIR}
-
-do-install:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./waf install --prefix=${PREFIX} --destdir=${STAGEDIR}
+post-install:
@${RM} ${STAGEDIR}${PREFIX}/share/icons/hicolor/icon-theme.cache
.include <bsd.port.mk>