aboutsummaryrefslogtreecommitdiffstats
path: root/misc/xosd/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-05-21 11:27:34 +0800
committerwill <will@FreeBSD.org>2001-05-21 11:27:34 +0800
commit93da2574f2a5a372c14e3ccfcd723b31727b49b5 (patch)
tree63ccd7eb49373e99cd38a0709e456e799e9cbc10 /misc/xosd/Makefile
parenta7936b7d66429335c7e4e56fe3cdf2a1634aedef (diff)
downloadfreebsd-ports-gnome-93da2574f2a5a372c14e3ccfcd723b31727b49b5.tar.gz
freebsd-ports-gnome-93da2574f2a5a372c14e3ccfcd723b31727b49b5.tar.zst
freebsd-ports-gnome-93da2574f2a5a372c14e3ccfcd723b31727b49b5.zip
Correct a few mistakes:
From MAINTAINER: 1) Add GTK/GLIB lib depends. 2) Fix building without xmms. 3) Install header file. 4) Correct xmms-config && gtk12-config paths. From will@: 5] Respect ${CC}. 6] Respect ${GLIB_CONFIG}. 7] Respect ${PTHREAD_[CFLAGS,LIBS]}. PR: 27479 Submitted by: maintainer
Diffstat (limited to 'misc/xosd/Makefile')
-rw-r--r--misc/xosd/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/misc/xosd/Makefile b/misc/xosd/Makefile
index b9f0e645a2bb..3f473fa542ce 100644
--- a/misc/xosd/Makefile
+++ b/misc/xosd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xosd
PORTVERSION= 0.7.0
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://www.ignavus.net/ \
http://www3.kr.freebsd.org/~perky/distfiles/
@@ -18,10 +19,17 @@ LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
LIB_DEPENDS+= xmms.1:${PORTSDIR}/audio/xmms
.endif
+XMMS_CONFIG?= ${X11BASE}/bin/xmms-config
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_GTK= yes
+USE_GLIB= yes
INSTALLS_SHLIB= yes
-MAKE_ENV= CFLAGS='${CFLAGS}' PREFIX='${PREFIX}'
+MAKE_ENV= CFLAGS='${CFLAGS}' PREFIX='${PREFIX}' \
+ X11BASE='${X11BASE}' LOCALBASE='${LOCALBASE}' \
+ GTK_CONFIG='${GTK_CONFIG}' GLIB_CONFIG="${GLIB_CONFIG}" \
+ XMMS_CONFIG="${XMMS_CONFIG}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
MAN1= osd_cat.1
MAN3= xosd.3
@@ -33,4 +41,7 @@ PLIST_SUB+= WITH_XMMS=""
PLIST_SUB+= WITH_XMMS="@comment "
.endif
+pre-build:
+ ${PERL} -pi -e "s@gcc@${CC}@g" ${WRKSRC}/Makefile
+
.include <bsd.port.mk>