aboutsummaryrefslogtreecommitdiffstats
path: root/misc/xosd
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-14 10:53:03 +0800
committersf <sf@FreeBSD.org>2003-07-14 10:53:03 +0800
commit971087c2b4d6b0b917e3fac3ac1334b04f7c9907 (patch)
tree7181a8316bbb1b7be4386d9173b3c6ace07025da /misc/xosd
parent0cc85c09b55a7d94ca1d7c16c8eedae091f2840c (diff)
downloadfreebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.tar.gz
freebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.tar.zst
freebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
Diffstat (limited to 'misc/xosd')
-rw-r--r--misc/xosd/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/misc/xosd/Makefile b/misc/xosd/Makefile
index bbdee3a3ca7f..528a8011b3a7 100644
--- a/misc/xosd/Makefile
+++ b/misc/xosd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xosd
PORTVERSION= 2.2.1
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://www.ignavus.net/ \
${MASTER_SITE_LOCAL}
@@ -15,20 +16,20 @@ MASTER_SITE_SUBDIR= perky
MAINTAINER= perky@FreeBSD.org
COMMENT= X On-Screen-Display Library and XMMS plug-in
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
- gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
.if !defined(WITHOUT_XMMS)
LIB_DEPENDS+= xmms.3:${PORTSDIR}/multimedia/xmms
.endif
XMMS_CONFIG?= ${X11BASE}/bin/xmms-config
+USE_GETOPT_LONG=yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gtk12
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-CONFIGURE_ENV= LIBS=${PTHREAD_LIBS}' -L${LOCALBASE}/lib -lgnugetopt' \
+CONFIGURE_ENV= LIBS=${PTHREAD_LIBS}' -L${LOCALBASE}/lib' \
CFLAGS='${CFLAGS}' X11BASE='${X11BASE}' \
GTK_CONFIG='${GTK_CONFIG}' GLIB_CONFIG='${GLIB_CONFIG}' \
XMMS_PLUGINDIR=${X11BASE}/lib/xmms