aboutsummaryrefslogtreecommitdiffstats
path: root/misc/yaucg/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-08-29 20:04:18 +0800
committerijliao <ijliao@FreeBSD.org>2001-08-29 20:04:18 +0800
commitbc395061dc94e894fe58d65fd95f28b6ab8ba2e6 (patch)
tree0db6a6ac7c522bff4b989759f98a84144ef777bc /misc/yaucg/Makefile
parent3278be211175ac1409913f1f71cf5e5fd7dccf9b (diff)
downloadfreebsd-ports-gnome-bc395061dc94e894fe58d65fd95f28b6ab8ba2e6.tar.gz
freebsd-ports-gnome-bc395061dc94e894fe58d65fd95f28b6ab8ba2e6.tar.zst
freebsd-ports-gnome-bc395061dc94e894fe58d65fd95f28b6ab8ba2e6.zip
add yaucg
A bash Script which will get you the today's Userfriendly.org Picture PR: 30093 Submitted by: Gea-Suan Lin <gslin@infomath.math.nctu.edu.tw>
Diffstat (limited to 'misc/yaucg/Makefile')
-rw-r--r--misc/yaucg/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/misc/yaucg/Makefile b/misc/yaucg/Makefile
new file mode 100644
index 000000000000..f23b1dfdd8fe
--- /dev/null
+++ b/misc/yaucg/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: yaucg
+# Date created: 26 August 2001
+# Whom: Gea-Suan Lin (gslin@ccca.nctu.edu.tw)
+#
+# $FreeBSD$
+#
+
+PORTNAME= yaucg
+PORTVERSION= 0.11
+CATEGORIES= misc
+MASTER_SITES= http://home.balcab.ch/joelle.wiesmann/secuserv/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= gslin@ccca.nctu.edu.tw
+
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget \
+ bash:${PORTSDIR}/shells/bash2
+
+NO_BUILD= yes
+STRIP= # empty
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/grepper/userfriendly.sh ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for FILE in changelog license readme todo
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>