aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2005-10-30 16:12:05 +0800
committerobrien <obrien@FreeBSD.org>2005-10-30 16:12:05 +0800
commit0cb7eb6e17cbc644eeeb6877b58e226b0e6a67d3 (patch)
tree23e6a10db8b6350541f1f7c29571eceb66baafdb /misc
parent6a4f750f89ac09fe513be46925ce1d6b429e8d11 (diff)
downloadfreebsd-ports-gnome-0cb7eb6e17cbc644eeeb6877b58e226b0e6a67d3.tar.gz
freebsd-ports-gnome-0cb7eb6e17cbc644eeeb6877b58e226b0e6a67d3.tar.zst
freebsd-ports-gnome-0cb7eb6e17cbc644eeeb6877b58e226b0e6a67d3.zip
eBay added multiple spaces in the layout. The bidwatcher parser stumbled
because the keywords didn't begin any longer at the first character of line. Obtained from: bidwatcher-devel Submitted by: Klaus Singvogel <sourceforge@si...>
Diffstat (limited to 'misc')
-rw-r--r--misc/bidwatcher/Makefile2
-rw-r--r--misc/bidwatcher/files/patch-helpers.cpp31
2 files changed, 17 insertions, 16 deletions
diff --git a/misc/bidwatcher/Makefile b/misc/bidwatcher/Makefile
index b0bc0b49413a..4a13d0b27b6a 100644
--- a/misc/bidwatcher/Makefile
+++ b/misc/bidwatcher/Makefile
@@ -8,7 +8,7 @@
PORTNAME= bidwatcher
PORTVERSION= 1.3.17
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/misc/bidwatcher/files/patch-helpers.cpp b/misc/bidwatcher/files/patch-helpers.cpp
index 5bbb998f1133..573308330f83 100644
--- a/misc/bidwatcher/files/patch-helpers.cpp
+++ b/misc/bidwatcher/files/patch-helpers.cpp
@@ -1,11 +1,5 @@
-Index: helpers.cpp
-===================================================================
-RCS file: /cvsroot/bidwatcher/bidwatcher/Attic/helpers.cpp,v
-retrieving revision 1.90.2.57
-retrieving revision 1.90.2.59
-diff -u -B -b -w -r1.90.2.57 -r1.90.2.59
---- helpers.cpp.orig 25 Feb 2005 13:47:37 -0000 1.90.2.57
-+++ helpers.cpp 11 Aug 2005 00:00:57 -0000 1.90.2.59
+--- helpers.cpp.orig Thu Feb 17 20:46:49 2005
++++ helpers.cpp Sun Oct 30 01:04:08 2005
@@ -54,7 +54,7 @@
const char * const CheckPrice="0123456789.$,"; // Characters allowed in a price
@@ -51,7 +45,7 @@ diff -u -B -b -w -r1.90.2.57 -r1.90.2.59
// strip the html tags
for (u = 0; u < buffLength; u++) {
c = stringToStrip[u];
-@@ -378,14 +393,37 @@
+@@ -378,19 +393,44 @@
stringToStrip[u+3] == '>') {
Buff[BuffIdx++] = '\n';
u+=2;
@@ -91,7 +85,14 @@ diff -u -B -b -w -r1.90.2.57 -r1.90.2.59
} else if (IncludeFlag==10) {
if ((BuffIdx > 0) && (c == ' ') &&
(Buff[BuffIdx-1] != ' ') &&
-@@ -735,11 +773,12 @@
+ (Buff[BuffIdx-1] != '\n'))
+ Buff[BuffIdx++] = ' ';
++ else if ((BuffIdx > 0) && (c == ' ') && (Buff[BuffIdx-1] != ' '))
++ continue; /* ignore -- crunch multiple spaces */
+ else if ((BuffIdx > 0) &&
+ (c == '\n') &&
+ (Buff[BuffIdx-1] != '\n'))
+@@ -736,11 +776,12 @@
else ops_type = auc_type;
// Watch the change, it's strNcmp now.
@@ -105,7 +106,7 @@ diff -u -B -b -w -r1.90.2.57 -r1.90.2.59
return 0;
-@@ -1030,7 +1069,7 @@
+@@ -1031,7 +1072,7 @@
}
}
@@ -114,7 +115,7 @@ diff -u -B -b -w -r1.90.2.57 -r1.90.2.59
int cnt;
int ended_early=0;
int auc_type=TYPE_EBAY;
-@@ -1065,23 +1104,44 @@
+@@ -1066,23 +1107,44 @@
* but that's not what I'm going to do right now.
* Thanks to Bob Beaty!
*/
@@ -164,7 +165,7 @@ diff -u -B -b -w -r1.90.2.57 -r1.90.2.59
StringBuffer streamBuff(Buff);
/* Skip everything before the start of auction data */
-@@ -1090,14 +1150,16 @@
+@@ -1091,14 +1153,16 @@
while(strstr(LineBuffer.buf(),"eBay")==NULL && streamBuff)
streamBuff.getline(LineBuffer.buf(), LineBuffer.size(), '\n');
@@ -185,7 +186,7 @@ diff -u -B -b -w -r1.90.2.57 -r1.90.2.59
streamBuff.getline(LineBuffer.buf(), LineBuffer.size(), '\n');
if ( strstr(LineBuffer.buf(),"Another buyer used Buy It Now to purchase the item immediately") == NULL ){
-@@ -1282,6 +1344,8 @@
+@@ -1283,6 +1347,8 @@
}
scratch = strstr(LineBuffer.buf(), ":");
@@ -194,7 +195,7 @@ diff -u -B -b -w -r1.90.2.57 -r1.90.2.59
//strcpy(LineBuffer.buf(),scratch);
parseprice2(scratch, this, FALSE);
if (!CurrentBid ) {
-@@ -1398,6 +1462,7 @@
+@@ -1399,6 +1465,7 @@
case 10: // seller id
case 18:
case 21: