aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-12-09 00:49:43 +0800
committerrakuco <rakuco@FreeBSD.org>2015-12-09 00:49:43 +0800
commit2447b762ada630bfd429c970df6b7dbdfeaf0a11 (patch)
tree344b6abf61ea06069f5de2c1cdcb8209791ac07e /misc
parent761533d12d1c53c68d9d0d582a3964731b76fb2c (diff)
downloadfreebsd-ports-gnome-2447b762ada630bfd429c970df6b7dbdfeaf0a11.tar.gz
freebsd-ports-gnome-2447b762ada630bfd429c970df6b7dbdfeaf0a11.tar.zst
freebsd-ports-gnome-2447b762ada630bfd429c970df6b7dbdfeaf0a11.zip
PyQt: Replace bsd.pyqt.mk with Uses/pyqt.mk.
In preparation for landing PyQt5 ports, generalize devel/py-qt4's bsd.pyqt.mk and make it a proper file in Uses/. Ports wishing to depend on PyQt4 ports can now do the following: USES= pyqt:4 USE_PYQT= foo bar_build baz_run Other changes include the renaming of the PYQT4_DIST variable to PYQT_DIST and the introduction of the PYQT_SIPDIR plist substitution variable. The rest of the contents of Uses/pyqt.mk are pretty much identical to what we had in bsd.pyqt.mk with additional processing of USE_PYQT. Even though this patch touches files in many different ports, the goal is for it to be a no-op from an end-user perspective (so that the basic infrastructure is landed before the other, riskier changes): no dependencies have been changed, PyQt/SIP/QScintilla have not been upgraded and the plists should remain exactly the same, since PYQT_SIPDIR currently contains the same value that used to be hardcoded in the plists. Huge thanks to Guido Falsi (madpilot@) for spearheading most of the work: he took the initiative to work on PyQt5 and sent D2910 to Phabricator with the original version of this patch. Tobias Berner (tcberner@gmail.com) later applied it to kde@'s experimental area51 repositories and did some more work on it.
Diffstat (limited to 'misc')
-rw-r--r--misc/py-qt4-demo/Makefile12
-rw-r--r--misc/py-qt4-doc/Makefile4
2 files changed, 8 insertions, 8 deletions
diff --git a/misc/py-qt4-demo/Makefile b/misc/py-qt4-demo/Makefile
index 8766fad650b7..f7834161dd6f 100644
--- a/misc/py-qt4-demo/Makefile
+++ b/misc/py-qt4-demo/Makefile
@@ -15,15 +15,15 @@ COMMENT= Python bindings for the Qt4 toolkit, Qt demo and examples
DISTINFO_FILE= ${PYQT4_DISTINFO_FILE}
-USES= python
+USES= python pyqt:4
EXAMPLESDIR= ${PREFIX}/share/examples/py-qt4
-.include "${.CURDIR}/../../devel/py-qt4/bsd.pyqt.mk"
-
-.for component in ${PYQT4_COMPONENTS:Ndemo}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}qt4-${component}>=0:${PORTSDIR}/${${component}_PORT}
-.endfor
+USE_PYQT= assistant_run core_run dbus_run dbussupport_run declarative_run \
+ designer_run designerplugin_run doc_run gui_run help_run \
+ multimedia_run network_run opengl_run phonon_run qscintilla2_run \
+ script_run scripttools_run sql_run svg_run test_run webkit_run xml_run \
+ xmlpatterns_run sip_run qscintilla2_run
do-build:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/examples
diff --git a/misc/py-qt4-doc/Makefile b/misc/py-qt4-doc/Makefile
index 7e8fc69ffb42..162865a9e25a 100644
--- a/misc/py-qt4-doc/Makefile
+++ b/misc/py-qt4-doc/Makefile
@@ -15,7 +15,8 @@ COMMENT= Python bindings for the Qt4 toolkit, documentation
DISTINFO_FILE= ${PYQT4_DISTINFO_FILE}
NO_BUILD= yes
-USES= python
+USES= python pyqt:4
+USE_PYQT= #
DOCSDIR= ${PREFIX}/share/doc/py-qt4
@@ -29,5 +30,4 @@ do-install:
${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR}
-.include "../../devel/py-qt4/bsd.pyqt.mk"
.include <bsd.port.mk>