aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-03-08 16:04:10 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-03-08 16:04:10 +0800
commit293b4b20649244406813c811cab80157f449e734 (patch)
tree7e4a0064fdcdc66000791a7845755050f6c92c45 /misc
parent2ca12b7ec0b6410bd0f9c1668039d54a00f1c4fb (diff)
downloadfreebsd-ports-gnome-293b4b20649244406813c811cab80157f449e734.tar.gz
freebsd-ports-gnome-293b4b20649244406813c811cab80157f449e734.tar.zst
freebsd-ports-gnome-293b4b20649244406813c811cab80157f449e734.zip
- Fix build with curl 7.24.0: curl/types.h was removed (unused since Apr 2004)
Submitted by: sunpoet (myself) Tested by: exp-run by linimon Approved by: linimon (with portmgr hat)
Diffstat (limited to 'misc')
-rw-r--r--misc/esniper/Makefile3
-rw-r--r--misc/gkrellm-helium/Makefile1
-rw-r--r--misc/sword/Makefile2
3 files changed, 6 insertions, 0 deletions
diff --git a/misc/esniper/Makefile b/misc/esniper/Makefile
index 6d0622559066..11c9afa93e41 100644
--- a/misc/esniper/Makefile
+++ b/misc/esniper/Makefile
@@ -25,6 +25,9 @@ PLIST_FILES= bin/esniper
PORTEXAMPLES= sample_auction.txt sample_config.txt
+post-patch:
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/http.c
+
post-install:
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
diff --git a/misc/gkrellm-helium/Makefile b/misc/gkrellm-helium/Makefile
index d818a6d5d114..df964a385ed9 100644
--- a/misc/gkrellm-helium/Makefile
+++ b/misc/gkrellm-helium/Makefile
@@ -28,5 +28,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/lib/gkrellm2/plugins|${PREFIX}/libexec/gkrellm2/plugins| ; \
s|CFLAGS =|CFLAGS?=| ; s|-lcurl|-lcurl -L${LOCALBASE}/lib|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|ulong|u_long|' ${WRKSRC}/*.c
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' ${WRKSRC}/http_net.c
.include <bsd.port.mk>
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index 749ac5265ca4..6f9807fccf9c 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -51,6 +51,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|:=|=|' ${WRKSRC}/Makefile.am \
${WRKSRC}/Makefile.in ${WRKSRC}/lib/Makefile.am \
${WRKSRC}/lib/Makefile.in
+ @${REINPLACE_CMD} -e '/<curl\/types.h>/d' \
+ ${WRKSRC}/src/mgr/curlhttpt.cpp ${WRKSRC}/src/mgr/curlftpt.cpp
post-install:
@${MKDIR} ${PREFIX}/share/sword/mods.d