aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-04-22 01:42:56 +0800
committermiwi <miwi@FreeBSD.org>2007-04-22 01:42:56 +0800
commit2d5459a5f4d8d3320deb0eb97cc37e7da18e397b (patch)
treef7af6061d1b935d4086f9aa0900aab9a55377d1b /misc
parent14e93d85d9817b4d6847d09fcbe0ec6bfc712a0d (diff)
downloadfreebsd-ports-gnome-2d5459a5f4d8d3320deb0eb97cc37e7da18e397b.tar.gz
freebsd-ports-gnome-2d5459a5f4d8d3320deb0eb97cc37e7da18e397b.tar.zst
freebsd-ports-gnome-2d5459a5f4d8d3320deb0eb97cc37e7da18e397b.zip
- Unbreak
- Fix build with HEAD PR: 111976 Submitted by: Thomas Abthorpe <thomas@goodking.ca>
Diffstat (limited to 'misc')
-rw-r--r--misc/sword/Makefile14
-rw-r--r--misc/sword15/Makefile14
2 files changed, 8 insertions, 20 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index 423947ad1230..56259faed6ea 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -21,17 +21,11 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake:19
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS+= --without-conf --without-clucene
+CONFIGURE_ARGS+= --without-conf --without-lucene
USE_LDCONFIG= yes
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-
-.if ( ${OSVERSION} >= 700000 )
-BROKEN= does not build on 7.X
-.endif
-
.if defined(WITHOUT_CURL)
CONFIGURE_ARGS+= --without-curl
PLIST_SUB+= INSTALLMGR="@comment "
@@ -51,7 +45,7 @@ post-patch:
post-install:
@${MKDIR} ${PREFIX}/share/sword/mods.d
.if !exists(${PREFIX}/etc/sword.conf)
- @(cd ${WRKSRC} && make install_config)
+ @(cd ${WRKSRC} && ${GMAKE} install_config)
.else
@${ECHO_CMD} "Config file not installed since ${PREFIX}/etc/sword.conf already exists."
@${ECHO_CMD} "Please check that DataPath points to your modules (default ${DATADIR}).";
@@ -60,6 +54,6 @@ post-install:
@${CAT} ${PKGMESSAGE}
register:
- @(cd ${WRKSRC} && make register)
+ @(cd ${WRKSRC} && ${GMAKE} register)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/sword15/Makefile b/misc/sword15/Makefile
index 423947ad1230..56259faed6ea 100644
--- a/misc/sword15/Makefile
+++ b/misc/sword15/Makefile
@@ -21,17 +21,11 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake:19
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS+= --without-conf --without-clucene
+CONFIGURE_ARGS+= --without-conf --without-lucene
USE_LDCONFIG= yes
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-
-.if ( ${OSVERSION} >= 700000 )
-BROKEN= does not build on 7.X
-.endif
-
.if defined(WITHOUT_CURL)
CONFIGURE_ARGS+= --without-curl
PLIST_SUB+= INSTALLMGR="@comment "
@@ -51,7 +45,7 @@ post-patch:
post-install:
@${MKDIR} ${PREFIX}/share/sword/mods.d
.if !exists(${PREFIX}/etc/sword.conf)
- @(cd ${WRKSRC} && make install_config)
+ @(cd ${WRKSRC} && ${GMAKE} install_config)
.else
@${ECHO_CMD} "Config file not installed since ${PREFIX}/etc/sword.conf already exists."
@${ECHO_CMD} "Please check that DataPath points to your modules (default ${DATADIR}).";
@@ -60,6 +54,6 @@ post-install:
@${CAT} ${PKGMESSAGE}
register:
- @(cd ${WRKSRC} && make register)
+ @(cd ${WRKSRC} && ${GMAKE} register)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>