aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorromain <romain@FreeBSD.org>2010-06-02 09:53:28 +0800
committerromain <romain@FreeBSD.org>2010-06-02 09:53:28 +0800
commit60f457233855fbbf1291fd35bd7863ed811aeaa6 (patch)
tree0ab820f42d6a0de03013feeea78cdeab753dfa8d /misc
parent1fe9023c147e7fb4be4cc6c86842d3275da7b771 (diff)
downloadfreebsd-ports-gnome-60f457233855fbbf1291fd35bd7863ed811aeaa6.tar.gz
freebsd-ports-gnome-60f457233855fbbf1291fd35bd7863ed811aeaa6.tar.zst
freebsd-ports-gnome-60f457233855fbbf1291fd35bd7863ed811aeaa6.zip
ipod-sharp is a library that allows manipulation of the iTunesDB used in Apple
iPod devices.
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/ipod-sharp/Makefile26
-rw-r--r--misc/ipod-sharp/distinfo3
-rw-r--r--misc/ipod-sharp/pkg-descr2
-rw-r--r--misc/ipod-sharp/pkg-plist13
5 files changed, 45 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 85fe6063d62d..1708639d01a1 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -189,6 +189,7 @@
SUBDIR += instant-server
SUBDIR += ipa_conv
SUBDIR += ipbt
+ SUBDIR += ipod-sharp
SUBDIR += iselect
SUBDIR += iso-codes
SUBDIR += jargon
diff --git a/misc/ipod-sharp/Makefile b/misc/ipod-sharp/Makefile
new file mode 100644
index 000000000000..493f1a6a7aab
--- /dev/null
+++ b/misc/ipod-sharp/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ipod-sharp
+# Date created: 2008-07-09
+# Whom: Romain Tartiere <romain@blogreen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipod-sharp
+PORTVERSION= 0.8.5
+CATEGORIES= misc
+MASTER_SITES= http://download.banshee-project.org/${PORTNAME}/${PORTVERSION}/
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= Manipulate iTunesDB used in Apple iPod devices
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/podsleuth.pc:${PORTSDIR}/misc/podsleuth \
+ ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/podsleuth.pc:${PORTSDIR}/misc/podsleuth \
+ ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gtksharp20
+
+.include <bsd.port.mk>
diff --git a/misc/ipod-sharp/distinfo b/misc/ipod-sharp/distinfo
new file mode 100644
index 000000000000..ee99263c1b40
--- /dev/null
+++ b/misc/ipod-sharp/distinfo
@@ -0,0 +1,3 @@
+MD5 (ipod-sharp-0.8.5.tar.bz2) = fb7f53f64d825847d578a637cd48dd41
+SHA256 (ipod-sharp-0.8.5.tar.bz2) = 7c5b02872c75a7d61662e266e6f7a2a1aae14f71d9820a59faef2813dcd825fd
+SIZE (ipod-sharp-0.8.5.tar.bz2) = 154042
diff --git a/misc/ipod-sharp/pkg-descr b/misc/ipod-sharp/pkg-descr
new file mode 100644
index 000000000000..1c7a5c50446c
--- /dev/null
+++ b/misc/ipod-sharp/pkg-descr
@@ -0,0 +1,2 @@
+ipod-sharp is a library that allows manipulation of the iTunesDB used in Apple
+iPod devices.
diff --git a/misc/ipod-sharp/pkg-plist b/misc/ipod-sharp/pkg-plist
new file mode 100644
index 000000000000..656b664c8ee3
--- /dev/null
+++ b/misc/ipod-sharp/pkg-plist
@@ -0,0 +1,13 @@
+@comment $FreeBSD$
+lib/ipod-sharp/ipod-sharp-firmware.dll
+lib/ipod-sharp/ipod-sharp-firmware.dll.mdb
+lib/ipod-sharp/ipod-sharp-ui.dll
+lib/ipod-sharp/ipod-sharp-ui.dll.mdb
+lib/ipod-sharp/ipod-sharp.dll
+lib/ipod-sharp/ipod-sharp.dll.mdb
+lib/monodoc/sources/ipod-sharp-docs.source
+lib/monodoc/sources/ipod-sharp-docs.tree
+lib/monodoc/sources/ipod-sharp-docs.zip
+libdata/pkgconfig/ipod-sharp-ui.pc
+libdata/pkgconfig/ipod-sharp.pc
+@dirrmtry lib/ipod-sharp