aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-31 10:25:18 +0800
committerwill <will@FreeBSD.org>2001-03-31 10:25:18 +0800
commit6d0995f8f3bb43ef4e80108c3f33eeb766c4eb4f (patch)
tree482f1bd173a4ee61ada70d0ced5bd3a692d6cb76 /misc
parent0da488ef70ec4b36f620684f234f3d6a91998c9a (diff)
downloadfreebsd-ports-gnome-6d0995f8f3bb43ef4e80108c3f33eeb766c4eb4f.tar.gz
freebsd-ports-gnome-6d0995f8f3bb43ef4e80108c3f33eeb766c4eb4f.tar.zst
freebsd-ports-gnome-6d0995f8f3bb43ef4e80108c3f33eeb766c4eb4f.zip
Add mango 0.3, a recipe management software. Also the first port to
take advantage of -lqtgl provided by the newest QT2.3.0 port. PR: 26029 Submitted by: Roland Jesse <jesse@cs.uni-magdeburg.de>
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/mango/Makefile30
-rw-r--r--misc/mango/distinfo1
-rw-r--r--misc/mango/pkg-comment1
-rw-r--r--misc/mango/pkg-descr8
-rw-r--r--misc/mango/pkg-plist1
6 files changed, 42 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index f9593efe0e42..e74ed920e028 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -93,6 +93,7 @@
SUBDIR += lv
SUBDIR += magicpoint
SUBDIR += man.el
+ SUBDIR += mango
SUBDIR += matrix-kmod
SUBDIR += mc
SUBDIR += metatheme
diff --git a/misc/mango/Makefile b/misc/mango/Makefile
new file mode 100644
index 000000000000..8508dee3c94c
--- /dev/null
+++ b/misc/mango/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mango
+# Date created: 23 March 2001
+# Whom: Roland Jesse <jesse@cs.uni-magdeburg.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mango
+PORTVERSION= 0.3
+CATEGORIES= misc
+MASTER_SITES= ftp://mango.sourceforge.net/pub/mango/
+
+MAINTAINER= jesse@cs.uni-magdeburg.de
+
+BUILD_DEPENDS= tmake:${PORTSDIR}/devel/tmake
+
+USE_BZIP2= yes
+USE_QT2= yes
+TMAKEENV= TMAKEPATH=${PREFIX}/share/tmake/freebsd-g++ QTDIR=${X11BASE}
+MAKE_ENV+= QTDIR=${X11BASE}
+
+do-build:
+ (cd ${WRKSRC}; ${SETENV} ${TMAKEENV} tmake -o Makefile mango.pro)
+ (${PERL} -pi.orig -e "s@-lqt2@-lqtgl@g" ${WRKSRC}/Makefile)
+ (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/mango ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/misc/mango/distinfo b/misc/mango/distinfo
new file mode 100644
index 000000000000..2f5fef8c5169
--- /dev/null
+++ b/misc/mango/distinfo
@@ -0,0 +1 @@
+MD5 (mango-0.3.tar.bz2) = ac9cb32f5174890552e4711065890f1d
diff --git a/misc/mango/pkg-comment b/misc/mango/pkg-comment
new file mode 100644
index 000000000000..7571c4dd8b5d
--- /dev/null
+++ b/misc/mango/pkg-comment
@@ -0,0 +1 @@
+A recipe management software
diff --git a/misc/mango/pkg-descr b/misc/mango/pkg-descr
new file mode 100644
index 000000000000..bf55d9db3dac
--- /dev/null
+++ b/misc/mango/pkg-descr
@@ -0,0 +1,8 @@
+Mango is a recipe management software. The main motivation of the
+project is to provide a mealmaster compatible application for UNIX and
+similar systems.
+
+WWW: http://mango.sourceforge.net/
+
+- Roland
+jesse@cs.uni-magdeburg.de
diff --git a/misc/mango/pkg-plist b/misc/mango/pkg-plist
new file mode 100644
index 000000000000..c99d254f3aa8
--- /dev/null
+++ b/misc/mango/pkg-plist
@@ -0,0 +1 @@
+bin/mango