aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-08-31 05:24:54 +0800
committermiwi <miwi@FreeBSD.org>2008-08-31 05:24:54 +0800
commit727b871d8376b9667261f59740617612a83659ac (patch)
tree59bbb8f01d7013fd3d96b788c3fad5bccd31a25c /misc
parente6da5add604263bbf70ef1e4258309806ef5f76a (diff)
downloadfreebsd-ports-gnome-727b871d8376b9667261f59740617612a83659ac.tar.gz
freebsd-ports-gnome-727b871d8376b9667261f59740617612a83659ac.tar.zst
freebsd-ports-gnome-727b871d8376b9667261f59740617612a83659ac.zip
Ruby/ProgressBar is a text progress bar library for Ruby.
It can indicate progress with percentage, a progress bar, and estimated remaining time. WWW: http://0xcc.net/ruby-progressbar/index.html.en PR: ports/126885 Submitted by: TAKATSU Tomonari <tota at rtfm.jp>
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/ruby-progressbar/Makefile31
-rw-r--r--misc/ruby-progressbar/distinfo3
-rw-r--r--misc/ruby-progressbar/pkg-descr5
-rw-r--r--misc/ruby-progressbar/pkg-plist5
5 files changed, 45 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 149d47cb470a..635359e057d7 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -476,6 +476,7 @@
SUBDIR += rname
SUBDIR += rpl
SUBDIR += rtfm
+ SUBDIR += ruby-progressbar
SUBDIR += ruby-vpim
SUBDIR += salias
SUBDIR += seq2
diff --git a/misc/ruby-progressbar/Makefile b/misc/ruby-progressbar/Makefile
new file mode 100644
index 000000000000..dac5666c9e00
--- /dev/null
+++ b/misc/ruby-progressbar/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ruby-progressbar
+# Date created: 2008-08-25
+# Whom: TAKATSU Tomonari <tota@rtfm.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= progressbar
+PORTVERSION= 0.9
+CATEGORIES= misc ruby
+MASTER_SITES= http://0xcc.net/ruby-progressbar/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= tota@rtfm.jp
+COMMENT= A text progress bar library for Ruby
+
+USE_RUBY= yes
+NO_BUILD= yes
+
+RUBY_RD_FILES= progressbar.en.rd progressbar.ja.rd
+DOCS= ChangeLog ${RUBY_RD_FILES}
+
+do-install:
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/${PORTNAME}.rb ${RUBY_SITELIBDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+ cd ${INSTALL_WRKSRC}; ${INSTALL_DATA} ${DOCS} ${RUBY_MODDOCDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/ruby-progressbar/distinfo b/misc/ruby-progressbar/distinfo
new file mode 100644
index 000000000000..b537518e5b70
--- /dev/null
+++ b/misc/ruby-progressbar/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby-progressbar-0.9.tar.gz) = c3bf66edc5af8760bb1468a55746335e
+SHA256 (ruby-progressbar-0.9.tar.gz) = f2ea4a03fafdfc55ac52e84664167a288ee63f80591392e89fe8925024110551
+SIZE (ruby-progressbar-0.9.tar.gz) = 5580
diff --git a/misc/ruby-progressbar/pkg-descr b/misc/ruby-progressbar/pkg-descr
new file mode 100644
index 000000000000..4589271505a0
--- /dev/null
+++ b/misc/ruby-progressbar/pkg-descr
@@ -0,0 +1,5 @@
+Ruby/ProgressBar is a text progress bar library for Ruby.
+It can indicate progress with percentage, a progress bar,
+and estimated remaining time.
+
+WWW: http://0xcc.net/ruby-progressbar/index.html.en
diff --git a/misc/ruby-progressbar/pkg-plist b/misc/ruby-progressbar/pkg-plist
new file mode 100644
index 000000000000..e5589158202a
--- /dev/null
+++ b/misc/ruby-progressbar/pkg-plist
@@ -0,0 +1,5 @@
+%%RUBY_SITELIBDIR%%/progressbar.rb
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/progressbar.en.rd
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/progressbar.ja.rd
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%