aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>1999-08-28 06:44:44 +0800
committercpiazza <cpiazza@FreeBSD.org>1999-08-28 06:44:44 +0800
commit7806d3c3f599e10248de2e3ee0c58240edbbb545 (patch)
treef7b5010fe8f095c948fa0394036d9dbfb189d925 /misc
parent1e5d52c1c8940883acc1336ab1a10a233260b10b (diff)
downloadfreebsd-ports-gnome-7806d3c3f599e10248de2e3ee0c58240edbbb545.tar.gz
freebsd-ports-gnome-7806d3c3f599e10248de2e3ee0c58240edbbb545.tar.zst
freebsd-ports-gnome-7806d3c3f599e10248de2e3ee0c58240edbbb545.zip
Import of ezload.
EZLOAD allows you to download firmware into and upload firmware from the memory of a EZ-USB chip. An example program for the ActiveWire board is included, including the Hex file with firmware for it. (http://www.ActiveWireInc.com/).. PR: 13424 Submitted by: n_hibma
Diffstat (limited to 'misc')
-rw-r--r--misc/ezload/Makefile26
-rw-r--r--misc/ezload/distinfo1
-rw-r--r--misc/ezload/pkg-comment1
-rw-r--r--misc/ezload/pkg-descr15
-rw-r--r--misc/ezload/pkg-plist3
5 files changed, 46 insertions, 0 deletions
diff --git a/misc/ezload/Makefile b/misc/ezload/Makefile
new file mode 100644
index 000000000000..9e9fa49a7578
--- /dev/null
+++ b/misc/ezload/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: oneko
+# Version required: 0.1
+# Date created: 14 august 1999
+# Whom: n_hibma
+#
+# $FreeBSD$
+#
+
+DISTNAME= ezload-0.1
+CATEGORIES= misc
+MASTER_SITES= http://www.etla.net/~n_hibma/usb/
+
+MAINTAINER= n_hibma@FreeBSD.ORG
+
+MAN8= ezupload.8 ezdownload.8 aw.8
+MANCOMPRESSED= yes
+
+MAKE_ENV= BINDIR=${PREFIX}/bin MANDIR=${PREFIX}/man/man
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400000
+IGNORE= 'This port only works on 4.x+'
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/ezload/distinfo b/misc/ezload/distinfo
new file mode 100644
index 000000000000..15789d3de927
--- /dev/null
+++ b/misc/ezload/distinfo
@@ -0,0 +1 @@
+MD5 (ezload-0.1.tar.gz) = e936ef6df4295d08b6ef937c63c9f00e
diff --git a/misc/ezload/pkg-comment b/misc/ezload/pkg-comment
new file mode 100644
index 000000000000..da9524afb5ba
--- /dev/null
+++ b/misc/ezload/pkg-comment
@@ -0,0 +1 @@
+Down-/uploader for AnchorChip's EZ-USB chip
diff --git a/misc/ezload/pkg-descr b/misc/ezload/pkg-descr
new file mode 100644
index 000000000000..13496a00e1b3
--- /dev/null
+++ b/misc/ezload/pkg-descr
@@ -0,0 +1,15 @@
+The utility allows you to download firmware into and upload firmware from the
+memory of a EZ-USB chip.
+
+The chip is a generic 8051 based programmeble device. To function in a specific
+device, e.g. a USB to Parallel port convertor, the 8051 needs application
+specific 8051 firmware code.
+
+The input file or the produced output file is in Intel Hex format.
+
+An example program for the ActiveWire board is included, including the
+Hex file with firmware for it. The board is available from
+
+ http://www.ActiveWireInc.com/
+
+- Nick Hibma (n_hibma@freebsd.org) and Dirk van Gulik (dirkx@webweaving.org)
diff --git a/misc/ezload/pkg-plist b/misc/ezload/pkg-plist
new file mode 100644
index 000000000000..dfad9c41caac
--- /dev/null
+++ b/misc/ezload/pkg-plist
@@ -0,0 +1,3 @@
+bin/ezdownload
+bin/ezupload
+bin/aw