aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2005-09-17 00:30:21 +0800
committercy <cy@FreeBSD.org>2005-09-17 00:30:21 +0800
commit8950dfb31f838573b7152dabf160481003722023 (patch)
tree59e09cfa72bd710fb001d7dc36361d9ee2b2404a /misc
parentf465d86094353b722c6ea66b64c6cbb95dea12fc (diff)
downloadfreebsd-ports-gnome-8950dfb31f838573b7152dabf160481003722023.tar.gz
freebsd-ports-gnome-8950dfb31f838573b7152dabf160481003722023.tar.zst
freebsd-ports-gnome-8950dfb31f838573b7152dabf160481003722023.zip
Add support for 256 colour Xterm.
PR: 81285 Submitted by: Jeremy Chadwick <freebsd@jdc.parodius.com>
Diffstat (limited to 'misc')
-rw-r--r--misc/screen/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/misc/screen/Makefile b/misc/screen/Makefile
index e41d43849771..64db128c44a2 100644
--- a/misc/screen/Makefile
+++ b/misc/screen/Makefile
@@ -7,7 +7,7 @@
PORTNAME= screen
PORTVERSION= 4.0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= ftp://ftp.uni-erlangen.de/pub/utilities/screen/ \
${MASTER_SITE_GNU}
@@ -28,6 +28,14 @@ NO_PACKAGE= Tends to loop using 100% CPU when used from package - perhaps it har
CFLAGS+= -O0
.endif
+# Enables support for 256 colour xterm. Note that you may need to
+# set up a custom termcap entry or .screenrc which modifies termcap
+# to contain the following: Co#256:AB=\E[48;5;%dm:AF=\E[38;5;%dm
+#
+.if defined(WITH_XTERM_256)
+CFLAGS+= -DCOLORS256
+.endif
+
.if defined(WITHOUT_NETHACK)
CFLAGS+= -DNONETHACK
.endif