aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-08-12 06:49:53 +0800
committerpav <pav@FreeBSD.org>2004-08-12 06:49:53 +0800
commitbf0e26f61137d01ee046afa7913bdd372715bb66 (patch)
treeb4691f064b44e83249c75197dcbc691a95b60476 /misc
parent35f7aefa97c0bb73e1417ad280dd15ceffcb71ff (diff)
downloadfreebsd-ports-gnome-bf0e26f61137d01ee046afa7913bdd372715bb66.tar.gz
freebsd-ports-gnome-bf0e26f61137d01ee046afa7913bdd372715bb66.tar.zst
freebsd-ports-gnome-bf0e26f61137d01ee046afa7913bdd372715bb66.zip
- update DESTDIR / PREFIX / pkg-plist and unbreak this port
PR: ports/69516 Submitted by: Yen-Ming Lee <leeym@utopia.leeym.com> Approved by: maintainer timeout (18 days)
Diffstat (limited to 'misc')
-rw-r--r--misc/matrix-kmod/Makefile15
-rw-r--r--misc/matrix-kmod/files/matrix_saver.sh22
-rw-r--r--misc/matrix-kmod/pkg-plist6
3 files changed, 32 insertions, 11 deletions
diff --git a/misc/matrix-kmod/Makefile b/misc/matrix-kmod/Makefile
index 85596c834fa6..2aaeff2f3010 100644
--- a/misc/matrix-kmod/Makefile
+++ b/misc/matrix-kmod/Makefile
@@ -7,14 +7,15 @@
PORTNAME= matrix
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://www.belousov.com/download/
PKGNAMESUFFIX= -kmod
-MAINTAINER= strijar@urai.ru
+MAINTAINER= strijar@urai.ru
COMMENT= Screensaver for console (matrix_saver.ko) "Matrix" like
-MAKE_ENV= DESTDIR="${PREFIX}/lib/matrix"
+KMODDIR= ${PREFIX}/modules
.include <bsd.port.pre.mk>
@@ -22,11 +23,9 @@ MAKE_ENV= DESTDIR="${PREFIX}/lib/matrix"
BROKEN= "Need FreeBSD 4.0 or above"
.endif
-.if ${OSVERSION} >= 500113
-BROKEN= "Installation fails"
-.endif
-
-pre-install:
- ${MKDIR} ${PREFIX}/lib/matrix/modules
+do-install:
+ @${MKDIR} ${KMODDIR}
+ ${INSTALL_SCRIPT} ${FILESDIR}/matrix_saver.sh ${PREFIX}/etc/rc.d
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.ko ${KMODDIR}
.include <bsd.port.post.mk>
diff --git a/misc/matrix-kmod/files/matrix_saver.sh b/misc/matrix-kmod/files/matrix_saver.sh
new file mode 100644
index 000000000000..0665113cdb02
--- /dev/null
+++ b/misc/matrix-kmod/files/matrix_saver.sh
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ if [ -x ${PREFIX}/modules/matrix_saver.ko ]; then
+ echo -n ' matrix_saver'
+ kldload ${PREFIX}/modules/matrix_saver.ko
+ fi
+ ;;
+stop)
+ kldunload -v -n matrix_saver && echo -n ' matrix_saver'
+ ;;
+*)
+ echo "Usage: $0 {start|stop}" >&2
+ exit 1
+ ;;
+esac
diff --git a/misc/matrix-kmod/pkg-plist b/misc/matrix-kmod/pkg-plist
index 511fc2cafb1f..1f6b26e5877d 100644
--- a/misc/matrix-kmod/pkg-plist
+++ b/misc/matrix-kmod/pkg-plist
@@ -1,3 +1,3 @@
-lib/matrix/modules/matrix_saver.ko
-@dirrm lib/matrix/modules
-@dirrm lib/matrix
+etc/rc.d/matrix_saver.sh
+modules/matrix_saver.ko
+@unexec rmdir -p %D/modules 2>/dev/null || true
559672d0cb06aeaac9e0'>Fix bogus ui files in preparation for Qt 3.3.5lofi2005-10-041-0/+10 * Fix a potential local root vulnverability in kcheckpass.lofi2005-09-052-1/+157 * Konqueror bugfixorama:lofi2005-08-064-0/+98 * Update to KDE 3.4.2 / KOffice 1.4.1lofi2005-08-012-3/+2 * Fix some of the issues in the media:/ kioslave. proc filesystems should nolofi2005-07-123-1/+101 * Fix compilation with OpenLDAP 2.3.4lofi2005-07-062-0/+10 * Change dependency pattern for libusb to usb-0.1lofi2005-06-291-1/+1 * Update to KDE 3.4.1lofi2005-06-267-361/+7 * Fix build on 4.9markus2005-05-071-0/+26 * Add patch to fix the kinfocenter PCI module (KDE Bug 101686)markus2005-04-151-0/+60 * Add CONFLICTS with kdeartwork 3.2.x and kdeartwork 3.3.x (plastik widgetlofi2005-03-261-1/+1 * Disable building kompmgr, instead RUN_DEPEND on it if xorg is installed.lofi2005-03-212-0/+16 * Update to KDE 3.4lofi2005-03-2111-300/+754 * Bump PORTREVISION to chase the glib20 shared lib version change.marcus2005-03-121-1/+1 * More cups-fixes and a patch that prevents konqueror from resettinglofi2005-02-063-0/+32 * Update to KDE 3.3.2lofi2004-12-146-107/+80 * Add imake as build dependency. It will soon no longer be picked up bylesi2004-12-081-1/+2 * Fix some more environment nits in the kdm configuration templates, andlofi2004-11-122-8/+17 * Update to KDE 3.3.1lofi2004-11-086-59/+39 * Bump PORTREVISION for the last commit.arved2004-10-111-1/+1 * Fix Environment for kdm/csh users.arved2004-10-111-1/+1 * Fix a typoarved2004-10-102-2/+2 * Fix bug in the default genkdmconf template - kdm would try and parselofi2004-09-243-6/+26 * The rc-script was botched, correct that and bump PORTREVISION.lofi2004-09-012-2/+3 * Update to KDE 3.3lofi2004-08-3112-443/+471 * A couple of patches didn't make it from the kde-freebsd repo into ports.lofi2004-08-136-1/+250 * Tell genkdmconf to ignore existing bits of xdm/kdm configuration, if itlofi2004-08-121-2/+1 * Factor out all but one of the build switches of the KDE main module portslofi2004-08-119-632/+757 * - Add the X_WINDOW_SYSTEM={xorg,xfree86-4,xfree86-3} variable to bsd.port.mk,anholt2004-07-241-1/+1 * Update to version 3.2.3lofi2004-06-104-15/+58 * Bump PORTREVISION.lofi2004-05-181-0/+1 * Fix a fat fingered commit I made two weeks ago:lofi2004-05-181-1/+1 * Put the pkg-message template back into PKGDIR.lofi2004-05-032-1/+1 * Process the pkg-message template earlier than post-install solofi2004-05-022-3/+7 * Update to KDE 3.2.2lofi2004-04-206-27/+27 * Respect WITHOUT_FOO.lofi2004-03-281-18/+1