aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorxride <xride@FreeBSD.org>2009-01-27 06:13:03 +0800
committerxride <xride@FreeBSD.org>2009-01-27 06:13:03 +0800
commitcf4b73f88e4b04a6c5151232d12fe2f4461d22f3 (patch)
tree8d8fa7446cf9c8ba927135acdf3b3b2ecd2427a6 /misc
parente4c1f12c673c88d5a923a6304dac2cfdf0bc4b04 (diff)
downloadfreebsd-ports-gnome-cf4b73f88e4b04a6c5151232d12fe2f4461d22f3.tar.gz
freebsd-ports-gnome-cf4b73f88e4b04a6c5151232d12fe2f4461d22f3.tar.zst
freebsd-ports-gnome-cf4b73f88e4b04a6c5151232d12fe2f4461d22f3.zip
Unbreak.
Obtained from: portsmon
Diffstat (limited to 'misc')
-rw-r--r--misc/wmcalendar/Makefile4
-rw-r--r--misc/wmcalendar/files/patch-calendar.c20
-rw-r--r--misc/wmcalendar/files/patch-calendar.h8
-rw-r--r--misc/wmcalendar/files/patch-calendarfunc.h11
4 files changed, 40 insertions, 3 deletions
diff --git a/misc/wmcalendar/Makefile b/misc/wmcalendar/Makefile
index dae6984c7551..a3f10702ac19 100644
--- a/misc/wmcalendar/Makefile
+++ b/misc/wmcalendar/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wmcalendar
PORTVERSION= 0.5.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= misc windowmaker
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,8 +17,6 @@ COMMENT= A dockable calendar with interface to iCalendar based calendars
LIB_DEPENDS= ical.42:${PORTSDIR}/devel/libical
-BROKEN= does not compile
-
WRKSRC= ${WRKDIR}/${DISTNAME}/Src
USE_XORG= xpm
diff --git a/misc/wmcalendar/files/patch-calendar.c b/misc/wmcalendar/files/patch-calendar.c
new file mode 100644
index 000000000000..3d4824f417cc
--- /dev/null
+++ b/misc/wmcalendar/files/patch-calendar.c
@@ -0,0 +1,20 @@
+--- calendar.c.orig 2007-01-15 01:14:32.000000000 +0100
++++ calendar.c 2009-01-26 19:11:27.000000000 +0100
+@@ -48,7 +48,7 @@
+
+
+
+-void kill (GtkWidget * widget)
++void wmkill (GtkWidget * widget)
+ {
+ gtk_widget_destroy ((GtkWidget*)gtk_widget_get_toplevel(widget));
+ gtk_main_quit ();
+@@ -193,7 +193,7 @@
+ gtk_signal_connect(GTK_OBJECT (event_box), "button_press_event",
+ GTK_SIGNAL_FUNC (move), NULL);
+ gtk_signal_connect(GTK_OBJECT (event_box2), "button_press_event",
+- (GtkSignalFunc) kill, GTK_OBJECT(dayView));
++ (GtkSignalFunc) wmkill, GTK_OBJECT(dayView));
+
+ gtk_widget_realize(dayView);
+ // gtk_window_set_position(GTK_WINDOW (dayView),GTK_WIN_POS_CENTER_ON_PARENT);
diff --git a/misc/wmcalendar/files/patch-calendar.h b/misc/wmcalendar/files/patch-calendar.h
new file mode 100644
index 000000000000..a07b43b50281
--- /dev/null
+++ b/misc/wmcalendar/files/patch-calendar.h
@@ -0,0 +1,8 @@
+--- calendar.h.orig 2009-01-26 18:35:48.000000000 +0100
++++ calendar.h 2009-01-26 18:36:03.000000000 +0100
+@@ -1,4 +1,4 @@
+-#include <ical.h>
++#include <libical/ical.h>
+ #include <stdlib.h>
+ #include <gtk/gtk.h>
+ #include <string.h>
diff --git a/misc/wmcalendar/files/patch-calendarfunc.h b/misc/wmcalendar/files/patch-calendarfunc.h
new file mode 100644
index 000000000000..46e56086033a
--- /dev/null
+++ b/misc/wmcalendar/files/patch-calendarfunc.h
@@ -0,0 +1,11 @@
+--- calendarfunc.h.orig 2009-01-26 19:19:55.000000000 +0100
++++ calendarfunc.h 2009-01-26 19:20:13.000000000 +0100
+@@ -22,7 +22,7 @@
+
+ #include <unistd.h>
+ #include <stdlib.h>
+-#include <ical.h>
++#include <libical/ical.h>
+ #define TIMZ 3.0
+ #define MINAGE 13.5
+ #define SUNSET 19.5 /*approximate */