aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2012-06-12 23:10:39 +0800
committertota <tota@FreeBSD.org>2012-06-12 23:10:39 +0800
commitd1796494df0845cc9e92f702db162733ce27fb5c (patch)
treee4b567ddd0a1e44b73a00405492126c3829e3883 /misc
parente4e4b863f13a03625dd8c33344543b1b2b57bc80 (diff)
downloadfreebsd-ports-gnome-d1796494df0845cc9e92f702db162733ce27fb5c.tar.gz
freebsd-ports-gnome-d1796494df0845cc9e92f702db162733ce27fb5c.tar.zst
freebsd-ports-gnome-d1796494df0845cc9e92f702db162733ce27fb5c.zip
- Convert to new options framework
Diffstat (limited to 'misc')
-rw-r--r--misc/rabbit/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/misc/rabbit/Makefile b/misc/rabbit/Makefile
index b7f25ed741f0..fcc6cdb92602 100644
--- a/misc/rabbit/Makefile
+++ b/misc/rabbit/Makefile
@@ -52,16 +52,17 @@ PORTDOCS= *
PORTEXAMPLES= *
PORTDATA= *
-OPTIONS= MIMETEX "Run with mimetex" off \
- TWITTER "Run with Twitter" off
+OPTIONS_DEFAULT= MIMETEX TWITTER
+MIMETEX_DESC= Run with mimetex
+TWITTER_DESC= Run with Twitter
.include <bsd.port.options.mk>
-.if defined(WITH_MIMETEX)
+.if ${PORT_OPTIONS:MMIMETEX}
RUN_DEPENDS+= ${LOCALBASE}/www/mimetex/cgi-bin/mimetex.cgi:${PORTSDIR}/www/mimetex
.endif
-.if defined(WITH_TWITTER)
+.if ${PORT_OPTIONS:MTWITTER}
RUN_DEPENDS+= rubygem-twitter_oauth>=0:${PORTSDIR}/security/rubygem-twitter_oauth \
rubygem-twitter-stream>=0:${PORTSDIR}/net/rubygem-twitter-stream
.endif
@@ -73,7 +74,7 @@ post-patch:
${RUBY} -i -pe 'sub %r|(require "hikidoc")|, %Q|require "rubygems"\n\\1|' ${WRKSRC}/lib/rabbit/parser/wiki.rb
${RUBY} -i -pe "sub %r|((\s*)require 'twitter_oauth')|, %Q|\\\2require 'rubygems'\n\\\1|" ${WRKSRC}/lib/rabbit/twitter.rb
${RUBY} -i -pe "sub %r|(require 'coderay')|, %Q|require 'rubygems'\n\\\1|" ${WRKSRC}/lib/rabbit/parser/ext/coderay.rb
-.if defined(WITH_MIMETEX)
+.if ${PORT_OPTIONS:MMIMETEX}
${REINPLACE_CMD} -e 's|"mimetex.cgi"|"${PREFIX}/www/mimetex/cgi-bin/mimetex.cgi"|' \
${WRKSRC}/lib/rabbit/parser/ext/tex.rb
.endif