aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2009-01-14 10:36:46 +0800
committeracm <acm@FreeBSD.org>2009-01-14 10:36:46 +0800
commitdd4262ec327e5c684bc9a52a0c2b6ad768de2c6b (patch)
tree114916773388218a58208fb26d6f1f0cd58cf2fc /misc
parent9e0caae2fc0fb7c804c5f9ee130268aa81dd5780 (diff)
downloadfreebsd-ports-gnome-dd4262ec327e5c684bc9a52a0c2b6ad768de2c6b.tar.gz
freebsd-ports-gnome-dd4262ec327e5c684bc9a52a0c2b6ad768de2c6b.tar.zst
freebsd-ports-gnome-dd4262ec327e5c684bc9a52a0c2b6ad768de2c6b.zip
New ports: misc/fpc-chm
Free Pascal unit to manipulate chm files
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/fpc-chm/Makefile21
-rw-r--r--misc/fpc-chm/pkg-plist44
3 files changed, 66 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 1409091e211b..810bd281a217 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -100,6 +100,7 @@
SUBDIR += fortune-mod-futurama
SUBDIR += fortune-mod-the-godfather
SUBDIR += fortuneit
+ SUBDIR += fpc-chm
SUBDIR += freedialog
SUBDIR += freeguide
SUBDIR += freshmeat-submit
diff --git a/misc/fpc-chm/Makefile b/misc/fpc-chm/Makefile
new file mode 100644
index 000000000000..79468acc1f4c
--- /dev/null
+++ b/misc/fpc-chm/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: fpc-chm
+# Date created: 2009-01-06
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= misc lang
+PKGNAMESUFFIX= -chm
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal unit to manipulate chm files
+
+USE_FPC= fcl-xml
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+.include "${MASTERDIR}/Makefile"
diff --git a/misc/fpc-chm/pkg-plist b/misc/fpc-chm/pkg-plist
new file mode 100644
index 000000000000..8471fc32c5b6
--- /dev/null
+++ b/misc/fpc-chm/pkg-plist
@@ -0,0 +1,44 @@
+bin/chmcmd
+bin/chmls
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/fasthtmlparser.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/htmlutil.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/paslzx.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/paslzxcomp.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/paslznonslide.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/chmbase.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/chmtypes.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/chmspecialfiles.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/chmsitemap.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/chmwriter.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/chmfilewriter.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/chmreader.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/fasthtmlparser.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/htmlutil.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/paslzx.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/paslzxcomp.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/paslznonslide.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/chmbase.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/chmtypes.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/chmspecialfiles.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/chmsitemap.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/chmwriter.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/chmfilewriter.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/chmreader.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/libpfasthtmlparser.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/libphtmlutil.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/libppaslzx.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/libppaslzxcomp.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/libppaslznonslide.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/libpchmbase.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/libpchmtypes.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/libpchmspecialfiles.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/libpchmsitemap.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/libpchmwriter.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/libpchmfilewriter.a
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm/libpchmreader.a
+@dirrm lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/chm
+@dirrmtry lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%
+@dirrmtry lib/fpc/%%PORTVERSION%%/units
+@dirrmtry lib/fpc/%%PORTVERSION%%
+@dirrmtry lib/fpc