aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2003-03-24 16:36:49 +0800
committerdemon <demon@FreeBSD.org>2003-03-24 16:36:49 +0800
commitf8eb6339739b86ef92cd4f384330d97c97d20b97 (patch)
treefdf889cb174132958129ab6ac01554e23993602e /misc
parent4fb98f6b549de2081149bbcb189e7dcba97a164f (diff)
downloadfreebsd-ports-gnome-f8eb6339739b86ef92cd4f384330d97c97d20b97.tar.gz
freebsd-ports-gnome-f8eb6339739b86ef92cd4f384330d97c97d20b97.tar.zst
freebsd-ports-gnome-f8eb6339739b86ef92cd4f384330d97c97d20b97.zip
Eliminate endless loop when trying to view file of zero length.
Submitted by: ru
Diffstat (limited to 'misc')
-rw-r--r--misc/deco/Makefile2
-rw-r--r--misc/deco/files/patch-ag11
2 files changed, 12 insertions, 1 deletions
diff --git a/misc/deco/Makefile b/misc/deco/Makefile
index 719e1b0da458..122833c2a1aa 100644
--- a/misc/deco/Makefile
+++ b/misc/deco/Makefile
@@ -7,7 +7,7 @@
PORTNAME= deco
PORTVERSION= 3.8.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= ftp://ftp.cronyx.ru/cronyx/deco/
DISTNAME= deco383
diff --git a/misc/deco/files/patch-ag b/misc/deco/files/patch-ag
new file mode 100644
index 000000000000..22dfb6ce5500
--- /dev/null
+++ b/misc/deco/files/patch-ag
@@ -0,0 +1,11 @@
+--- view.c Sat Jul 12 20:53:25 1997
++++ view.c Sat Mar 22 18:24:31 2003
+@@ -47,7 +47,7 @@
+ int sline, soff; /* search position */
+
+ baseline = basecol = 0;
+- while (viewrec->lindex[baseline+1].seek < viewseek)
++ while (viewrec->lindex[baseline].len != -1 && viewrec->lindex[baseline+1].seek < viewseek)
+ ++baseline;
+ while (viewrec->lindex[baseline].seek + offset (baseline, basecol) + 40 < viewseek)
+ basecol += 40;