aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-09-18 08:37:53 +0800
committeredwin <edwin@FreeBSD.org>2005-09-18 08:37:53 +0800
commitc645b467040ffed87ff4c579a5fc022e6de1324c (patch)
treee031801def8f7908033c7ae1f6b3c29db608897e /misc
parent88b8bab3cb6ea86c9a0a1174ec2612f905d2e68e (diff)
downloadfreebsd-ports-gnome-c645b467040ffed87ff4c579a5fc022e6de1324c.tar.gz
freebsd-ports-gnome-c645b467040ffed87ff4c579a5fc022e6de1324c.tar.zst
freebsd-ports-gnome-c645b467040ffed87ff4c579a5fc022e6de1324c.zip
A framework to produce sprite animations using ASCII art.
This module provides a framework to produce sprite animations using ASCII art. Each ASCII 'sprite' is given one or more frames, and placed into the animation as an 'animation object'. An animation object can have a callback routine that controls the position and frame of the object.
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Term-Animation/Makefile26
-rw-r--r--misc/p5-Term-Animation/distinfo2
-rw-r--r--misc/p5-Term-Animation/pkg-descr15
-rw-r--r--misc/p5-Term-Animation/pkg-plist3
5 files changed, 47 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 64e4aa662e11..a9a273532162 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -341,6 +341,7 @@
SUBDIR += p5-Locale-SubCountry
SUBDIR += p5-Net-vCard
SUBDIR += p5-Norge
+ SUBDIR += p5-Term-Animation
SUBDIR += p5-Text-FIGlet
SUBDIR += p5-Tie-DxHash
SUBDIR += patanjali
diff --git a/misc/p5-Term-Animation/Makefile b/misc/p5-Term-Animation/Makefile
new file mode 100644
index 000000000000..bbf7f2bc18af
--- /dev/null
+++ b/misc/p5-Term-Animation/Makefile
@@ -0,0 +1,26 @@
+#
+# New ports collection makefile for: p5-Term-Animation
+# Date created: 18 september 2005
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Term-Animation
+PORTVERSION= 2.1
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Term
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= ASCII sprite animation framework
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Curses.pm:${PORTSDIR}/devel/p5-Curses
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Term::Animation.3
+
+.include <bsd.port.mk>
diff --git a/misc/p5-Term-Animation/distinfo b/misc/p5-Term-Animation/distinfo
new file mode 100644
index 000000000000..f3da165e004a
--- /dev/null
+++ b/misc/p5-Term-Animation/distinfo
@@ -0,0 +1,2 @@
+MD5 (Term-Animation-2.1.tar.gz) = 8bfb8225be9318f95e0b1e1718da9691
+SIZE (Term-Animation-2.1.tar.gz) = 17369
diff --git a/misc/p5-Term-Animation/pkg-descr b/misc/p5-Term-Animation/pkg-descr
new file mode 100644
index 000000000000..83d52f6e0fa4
--- /dev/null
+++ b/misc/p5-Term-Animation/pkg-descr
@@ -0,0 +1,15 @@
+A framework to produce sprite animations using ASCII art.
+
+This module provides a framework to produce sprite animations using
+ASCII art. Each ASCII 'sprite' is given one or more frames, and
+placed into the animation as an 'animation object'. An animation
+object can have a callback routine that controls the position and
+frame of the object.
+
+If the constructor is passed no arguments, it assumes that it is
+running full screen, and behaves accordingly. Alternatively, it can
+accept a curses window (created with the Curses newwin call) as an
+argument, and will draw into that window.
+
+Author: Kirk Baucom, <kbaucom@schizoid.com>
+WWW: http://search.cpan.org/dist/Term-Animation/
diff --git a/misc/p5-Term-Animation/pkg-plist b/misc/p5-Term-Animation/pkg-plist
new file mode 100644
index 000000000000..4df5bac5e18b
--- /dev/null
+++ b/misc/p5-Term-Animation/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Term/Animation.pm
+%%SITE_PERL%%/Term/Animation/Entity.pm
+@dirrm %%SITE_PERL%%/Term/Animation