aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2018-02-19 22:01:41 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2018-02-19 22:01:41 +0800
commit27c63cb5e57dc272aba6e669d90c20cc5ab22b3a (patch)
treef6b80cf70664c939dd4ccf1368d6d5352754ef10 /misc
parentb426f3c4aef7b8080c33f1f358d987e3d1f26f7e (diff)
downloadfreebsd-ports-gnome-27c63cb5e57dc272aba6e669d90c20cc5ab22b3a.tar.gz
freebsd-ports-gnome-27c63cb5e57dc272aba6e669d90c20cc5ab22b3a.tar.zst
freebsd-ports-gnome-27c63cb5e57dc272aba6e669d90c20cc5ab22b3a.zip
Fix bunch of ports by TundraWare, which share a common set of problems
- Add LICENSE It explicitly requires user agreement (thus no-auto-accept) and forbids distribution for a fee `beyond reasonable duplication charges` which is too vague I don't think can be guaranteed in any case (thus no-*-sell) tdir port uses another variant of license, which also forbids modification, and since the port requires shebangfix and Makefile patching, also mark it no-pkg-mirror and BROKEN. - Don't install licenses with documentation, since our license framework already handles this - Fix python shebangs - Limit python version to 2.7, as no port is compatible with python3 - Add NO_ARCH - User options targets helpers - Simplify installation in a few cases Approved by: portmgr blanket
Diffstat (limited to 'misc')
-rw-r--r--misc/hb/Makefile16
-rw-r--r--misc/hb/files/patch-Makefile7
-rw-r--r--misc/hb/pkg-plist11
3 files changed, 18 insertions, 16 deletions
diff --git a/misc/hb/Makefile b/misc/hb/Makefile
index dc8ae5b3175b..26634447251d 100644
--- a/misc/hb/Makefile
+++ b/misc/hb/Makefile
@@ -3,18 +3,22 @@
PORTNAME= hb
PORTVERSION= 1.88
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc python
MASTER_SITES= http://www.tundraware.com/Software/hb/
MAINTAINER= tundra@tundraware.com
COMMENT= Simple, but complete budget management in Python
-USES= python shebangfix
+LICENSE= TundraWare
+LICENSE_NAME= TundraWare license
+LICENSE_FILE= ${WRKSRC}/1-HB-License.txt
+LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell no-auto-accept
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/bin/python|${python_CMD}|' \
- ${WRKSRC}/hb.py
- @${FIND} ${WRKSRC} -name "*.bak" -delete
+USES= python:2.7,run shebangfix
+SHEBANG_FILES= hb.py
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/misc/hb/files/patch-Makefile b/misc/hb/files/patch-Makefile
index ed563076ea58..a09628102e8f 100644
--- a/misc/hb/files/patch-Makefile
+++ b/misc/hb/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2014-07-15 21:44:10.713832840 +0800
-+++ Makefile 2014-07-15 21:43:38.083846847 +0800
-@@ -4,13 +4,13 @@
+--- Makefile.orig 2002-09-04 23:41:00 UTC
++++ Makefile
+@@ -4,13 +4,12 @@
all: # Do nothing - this is a python script that needs no build
install:
@@ -18,7 +18,6 @@
+ $(BSD_INSTALL_MAN) ./hb.1.gz $(DESTDIR)${PREFIX}/man/man1
+ $(BSD_INSTALL_DATA) ./hb.txt $(DESTDIR)${PREFIX}/share/doc/hb
+ $(BSD_INSTALL_DATA) ./0-StartHere.txt $(DESTDIR)${PREFIX}/share/doc/hb
-+ $(BSD_INSTALL_DATA) ./1-HB-License.txt $(DESTDIR)${PREFIX}/share/doc/hb
+ $(BSD_INSTALL_DATA) ./2-HowToUse.txt $(DESTDIR)${PREFIX}/share/doc/hb
+ $(BSD_INSTALL_DATA) ./3-UnderTheHood.txt $(DESTDIR)${PREFIX}/share/doc/hb
+ $(BSD_INSTALL_DATA) ./4-Limitations-Enhancements.txt $(DESTDIR)${PREFIX}/share/doc/hb
diff --git a/misc/hb/pkg-plist b/misc/hb/pkg-plist
index 571ea0782c4b..d692f2d6cb9f 100644
--- a/misc/hb/pkg-plist
+++ b/misc/hb/pkg-plist
@@ -1,8 +1,7 @@
bin/hb.py
man/man1/hb.1.gz
-share/doc/hb/hb.txt
-share/doc/hb/0-StartHere.txt
-share/doc/hb/1-HB-License.txt
-share/doc/hb/2-HowToUse.txt
-share/doc/hb/3-UnderTheHood.txt
-share/doc/hb/4-Limitations-Enhancements.txt
+%%PORTDOCS%%%%DOCSDIR%%/hb.txt
+%%PORTDOCS%%%%DOCSDIR%%/0-StartHere.txt
+%%PORTDOCS%%%%DOCSDIR%%/2-HowToUse.txt
+%%PORTDOCS%%%%DOCSDIR%%/3-UnderTheHood.txt
+%%PORTDOCS%%%%DOCSDIR%%/4-Limitations-Enhancements.txt