aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2015-07-14 09:51:23 +0800
committerwg <wg@FreeBSD.org>2015-07-14 09:51:23 +0800
commit39441e9604954a4772f3870e542afb7f44d9e616 (patch)
tree0f292258ff0ce945ee0565a7c11ca05f76946f79 /misc
parentb088a446450245589724412ff507389cf0d08890 (diff)
downloadfreebsd-ports-gnome-39441e9604954a4772f3870e542afb7f44d9e616.tar.gz
freebsd-ports-gnome-39441e9604954a4772f3870e542afb7f44d9e616.tar.zst
freebsd-ports-gnome-39441e9604954a4772f3870e542afb7f44d9e616.zip
misc/py-progressbar231: text progress bar library for Python
This is a fork of the real py-progressbar with a few additions.
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-progressbar231/Makefile19
-rw-r--r--misc/py-progressbar231/distinfo2
-rw-r--r--misc/py-progressbar231/pkg-descr16
4 files changed, 38 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index c902b21a210a..8dc1df3d4c35 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -371,6 +371,7 @@
SUBDIR += py-osd
SUBDIR += py-pexpect
SUBDIR += py-progressbar
+ SUBDIR += py-progressbar231
SUBDIR += py-qt4-demo
SUBDIR += py-qt4-doc
SUBDIR += py-yolk
diff --git a/misc/py-progressbar231/Makefile b/misc/py-progressbar231/Makefile
new file mode 100644
index 000000000000..8daaa003af17
--- /dev/null
+++ b/misc/py-progressbar231/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= progressbar231
+PORTVERSION= 2.3.1
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wg@FreeBSD.org
+COMMENT= Text progressbar library for python
+
+LICENSE= BSD3CLAUSE
+
+USE_PYTHON= autoplist distutils
+USES= python:2
+
+CONFLICTS= py*-progressbar
+
+.include <bsd.port.mk>
diff --git a/misc/py-progressbar231/distinfo b/misc/py-progressbar231/distinfo
new file mode 100644
index 000000000000..4cc91e326d9d
--- /dev/null
+++ b/misc/py-progressbar231/distinfo
@@ -0,0 +1,2 @@
+SHA256 (progressbar231-2.3.1.tar.gz) = 55b5e5c6b0077b21d14cf2166f3ee74758f89ec75175a6fce4e3f78366771148
+SIZE (progressbar231-2.3.1.tar.gz) = 10402
diff --git a/misc/py-progressbar231/pkg-descr b/misc/py-progressbar231/pkg-descr
new file mode 100644
index 000000000000..2b2cf048736f
--- /dev/null
+++ b/misc/py-progressbar231/pkg-descr
@@ -0,0 +1,16 @@
+This library provides a text mode progressbar. This is typically
+used to display the progress of a long running operation, providing
+a visual clue that processing is underway.
+
+The ProgressBar class manages the progress, and the format of the
+line is given by a number of widgets. A widget is an object that
+may display diferently depending on the state of the progress.
+
+There are three types of widget:
+- a string, which always shows itself;
+- a ProgressBarWidget, which may return a diferent value every time
+ it's update method is called; and
+- a ProgressBarWidgetHFill, which is like ProgressBarWidget, except
+ it expands to fill the remaining width of the line.
+
+WWW: https://pypi.python.org/pypi/progressbar231