aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-03-31 00:49:36 +0800
committerijliao <ijliao@FreeBSD.org>2001-03-31 00:49:36 +0800
commit3b0dc95b3cb0dc92bc34ba0ababf65f381472460 (patch)
treeb5aa9498142c6b347ab08838ca13263ba1fe0f8e /misc
parente8402e855398d6990fb94fc987d99d684dc5f3c6 (diff)
downloadfreebsd-ports-gnome-3b0dc95b3cb0dc92bc34ba0ababf65f381472460.tar.gz
freebsd-ports-gnome-3b0dc95b3cb0dc92bc34ba0ababf65f381472460.tar.zst
freebsd-ports-gnome-3b0dc95b3cb0dc92bc34ba0ababf65f381472460.zip
add gman
G-man is a user-friendly graphical front end for the man system
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/gman/Makefile25
-rw-r--r--misc/gman/distinfo1
-rw-r--r--misc/gman/files/patch-Makefile23
-rw-r--r--misc/gman/files/patch-gman.c20
-rw-r--r--misc/gman/files/patch-mandata.c67
-rw-r--r--misc/gman/files/patch-mandata.h17
-rw-r--r--misc/gman/files/patch-menu.c11
-rw-r--r--misc/gman/files/patch-window2.c11
-rw-r--r--misc/gman/pkg-comment1
-rw-r--r--misc/gman/pkg-descr5
-rw-r--r--misc/gman/pkg-plist1
12 files changed, 183 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 42b315031b63..f9593efe0e42 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -55,6 +55,7 @@
SUBDIR += ftree
SUBDIR += geekcode
SUBDIR += git
+ SUBDIR += gman
SUBDIR += gnomepm
SUBDIR += gnomeusersguide
SUBDIR += gnomeutils
diff --git a/misc/gman/Makefile b/misc/gman/Makefile
new file mode 100644
index 000000000000..bea9acea4176
--- /dev/null
+++ b/misc/gman/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# New ports collection makefile for: gman
+# Date created: Mar 30, 3001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gman
+PORTVERSION= 0.9.0
+CATEGORIES= misc
+MASTER_SITES= http://homex.coolconnect.com/user/xkwang/gman/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+RUN_DEPENDS= ghostview:${PORTSDIR}/print/ghostview
+
+USE_GTK= yes
+
+MAN1= gman.1x
+
+post-patch:
+ @${PERL} -pi -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/misc/gman/distinfo b/misc/gman/distinfo
new file mode 100644
index 000000000000..093f29f5c700
--- /dev/null
+++ b/misc/gman/distinfo
@@ -0,0 +1 @@
+MD5 (gman-0.9.0.tar.gz) = b00c5308095acd146e19a49dc5897bb9
diff --git a/misc/gman/files/patch-Makefile b/misc/gman/files/patch-Makefile
new file mode 100644
index 000000000000..c2911895df6f
--- /dev/null
+++ b/misc/gman/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig Sat Mar 31 00:33:31 2001
++++ Makefile Sat Mar 31 00:34:53 2001
+@@ -1,17 +1,17 @@
+ # Gman Makefile
+ # You can adjust the following variables.
+ CXX = g++
+-CXXFLAGS = -DVERSION=\"0.9.0\" `gtk-config --cflags` -O2 #-Wall
++CXXFLAGS += -DVERSION=\"0.9.0\" `${GTK_CONFIG} --cflags`
+ CC = $(CXX) $(CXXFLAGS)
+
+ GNOMELIB = #`gnome-config --libs gnomeui`
+-prefix = /usr
++prefix = ${PREFIX}
+
+ # There shouldn't be any need to edit anything below this point.
+ all: gman
+
+ gman: menu.o mandata.o util.o gman.o list.o context.o task.o taskfunc.o window2.o
+- $(CC) -lgtk -lgdk -lpthread $(GNOMELIB) menu.o mandata.o util.o gman.o list.o context.o task.o taskfunc.o window2.o -o gman
++ $(CC) -lpthread `${GTK_CONFIG} --libs` $(GNOMELIB) menu.o mandata.o util.o gman.o list.o context.o task.o taskfunc.o window2.o -o gman
+
+ gman.o: gman.c menu.h
+ $(CC) -c gman.c
diff --git a/misc/gman/files/patch-gman.c b/misc/gman/files/patch-gman.c
new file mode 100644
index 000000000000..892f23a6e3c1
--- /dev/null
+++ b/misc/gman/files/patch-gman.c
@@ -0,0 +1,20 @@
+--- gman.c.orig Mon Mar 26 17:08:28 2001
++++ gman.c Fri Mar 30 23:46:22 2001
+@@ -83,7 +83,7 @@
+ context = new AppContext();
+ // context->set_default_value("v_size",(void*)400);
+ context->set_default_value("debuging","int",(void*)0);
+- context->set_default_value("man_paths","char*",(void*)"/usr/man:/usr/local/man:/usr/X11R6/man");
++ context->set_default_value("man_paths","char*",(void*)"/usr/share/man:/usr/local/man:/usr/X11R6/man");
+ context->set_default_value("display_section_policy","int",(void*)0);
+ context->set_default_value("display_section","int",(void*)3);
+ context->set_default_value("searching_mode","int",(void*)0);
+@@ -91,7 +91,7 @@
+ context->set_default_value("show_warning","int",(void*)0);
+ context->set_default_value("show_mode","int",(void*)0); // 0 = xterm, 1 = ghostview
+ context->set_default_value("xterm_command","char*",(void*)"xterm");
+- context->set_default_value("gv_command","char*",(void*)"gv");
++ context->set_default_value("gv_command","char*",(void*)"ghostview");
+ context->set_default_value("print_command","char*",(void*)"lpr");
+
+ attach(buffer,getenv("HOME"),".gman");
diff --git a/misc/gman/files/patch-mandata.c b/misc/gman/files/patch-mandata.c
new file mode 100644
index 000000000000..68d0af1f4154
--- /dev/null
+++ b/misc/gman/files/patch-mandata.c
@@ -0,0 +1,67 @@
+--- mandata.c.orig Mon Mar 26 16:40:49 2001
++++ mandata.c Sat Mar 31 00:21:55 2001
+@@ -58,7 +58,7 @@
+ if(path_name) free(path_name);
+ }
+
+-ManPath::GetSize(int section_ID)
++int ManPath::GetSize(int section_ID)
+ {
+ int count;
+ int i;
+@@ -67,7 +67,7 @@
+ return count;
+ }
+
+-ManPath::GetItems(int section_ID, ManItem * buffer[])
++int ManPath::GetItems(int section_ID, ManItem * buffer[])
+ {
+ int count;
+ int i;
+@@ -80,7 +80,7 @@
+
+ struct stat state;
+
+-ManPath::LoadManPath(char * path_name)
++int ManPath::LoadManPath(char * path_name)
+ {
+ DIR *dirp;
+ #if defined(SYS_DIR)||defined(NDIR)
+@@ -125,7 +125,7 @@
+ return 0;
+ }
+
+-ManPath::LoadManSubPath(char * sub_name)
++int ManPath::LoadManSubPath(char * sub_name)
+ {
+ DIR *dirp;
+ #if defined(SYS_DIR)||defined(NDIR)
+@@ -242,11 +242,11 @@
+ char loc_name[BUFFER_SIZE];
+ switch ((int)context->get_value("show_mode")) {
+ case 0:
+- sprintf(buffer,"%s -T '%s manual page' -n GMan -e man ",
++ sprintf(buffer,"%s -T '%s manual page' -n GMan -e man %s",
+ (char*)context->get_value("xterm_command"),
+- get_display_name(buffer1));
+- len = strlen(buffer);
+- attach(buffer+len,man_path->GetPath(),file_name);
++ get_display_name(buffer1), get_display_name(buffer1));
++/* len = strlen(buffer);
++ attach(buffer+len,man_path->GetPath(),file_name); */
+ //g_warning(buffer);
+ if(!fork())
+ {
+@@ -257,9 +257,9 @@
+ break;
+ case 1:
+ sprintf(loc_name," ~/.gman.%s.ps ",get_display_name(buffer1));
+- sprintf(buffer,"man -t ");
+- len = strlen(buffer);
+- attach(buffer+len,man_path->GetPath(),file_name);
++ sprintf(buffer,"man -t %s", get_display_name(buffer1));
++/* len = strlen(buffer);
++ attach(buffer+len,man_path->GetPath(),file_name); */
+ strcat(buffer," >> ");
+ strcat(buffer,loc_name);
+ strcat(buffer," ; ");
diff --git a/misc/gman/files/patch-mandata.h b/misc/gman/files/patch-mandata.h
new file mode 100644
index 000000000000..857c44b49603
--- /dev/null
+++ b/misc/gman/files/patch-mandata.h
@@ -0,0 +1,17 @@
+--- mandata.h.orig Fri Mar 30 09:35:42 2001
++++ mandata.h Fri Mar 30 09:35:56 2001
+@@ -17,12 +17,12 @@
+ char * path_name;
+ List * section[MAX_MAN_SECTION]; //1:2:3:4:5:6:7:8:9:tcl:n:l:p:o
+ private:
+- LoadManSubPath(char *);
++ int LoadManSubPath(char *);
+ public:
+ int active;
+ ManPath(char * path_name);
+ ~ManPath();
+- LoadManPath(char *);
++ int LoadManPath(char *);
+ const char * GetPath();
+ int GetSize(int section_ID);
+ int GetItems(int section_ID, ManItem **buffer);
diff --git a/misc/gman/files/patch-menu.c b/misc/gman/files/patch-menu.c
new file mode 100644
index 000000000000..d5f457a7973f
--- /dev/null
+++ b/misc/gman/files/patch-menu.c
@@ -0,0 +1,11 @@
+--- menu.c.orig Fri Mar 30 09:36:30 2001
++++ menu.c Fri Mar 30 09:36:47 2001
+@@ -588,7 +588,7 @@
+ }
+ }
+
+-static status_bar_callback (GtkWidget *widget, gpointer data)
++static int status_bar_callback (GtkWidget *widget, gpointer data)
+ {
+ int k,k2;
+ if(signal_menu_change>0) {signal_menu_change--;return 1;}
diff --git a/misc/gman/files/patch-window2.c b/misc/gman/files/patch-window2.c
new file mode 100644
index 000000000000..229b4a4fe110
--- /dev/null
+++ b/misc/gman/files/patch-window2.c
@@ -0,0 +1,11 @@
+--- window2.c.orig Fri Mar 30 09:40:02 2001
++++ window2.c Fri Mar 30 09:40:50 2001
+@@ -172,7 +172,7 @@
+ for (i = 0;i<j;i++) {
+ p = (ManPath*) man_paths->get_value(i);
+ if (p) {
+- clist_item[0] = p->active?"o":"";
++ clist_item[0] = (gchar *)(p->active?"o":"");
+ clist_item[1] = man_paths->get_name(i);
+ sprintf(buffer,"%d",p->GetSize(-1));
+ clist_item[2] = buffer;
diff --git a/misc/gman/pkg-comment b/misc/gman/pkg-comment
new file mode 100644
index 000000000000..ef6fce8f5ece
--- /dev/null
+++ b/misc/gman/pkg-comment
@@ -0,0 +1 @@
+G-man is a user-friendly graphical front end for the man system
diff --git a/misc/gman/pkg-descr b/misc/gman/pkg-descr
new file mode 100644
index 000000000000..9c9aec3a36d7
--- /dev/null
+++ b/misc/gman/pkg-descr
@@ -0,0 +1,5 @@
+G-man is a user-friendly graphical front end for the man system mostly
+designed for the new users of UNIX. It can help a newbie find specific
+information or idly browse other man pages.
+
+WWW: http://homex.coolconnect.com/user/xkwang/gman/
diff --git a/misc/gman/pkg-plist b/misc/gman/pkg-plist
new file mode 100644
index 000000000000..769b105dd8fc
--- /dev/null
+++ b/misc/gman/pkg-plist
@@ -0,0 +1 @@
+bin/gman