aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2007-08-23 15:35:53 +0800
committeritetcu <itetcu@FreeBSD.org>2007-08-23 15:35:53 +0800
commit65f340a9c7ac4ee42fcb48067f52c3539dc7e568 (patch)
tree75314384b8c31a70173ea5869cb3137f5117f83e /misc
parent1d8097732c19f729c233654687bfcc4b60227093 (diff)
downloadfreebsd-ports-gnome-65f340a9c7ac4ee42fcb48067f52c3539dc7e568.tar.gz
freebsd-ports-gnome-65f340a9c7ac4ee42fcb48067f52c3539dc7e568.tar.zst
freebsd-ports-gnome-65f340a9c7ac4ee42fcb48067f52c3539dc7e568.zip
- Unbreak on HEAD (gcc 4.2)
PR: ports/115744 Submitted by: Simun Mikecin
Diffstat (limited to 'misc')
-rw-r--r--misc/alevt/Makefile4
-rw-r--r--misc/alevt/files/patch-xio.c30
2 files changed, 30 insertions, 4 deletions
diff --git a/misc/alevt/Makefile b/misc/alevt/Makefile
index c67e7b9ee971..9216db6eb181 100644
--- a/misc/alevt/Makefile
+++ b/misc/alevt/Makefile
@@ -22,10 +22,6 @@ MAN1= alevt.1x alevt-date.1 alevt-cap.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
.if defined(WITH_PNG)
LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
MAKE_ARGS+= -DWITH_PNG
diff --git a/misc/alevt/files/patch-xio.c b/misc/alevt/files/patch-xio.c
new file mode 100644
index 000000000000..0f80a2cdf1b2
--- /dev/null
+++ b/misc/alevt/files/patch-xio.c
@@ -0,0 +1,30 @@
+--- xio.c.orig 2002-08-20 05:09:38.000000000 +0200
++++ xio.c 2007-08-23 07:48:59.587926513 +0200
+@@ -31,11 +31,11 @@
+
+ static struct dl_head dpys[1]; /* list of all displays */
+
++static void xio_timer();
+
+ static int
+ timer_init(int argc, char **argv)
+ {
+- static void xio_timer();
+ int p[2], timer_pid, i;
+
+ if (pipe(p) == -1)
+@@ -154,13 +154,12 @@
+ fdset_del_fd(fds, fd);
+ }
+
+-
++static void handle_event(); //forward ref
+
+ struct xio *
+ xio_open_dpy(char *dpy, int argc, char **argv)
+ {
+ XClassHint classhint[1];
+- static void handle_event(); //forward ref
+ struct xio *xio;
+
+ if (local_init(argc, argv) == -1)