aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-07-09 16:40:17 +0800
committermat <mat@FreeBSD.org>2018-07-09 16:40:17 +0800
commit79c3ac81e82fba101ce34956c5de634b8ed032d0 (patch)
treeaa20f69168c1d6c9e0dbf200cc417eb6ea9147ca /misc
parent89ac30bfd79e5d0fe14f37fae8ce263170a2af2d (diff)
downloadfreebsd-ports-gnome-79c3ac81e82fba101ce34956c5de634b8ed032d0.tar.gz
freebsd-ports-gnome-79c3ac81e82fba101ce34956c5de634b8ed032d0.tar.zst
freebsd-ports-gnome-79c3ac81e82fba101ce34956c5de634b8ed032d0.zip
Remove all := from BUILD_DEPENDS, here are never needed.
While there, cleanup, and sort depends. When build and run dependencies are the same, there are three ways to avoid duplicating the list while not adding the framework added BUILD_DEPENDS to the RUN_DEPENDS. In order of preference, they are: 1) use RUN_DEPENDS to set BUILD_DEPENDS: BUILD_DEPENDS= ${RUN_DEPENDS} RUN_DEPENDS= foo:bar/baz 2) create another variable and use it: MY_DEPENDS= foo:bar/baz BUILD_DEPENDS= ${MY_DEPENDS} RUN_DEPENDS= ${MY_DEPENDS} 3) use BUILD_DEPENDS to set RUN_DEPENDS and force evaluation: BUILD_DEPENDS= foo:bar/baz RUN_DEPENDS:= ${BUILD_DEPENDS} Sponsored by: Absolight
Diffstat (limited to 'misc')
-rw-r--r--misc/p5-Geo-Cache/Makefile2
-rw-r--r--misc/p5-Geo-Coder-Multiple/Makefile2
-rw-r--r--misc/p5-Locale-Geocode/Makefile2
-rw-r--r--misc/xiphos/Makefile4
4 files changed, 5 insertions, 5 deletions
diff --git a/misc/p5-Geo-Cache/Makefile b/misc/p5-Geo-Cache/Makefile
index a6db769363f3..988e46e4b19f 100644
--- a/misc/p5-Geo-Cache/Makefile
+++ b/misc/p5-Geo-Cache/Makefile
@@ -14,9 +14,9 @@ COMMENT= Object interface for GPS waypoints
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-Time-modules>=0:devel/p5-Time-modules \
p5-XML-Simple>=0:textproc/p5-XML-Simple
-BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/misc/p5-Geo-Coder-Multiple/Makefile b/misc/p5-Geo-Coder-Multiple/Makefile
index c4e1d06b602d..1153b5864ad4 100644
--- a/misc/p5-Geo-Coder-Multiple/Makefile
+++ b/misc/p5-Geo-Coder-Multiple/Makefile
@@ -14,8 +14,8 @@ COMMENT= Perl module to tie together multiple Geo::Coder modules
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-List-Util-WeightedRoundRobin>=0:misc/p5-List-Util-WeightedRoundRobin
-BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/misc/p5-Locale-Geocode/Makefile b/misc/p5-Locale-Geocode/Makefile
index ddcb3aeb91dd..b7cdfcfd1ec0 100644
--- a/misc/p5-Locale-Geocode/Makefile
+++ b/misc/p5-Locale-Geocode/Makefile
@@ -12,9 +12,9 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C/0$//}
MAINTAINER= perl@FreeBSD.org
COMMENT= Find codes and information on geographical location
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-XML-SAX-Expat>=0.39:textproc/p5-XML-SAX-Expat \
p5-XML-Simple>=2.16:textproc/p5-XML-Simple
-BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/misc/xiphos/Makefile b/misc/xiphos/Makefile
index 61df7ad69b35..61d0585db882 100644
--- a/misc/xiphos/Makefile
+++ b/misc/xiphos/Makefile
@@ -13,14 +13,14 @@ LICENSE= GPLv2
BROKEN_FreeBSD_12= fails to compile: /usr/include/c++/v1/type_traits:1116:29: recursive template instantiation exceeded maximum depth of 25
-RUN_DEPENDS= yelp:x11/yelp
-BUILD_DEPENDS:= ${RUN_DEPENDS} \
+BUILD_DEPENDS= ${RUN_DEPENDS} \
docbook2html:textproc/docbook-utils \
gnome-doc-tool:textproc/gnome-doc-utils \
nspr>=4.8:devel/nspr
LIB_DEPENDS= libwebkitgtk-3.0.so:www/webkit-gtk3 \
libdbus-glib-1.so:devel/dbus-glib \
libsword.so:misc/sword
+RUN_DEPENDS= yelp:x11/yelp
USES= gettext pkgconfig waf
INSTALLS_OMF= yes