aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authortheraven <theraven@FreeBSD.org>2015-07-01 21:50:28 +0800
committertheraven <theraven@FreeBSD.org>2015-07-01 21:50:28 +0800
commit904c17e098fd87d14c369a6777af92f88f3150ea (patch)
tree768c0d7e8d779c0a07374b2216328f05189ef2df /misc
parentc7b08070be2e3668771df19f5912e2373455f70c (diff)
downloadfreebsd-ports-gnome-904c17e098fd87d14c369a6777af92f88f3150ea.tar.gz
freebsd-ports-gnome-904c17e098fd87d14c369a6777af92f88f3150ea.tar.zst
freebsd-ports-gnome-904c17e098fd87d14c369a6777af92f88f3150ea.zip
Update GNUstep ports to their latest versions.
Also fix a few bits of generic infrastructure along the way. Approved by: bapt (mentor) Differential Revision: https://reviews.freebsd.org/D2961
Diffstat (limited to 'misc')
-rw-r--r--misc/gnustep-examples/Makefile26
1 files changed, 17 insertions, 9 deletions
diff --git a/misc/gnustep-examples/Makefile b/misc/gnustep-examples/Makefile
index c3658a881591..851d8d1c15e9 100644
--- a/misc/gnustep-examples/Makefile
+++ b/misc/gnustep-examples/Makefile
@@ -7,22 +7,30 @@ CATEGORIES= misc gnustep
MASTER_SITES= GNUSTEP/usr-apps
MAINTAINER= ports@FreeBSD.org
-COMMENT= GNUstep example applications
-BROKEN= Not converted to USES=gnustep
-
-USE_GNUSTEP= yes
-USE_GNUSTEP_BACK= yes
-USE_GNUSTEP_BUILD= yes
-USE_GNUSTEP_INSTALL= yes
-USE_GL= yes
+USES= gnustep
+USE_GNUSTEP= back build
WRKSRC= ${WRKDIR}/${DISTNAME}
USE_GNUSTEP_MAKE_DIRS+= . gui/Finger gui/GFractal gui/HostAddress gui/MyGL
-MAKE_ENV+= GNUSTEP_INSTALLATION_DIR=${GNUSTEP_LOCAL_ROOT}
post-patch:
${REINPLACE_CMD} -e 's|^//|#|' \
${WRKSRC}/gui/GFractal/GNUmakefile
+do-build:
+.for i in ${USE_GNUSTEP_MAKE_DIRS}
+ @(cd ${BUILD_WRKSRC}/${i}; . ${GNUSTEP_MAKEFILES}/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
+.endfor
+
+# ---------------------------------------------------------------------------
+# source GNUstep.sh
+#
+do-install:
+.for i in ${USE_GNUSTEP_MAKE_DIRS}
+ @(cd ${INSTALL_WRKSRC}/${i}; . ${GNUSTEP_MAKEFILES}/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+.endfor
+
.include <bsd.port.mk>