aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2008-11-12 23:01:50 +0800
committerwxs <wxs@FreeBSD.org>2008-11-12 23:01:50 +0800
commit9320a92d8c6e31d8996bed3ef04d602e15ed0895 (patch)
treeff72b40712b23b0cfda51c0ae263211f92e0c709 /misc
parentf1df905e6284ce636426d751fc534365ebb17a05 (diff)
downloadfreebsd-ports-gnome-9320a92d8c6e31d8996bed3ef04d602e15ed0895.tar.gz
freebsd-ports-gnome-9320a92d8c6e31d8996bed3ef04d602e15ed0895.tar.zst
freebsd-ports-gnome-9320a92d8c6e31d8996bed3ef04d602e15ed0895.zip
This module is a simple tool for calculating business hours in a time
period. Over time, additional functionality will be added to make it easy to calculate the number of business hours between arbitrary dates. PR: ports/126778 Submitted by: Matthew Seaman <m.seaman@infracaninophile.co.uk>
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Business-Hours/Makefile24
-rw-r--r--misc/p5-Business-Hours/distinfo3
-rw-r--r--misc/p5-Business-Hours/pkg-descr6
-rw-r--r--misc/p5-Business-Hours/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 3ed0176960db..b67332550cdf 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -398,6 +398,7 @@
SUBDIR += p5-Array-PrintCols
SUBDIR += p5-Array-RefElem
SUBDIR += p5-Asterisk
+ SUBDIR += p5-Business-Hours
SUBDIR += p5-Business-ISBN
SUBDIR += p5-Business-ISBN-Data
SUBDIR += p5-Business-ISIN
diff --git a/misc/p5-Business-Hours/Makefile b/misc/p5-Business-Hours/Makefile
new file mode 100644
index 000000000000..ee9642cb88c3
--- /dev/null
+++ b/misc/p5-Business-Hours/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Business-Hours
+# Date created: 23 August 2008
+# Whom: Matthew Seaman <m.seaman@infracaninophile.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-Hours
+PORTVERSION= 0.08
+CATEGORIES= misc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m.seaman@infracaninophile.co.uk
+COMMENT= Calculate business hours during a time period
+
+BUILD_DEPENDS= ${SITE_PERL}/Set/IntSpan.pm:${PORTSDIR}/math/p5-Set-IntSpan
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Business::Hours.3
+
+.include <bsd.port.mk>
diff --git a/misc/p5-Business-Hours/distinfo b/misc/p5-Business-Hours/distinfo
new file mode 100644
index 000000000000..2abf6b27d951
--- /dev/null
+++ b/misc/p5-Business-Hours/distinfo
@@ -0,0 +1,3 @@
+MD5 (Business-Hours-0.08.tar.gz) = 047ea5e498f73cc2c023c250a612aaea
+SHA256 (Business-Hours-0.08.tar.gz) = ee95277d17ed399439eb97313ebf56eb43cd86fc58e6834c3ea13fd233bc632f
+SIZE (Business-Hours-0.08.tar.gz) = 13892
diff --git a/misc/p5-Business-Hours/pkg-descr b/misc/p5-Business-Hours/pkg-descr
new file mode 100644
index 000000000000..e560e2e8fbda
--- /dev/null
+++ b/misc/p5-Business-Hours/pkg-descr
@@ -0,0 +1,6 @@
+This module is a simple tool for calculating business hours in a time
+period. Over time, additional functionality will be added to make it
+easy to calculate the number of business hours between arbitrary
+dates.
+
+WWW: http://search.cpan.org/perldoc?Business::Hours
diff --git a/misc/p5-Business-Hours/pkg-plist b/misc/p5-Business-Hours/pkg-plist
new file mode 100644
index 000000000000..f6819be4142e
--- /dev/null
+++ b/misc/p5-Business-Hours/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/Hours/.packlist
+%%SITE_PERL%%/Business/Hours.pm
+@dirrmtry %%SITE_PERL%%/Business
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/Hours
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business