aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2005-12-21 04:03:56 +0800
committerdougb <dougb@FreeBSD.org>2005-12-21 04:03:56 +0800
commita1beec14d2fa6584c63265ee5827245ee5fe3960 (patch)
treec052096d1132081063edf8b2521f9656a3f37194 /misc
parent6864ab540a90ea574d565a00e511a05a4e2b8bff (diff)
downloadfreebsd-ports-gnome-a1beec14d2fa6584c63265ee5827245ee5fe3960.tar.gz
freebsd-ports-gnome-a1beec14d2fa6584c63265ee5827245ee5fe3960.tar.zst
freebsd-ports-gnome-a1beec14d2fa6584c63265ee5827245ee5fe3960.zip
Reduce POLA violation for users who didn't expect to have to enable
this feature. Prodded by: pav
Diffstat (limited to 'misc')
-rw-r--r--misc/compat4x/Makefile14
-rw-r--r--misc/compat5x/Makefile16
2 files changed, 28 insertions, 2 deletions
diff --git a/misc/compat4x/Makefile b/misc/compat4x/Makefile
index d0ac38d52ede..1e1ab1fea126 100644
--- a/misc/compat4x/Makefile
+++ b/misc/compat4x/Makefile
@@ -7,7 +7,7 @@
PORTNAME= compat4x
PORTVERSION= ${COMPAT4X_PORTVERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= misc
MASTER_SITES= ${COMPAT4X_MASTER_SITES}
MASTER_SITE_SUBDIR= ${COMPAT4X_MASTER_SITE_SUBDIR}
@@ -127,6 +127,17 @@ do-extract:
.endfor
.endif
+post-extract:
+ @( ${ECHO} ""; \
+ ${ECHO} "******************************************************"; \
+ ${ECHO} "To enable the ldconfig of these libraries at boot time"; \
+ ${ECHO} "you need to add compat4x_enable=\"yes\" to either"; \
+ ${ECHO} "/etc/rc.conf.local or /etc/rc.conf"; \
+ ${ECHO} "******************************************************"; \
+ ${ECHO} ""; ) > ${WRKDIR}/pkg-message
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
NO_BUILD= yes
do-install:
@@ -143,5 +154,6 @@ do-install:
post-install:
@${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/misc/compat5x/Makefile b/misc/compat5x/Makefile
index b6912b646c3b..65a7be4da2e7 100644
--- a/misc/compat5x/Makefile
+++ b/misc/compat5x/Makefile
@@ -11,7 +11,7 @@
PORTNAME= compat5x
PORTVERSION= 5.4.0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=lesi/compat5x
@@ -67,6 +67,17 @@ PLIST_SUB+= SPARC64=""
PLIST_SUB+= SPARC64="@comment "
.endif
+post-extract:
+ @( ${ECHO} ""; \
+ ${ECHO} "******************************************************"; \
+ ${ECHO} "To enable the ldconfig of these libraries at boot time"; \
+ ${ECHO} "you need to add compat5x_enable=\"yes\" to either"; \
+ ${ECHO} "/etc/rc.conf.local or /etc/rc.conf"; \
+ ${ECHO} "******************************************************"; \
+ ${ECHO} ""; ) > ${WRKDIR}/pkg-message
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
NO_BUILD= yes
do-install:
@@ -78,4 +89,7 @@ do-install:
${LDCONFIG} -32 -m ${TARGET32_DIR}
.endif
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.post.mk>