aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
committerlinimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
commitbcc2006e5a05ff46461202f4b3c0a4ac8d86476e (patch)
tree7d9d8595a250c7e5a9a646200945ef2094927620 /misc
parent27befbedb683f9336783ae19591c9b2f5037500d (diff)
downloadfreebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.tar.gz
freebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.tar.zst
freebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.zip
Force numerous ports that fail to build with clang over to instead always
rely on gcc. The patch uses the new USE_GCC=any code in Mk/bsd.gcc.mk to accomplish this. The ports chosen were ports that blocked 2 or more ports from building with clang. (There are several hundred other ports that still fail to build with clang, even with this patch. This is merely one step along the way.) Those interested in fixing these ports with clang, and have clang as their default compiler, can simply set FORCE_BASE_CC_FOR_TESTING=yes. For those who have gcc as their default compiler, this change is believed to cause no change. Hat: portmgr Tested with: multiple runs on amd64-8-exp-bcm and 9-exp-clang, with various combinations of patch/no-patch and flag settings.
Diffstat (limited to 'misc')
-rw-r--r--misc/sword/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index ca2996e246ba..6ed3f474e9a3 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -23,6 +23,7 @@ BUILD_DEPENDS= cppunit-config:${PORTSDIR}/devel/cppunit
MAKE_JOBS_SAFE= yes
+USE_GCC= any
USE_GNOME= pkgconfig
USE_GMAKE= yes
GNU_CONFIGURE= yes