aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2007-12-26 18:18:45 +0800
committersobomax <sobomax@FreeBSD.org>2007-12-26 18:18:45 +0800
commit0353a621ad50028fc590a343cebdcd029aa09bf8 (patch)
treebe5bac2c4961812c826106e834073f1367e43d1a /misc
parent95130449fdfee04fa48c4a8bcf1f66f49cb39ef9 (diff)
downloadfreebsd-ports-gnome-0353a621ad50028fc590a343cebdcd029aa09bf8.tar.gz
freebsd-ports-gnome-0353a621ad50028fc590a343cebdcd029aa09bf8.tar.zst
freebsd-ports-gnome-0353a621ad50028fc590a343cebdcd029aa09bf8.zip
Use destroy_dev_sched() instead of destroy_dev() when __FreeBSD_version >=
700050. The 700050 is not exactly the revision in question (sadly the __FreeBSD_version has not been bumped), but it is really close and should be sufficient as a cut-off date for any practical purposes. Submitted by: Ian FREISLICH (modulo __FreeBSD_version check)
Diffstat (limited to 'misc')
-rw-r--r--misc/zaptel/Makefile2
-rw-r--r--misc/zaptel/files/patch-zaptel::zaptel.c21
2 files changed, 19 insertions, 4 deletions
diff --git a/misc/zaptel/Makefile b/misc/zaptel/Makefile
index 4fceaafd780f..f7740814896a 100644
--- a/misc/zaptel/Makefile
+++ b/misc/zaptel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= zaptel
PORTVERSION= 1.4.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc kld
MASTER_SITES= http://www.pbxpress.com/~gonzo/
DISTNAME= ${PORTNAME}-bsd-${PORTVERSION}
diff --git a/misc/zaptel/files/patch-zaptel::zaptel.c b/misc/zaptel/files/patch-zaptel::zaptel.c
index 6942f8fbdbe6..c8d4863017db 100644
--- a/misc/zaptel/files/patch-zaptel::zaptel.c
+++ b/misc/zaptel/files/patch-zaptel::zaptel.c
@@ -1,6 +1,9 @@
---- zaptel/zaptel.c.orig Sun Jun 25 14:21:49 2006
-+++ zaptel/zaptel.c Fri Aug 11 11:56:20 2006
-@@ -397,7 +397,7 @@
+
+$FreeBSD$
+
+--- zaptel/zaptel.c.orig
++++ zaptel/zaptel.c
+@@ -396,7 +396,7 @@
int schluffen(void *q)
{
@@ -9,3 +12,15 @@
switch(rc)
{
case EINTR:
+@@ -675,7 +675,11 @@
+ /* Free dev_info, if exist */
+ if(dev->si_drv2) free(dev->si_drv2, M_ZAP);
+ dev->si_drv2 = NULL;
++#if (__FreeBSD_version >= 700050)
++ destroy_dev_sched(dev);
++#else
+ destroy_dev(dev);
++#endif
+ return res;
+ }
+