aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-04-03 19:26:48 +0800
committermat <mat@FreeBSD.org>2015-04-03 19:26:48 +0800
commit0691688a506fc2dffc574eeeb80dc0d876378fed (patch)
tree204c01c7973e83331fc29d8b09e59b3e9f219bd6 /misc
parent33639ffbb666f12097ddeff5ef7da2226febf15b (diff)
downloadfreebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.tar.gz
freebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.tar.zst
freebsd-ports-gnome-0691688a506fc2dffc574eeeb80dc0d876378fed.zip
Remove OSVERSION checks that do not make sense any more.
For example (${OSVERSION} >= 900000 && ${OSVERSION} < 900021) is always true, as is (${OSVERSION} > 900002 || ${OSVERSION} < 900000 && ${OSVERSION} > 800107). Regarding patches, when an EXTRA_PATCHES is no longer needed, I remove it, when it is always needed, I renamed it, in one case, I merged two patches. Differential Revision: https://reviews.freebsd.org/D2209
Diffstat (limited to 'misc')
-rw-r--r--misc/amfm/Makefile8
-rw-r--r--misc/compat7x/Makefile4
-rw-r--r--misc/compat8x/Makefile4
-rw-r--r--misc/fxload/Makefile8
-rw-r--r--misc/usbrh-libusb/Makefile8
5 files changed, 3 insertions, 29 deletions
diff --git a/misc/amfm/Makefile b/misc/amfm/Makefile
index e9a82f5339d7..ae435de23041 100644
--- a/misc/amfm/Makefile
+++ b/misc/amfm/Makefile
@@ -17,18 +17,12 @@ LIB_DEPENDS= libhid.so:${PORTSDIR}/devel/libhid
NO_WRKSUBDIR= yes
-.include <bsd.port.pre.mk>
-
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS= -p
EXTRACT_AFTER_ARGS= ${WRKDIR}
-.if ${OSVERSION} <= 800097
-BROKEN= does not build
-.endif
-
do-install:
@${INSTALL} ${WRKSRC}/amfm ${STAGEDIR}${PREFIX}/bin/amfm
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/amfm
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/compat7x/Makefile b/misc/compat7x/Makefile
index 797043ba6c50..8868f0a1d01f 100644
--- a/misc/compat7x/Makefile
+++ b/misc/compat7x/Makefile
@@ -23,10 +23,6 @@ USE_LDCONFIG= ${TARGET_DIR}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-IGNORE= is for FreeBSD 7.x and newer
-.endif
-
.if ${ARCH} == amd64
PLIST_SUB+= LDCONFIG_LIB32="${LDCONFIG} -32"
USE_LDCONFIG32= ${TARGET32_DIR}
diff --git a/misc/compat8x/Makefile b/misc/compat8x/Makefile
index aea1e8d6d829..cbe2c0bce28d 100644
--- a/misc/compat8x/Makefile
+++ b/misc/compat8x/Makefile
@@ -24,10 +24,6 @@ USE_LDCONFIG= ${TARGET_DIR}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 800000
-IGNORE= is for FreeBSD 8.x and newer
-.endif
-
# libstdc++.so.6 could be necessary to run an 8.x binary
.if ${OSVERSION} >= 1000054
RUN_DEPENDS= ${LOCALBASE}/lib/compat/libstdc++.so.6:${PORTSDIR}/misc/compat9x
diff --git a/misc/fxload/Makefile b/misc/fxload/Makefile
index 47c8fbef987d..67627f0798c9 100644
--- a/misc/fxload/Makefile
+++ b/misc/fxload/Makefile
@@ -20,10 +20,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/a3load.hex ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${FILESDIR}/xilinx.conf ${STAGEDIR}${PREFIX}/etc/devd
-.include <bsd.port.pre.mk>
-
-.if (${OSVERSION} < 800069)
-BROKEN= doesn't build on FreeBSD prior libusb(8) integration to base system
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/usbrh-libusb/Makefile b/misc/usbrh-libusb/Makefile
index faff61b4a656..1269cc02dca0 100644
--- a/misc/usbrh-libusb/Makefile
+++ b/misc/usbrh-libusb/Makefile
@@ -14,13 +14,7 @@ COMMENT= Yet another reads temperatures and humidity from a Strawberry Linux USB
PLIST_FILES= bin/usbrh
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} <= 800097
-BROKEN= does not build
-.endif
-
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/usbrh ${STAGEDIR}${PREFIX}/bin/usbrh
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>