aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-07-04 11:17:37 +0800
committeradamw <adamw@FreeBSD.org>2003-07-04 11:17:37 +0800
commit0e6e60b2b0d59186c1a0366938e1ba93ef449455 (patch)
tree706d40b1a660b0baed4fef6662035b4c0014c3a3 /misc
parent7a97b1293c2e2b1a9791b943600bf7d25680bf42 (diff)
downloadfreebsd-ports-gnome-0e6e60b2b0d59186c1a0366938e1ba93ef449455.tar.gz
freebsd-ports-gnome-0e6e60b2b0d59186c1a0366938e1ba93ef449455.tar.zst
freebsd-ports-gnome-0e6e60b2b0d59186c1a0366938e1ba93ef449455.zip
Add talkfilters.
From the website: The GNU Talk Filters are filter programs that convert ordinary English text into text that mimics a stereotyped or otherwise humorous dialect. These filters have been in the public domain for many years, but now for the first time they are provided as a single integrated package. The filters include b1ff, brooklyn, chef, cockney, drawl, fudd, funetak, jethro, jive, kraut, pansy, postmodern, redneck, valspeak, and warez. Each program reads from standard input and writes to standard output. This version of the package also provides the filters as a C library, so they can be easily embedded in other programs.
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/talkfilters/Makefile23
-rw-r--r--misc/talkfilters/distinfo1
-rw-r--r--misc/talkfilters/files/patch-configure10
-rw-r--r--misc/talkfilters/pkg-descr9
-rw-r--r--misc/talkfilters/pkg-plist23
6 files changed, 67 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 1dface733b88..307ce0edfb63 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -333,6 +333,7 @@
SUBDIR += susv3
SUBDIR += sword
SUBDIR += sword-modules
+ SUBDIR += talkfilters
SUBDIR += tcb
SUBDIR += team
SUBDIR += telbook
diff --git a/misc/talkfilters/Makefile b/misc/talkfilters/Makefile
new file mode 100644
index 000000000000..031c84972932
--- /dev/null
+++ b/misc/talkfilters/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: talkfilters
+# Date created: 03 July 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= talkfilters
+PORTVERSION= 2.0.1
+CATEGORIES= misc
+MASTER_SITES= http://www2.dystance.net:8080/software/talkfilters/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Set of filters to convert English text to various stereotyped dialects
+
+CONFLICTS= jive* chef*
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+MAN1= talkfilters.1 wrap.1
+
+.include <bsd.port.mk>
diff --git a/misc/talkfilters/distinfo b/misc/talkfilters/distinfo
new file mode 100644
index 000000000000..82d8b4975460
--- /dev/null
+++ b/misc/talkfilters/distinfo
@@ -0,0 +1 @@
+MD5 (talkfilters-2.0.1.tar.gz) = d846b298aa3cf3698265408975dcbd41
diff --git a/misc/talkfilters/files/patch-configure b/misc/talkfilters/files/patch-configure
new file mode 100644
index 000000000000..a71ea36d3721
--- /dev/null
+++ b/misc/talkfilters/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Thu Jul 3 19:22:24 2003
++++ configure Thu Jul 3 19:22:53 2003
+@@ -8177,6 +8177,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/misc/talkfilters/pkg-descr b/misc/talkfilters/pkg-descr
new file mode 100644
index 000000000000..453c9a914cb4
--- /dev/null
+++ b/misc/talkfilters/pkg-descr
@@ -0,0 +1,9 @@
+The GNU Talk Filters are filter programs that convert ordinary English
+text into text that mimics a stereotyped or otherwise humorous dialect.
+These filters have been in the public domain for many years, but now for
+the first time they are provided as a single integrated package. The
+filters include b1ff, brooklyn, chef, cockney, drawl, fudd, funetak,
+jethro, jive, kraut, pansy, postmodern, redneck, valspeak, and warez.
+Each program reads from standard input and writes to standard output.
+
+WWW: http://www2.dystance.net:8080/software/talkfilters/
diff --git a/misc/talkfilters/pkg-plist b/misc/talkfilters/pkg-plist
new file mode 100644
index 000000000000..cbcc3d3d2637
--- /dev/null
+++ b/misc/talkfilters/pkg-plist
@@ -0,0 +1,23 @@
+bin/b1ff
+bin/brooklyn
+bin/chef
+bin/cockney
+bin/drawl
+bin/fudd
+bin/funetak
+bin/jethro
+bin/jive
+bin/kraut
+bin/pansy
+bin/postmodern
+bin/redneck
+bin/valspeak
+bin/warez
+bin/wrap
+include/talkfilters.h
+@unexec install-info --delete %D/info/talkfilters.info %D/info/dir
+info/talkfilters.info
+@exec install-info %D/info/talkfilters.info %D/info/dir
+lib/libtalkfilters.a
+lib/libtalkfilters.so
+lib/libtalkfilters.so.0