aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-11-28 00:44:31 +0800
committersobomax <sobomax@FreeBSD.org>2000-11-28 00:44:31 +0800
commit1e4dc72333661be25407ae530773ecab39d9de5c (patch)
treefd6ec6aad41d9f822f2df68e7c67d02f1b96135d /misc
parent289d9b5508b99254600ce7ca2e7e9e241315a1c4 (diff)
downloadfreebsd-ports-gnome-1e4dc72333661be25407ae530773ecab39d9de5c.tar.gz
freebsd-ports-gnome-1e4dc72333661be25407ae530773ecab39d9de5c.tar.zst
freebsd-ports-gnome-1e4dc72333661be25407ae530773ecab39d9de5c.zip
Add another monster from Helixcode - Metatheme, an utility for managing "theme
sets" that accomodate gtk, window manager, etc.
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/metatheme/Makefile40
-rw-r--r--misc/metatheme/distinfo1
-rw-r--r--misc/metatheme/files/patch-aa11
-rw-r--r--misc/metatheme/files/patch-ab11
-rw-r--r--misc/metatheme/files/patch-ac11
-rw-r--r--misc/metatheme/files/patch-ad11
-rw-r--r--misc/metatheme/files/patch-ae11
-rw-r--r--misc/metatheme/files/patch-af21
-rw-r--r--misc/metatheme/files/patch-ag15
-rw-r--r--misc/metatheme/files/patch-ah11
-rw-r--r--misc/metatheme/pkg-comment1
-rw-r--r--misc/metatheme/pkg-descr2
-rw-r--r--misc/metatheme/pkg-plist47
-rw-r--r--misc/metatheme2/Makefile40
-rw-r--r--misc/metatheme2/distinfo1
-rw-r--r--misc/metatheme2/files/patch-aa11
-rw-r--r--misc/metatheme2/files/patch-ab11
-rw-r--r--misc/metatheme2/files/patch-ac11
-rw-r--r--misc/metatheme2/files/patch-ad11
-rw-r--r--misc/metatheme2/files/patch-ae11
-rw-r--r--misc/metatheme2/files/patch-af21
-rw-r--r--misc/metatheme2/files/patch-ag15
-rw-r--r--misc/metatheme2/files/patch-ah11
-rw-r--r--misc/metatheme2/pkg-comment1
-rw-r--r--misc/metatheme2/pkg-descr2
-rw-r--r--misc/metatheme2/pkg-plist47
27 files changed, 387 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index b968c902f84d..5d314a8afec6 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -91,6 +91,7 @@
SUBDIR += magicpoint
SUBDIR += man.el
SUBDIR += mc
+ SUBDIR += metatheme
SUBDIR += mgp-mode.el
SUBDIR += mmv
SUBDIR += most
diff --git a/misc/metatheme/Makefile b/misc/metatheme/Makefile
new file mode 100644
index 000000000000..abb2047de844
--- /dev/null
+++ b/misc/metatheme/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: metatheme
+# Date created: 25 November 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= metatheme
+PORTVERSION= 0.5.0
+CATEGORIES= misc gnome
+MASTER_SITES= ftp://ftp.helixcode.com/pub/metatheme/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= gtkhtml.5:${PORTSDIR}/www/gtkhtml \
+ gal.1:${PORTSDIR}/x11-toolkits/gal \
+ gnet.0:${PORTSDIR}/net/gnet
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+post-configure:
+.for file in gtk/gtk-plugin.c background/background-plugin.c sawfish/sawfish-plugin.c
+ @${PERL} -pi -e 's|%%GTK_CONFIG%%|${GTK_CONFIG}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g ; s|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/plugins/${file}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/misc/metatheme/distinfo b/misc/metatheme/distinfo
new file mode 100644
index 000000000000..bd73cd41eb19
--- /dev/null
+++ b/misc/metatheme/distinfo
@@ -0,0 +1 @@
+MD5 (metatheme-0.5.0.tar.gz) = e3e5f9a57d58e132092b9c16b877c8ae
diff --git a/misc/metatheme/files/patch-aa b/misc/metatheme/files/patch-aa
new file mode 100644
index 000000000000..c12316601bc7
--- /dev/null
+++ b/misc/metatheme/files/patch-aa
@@ -0,0 +1,11 @@
+--- mtm-ui/Makefile.in 2000/11/25 22:18:16 1.1
++++ mtm-ui/Makefile.in 2000/11/25 22:22:42
+@@ -149,7 +149,7 @@
+
+
+ test_selector_SOURCES = test-selector.c
+-test_selector_LDFLAGS = `gnome-config --libs xml gnome` `gtk-config --libs`
++test_selector_LDFLAGS = @GNOME_LIBS@ @GTK_LIBS@ @EXTRA_LIBS@
+
+
+ test_selector_LDADD = ../mtm/libmtm.la libmtm-ui.la
diff --git a/misc/metatheme/files/patch-ab b/misc/metatheme/files/patch-ab
new file mode 100644
index 000000000000..3535dde01329
--- /dev/null
+++ b/misc/metatheme/files/patch-ab
@@ -0,0 +1,11 @@
+--- plugins/gtk/Makefile.in 2000/11/26 21:12:29 1.1
++++ plugins/gtk/Makefile.in 2000/11/26 21:12:58
+@@ -148,7 +148,7 @@
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+-libgtk_la_LDFLAGS =
++libgtk_la_LDFLAGS = -module -avoid-version
+ libgtk_la_LIBADD =
+ libgtk_la_OBJECTS = gtk-plugin.lo
+ CFLAGS = @CFLAGS@
diff --git a/misc/metatheme/files/patch-ac b/misc/metatheme/files/patch-ac
new file mode 100644
index 000000000000..b34e96ee8945
--- /dev/null
+++ b/misc/metatheme/files/patch-ac
@@ -0,0 +1,11 @@
+--- plugins/background/Makefile.in 2000/11/26 21:12:29 1.1
++++ plugins/background/Makefile.in 2000/11/26 21:13:03
+@@ -150,7 +150,7 @@
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+-libbackground_la_LDFLAGS =
++libbackground_la_LDFLAGS = -module -avoid-version
+ libbackground_la_DEPENDENCIES =
+ libbackground_la_OBJECTS = background-plugin.lo config-io.lo \
+ bg-ext-handler.lo
diff --git a/misc/metatheme/files/patch-ad b/misc/metatheme/files/patch-ad
new file mode 100644
index 000000000000..015bddfcccf5
--- /dev/null
+++ b/misc/metatheme/files/patch-ad
@@ -0,0 +1,11 @@
+--- plugins/sawfish/Makefile.in 2000/11/26 21:12:29 1.1
++++ plugins/sawfish/Makefile.in 2000/11/26 21:13:06
+@@ -148,7 +148,7 @@
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+-libsawfish_la_LDFLAGS =
++libsawfish_la_LDFLAGS = -module -avoid-version
+ libsawfish_la_LIBADD =
+ libsawfish_la_OBJECTS = sawfish-plugin.lo
+ CFLAGS = @CFLAGS@
diff --git a/misc/metatheme/files/patch-ae b/misc/metatheme/files/patch-ae
new file mode 100644
index 000000000000..2c014ca52fcd
--- /dev/null
+++ b/misc/metatheme/files/patch-ae
@@ -0,0 +1,11 @@
+--- plugins/preview/Makefile.in 2000/11/26 21:12:29 1.1
++++ plugins/preview/Makefile.in 2000/11/26 21:13:09
+@@ -148,7 +148,7 @@
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+-libpreview_la_LDFLAGS =
++libpreview_la_LDFLAGS = -module -avoid-version
+ libpreview_la_LIBADD =
+ libpreview_la_OBJECTS = preview-plugin.lo
+ CFLAGS = @CFLAGS@
diff --git a/misc/metatheme/files/patch-af b/misc/metatheme/files/patch-af
new file mode 100644
index 000000000000..572e38b524b2
--- /dev/null
+++ b/misc/metatheme/files/patch-af
@@ -0,0 +1,21 @@
+--- plugins/gtk/gtk-plugin.c 2000/11/26 21:25:12 1.1
++++ plugins/gtk/gtk-plugin.c 2000/11/26 21:27:39
+@@ -375,15 +375,15 @@
+
+ /* This should be more robust.
+ * Perhaps we could make this user-configurable somehow. */
+- pipe = popen ("gtk-config --prefix", "r");
++ pipe = popen ("%%GTK_CONFIG%% --prefix", "r");
+ if (pipe == NULL)
+- return g_strdup ("/usr");
++ return g_strdup ("%%X11BASE%%");
+
+ fgets (prefix, 1000, pipe);
+ pclose (pipe);
+
+ if (prefix == NULL)
+- return g_strdup ("/usr");
++ return g_strdup ("%%X11BASE%%");
+
+ return g_strchomp (g_strdup (prefix));
+ }
diff --git a/misc/metatheme/files/patch-ag b/misc/metatheme/files/patch-ag
new file mode 100644
index 000000000000..7e22f7655ec9
--- /dev/null
+++ b/misc/metatheme/files/patch-ag
@@ -0,0 +1,15 @@
+--- plugins/background/background-plugin.c 2000/11/26 21:31:41 1.1
++++ plugins/background/background-plugin.c 2000/11/26 21:33:54
+@@ -227,9 +227,9 @@
+ bg_plugin_find_theme (MtmExtHandler *handler, gchar *name,
+ gboolean is_root)
+ {
+- gchar *root_prefixes[] = {"/usr/share/pixmaps/backgrounds",
+- "/usr/share/pixmaps/backgrounds/tiles",
+- "/usr/share/wallpapers",
++ gchar *root_prefixes[] = {"%%X11BASE%%/share/gnome/pixmaps/backgrounds",
++ "%%X11BASE%%/share/gnome/pixmaps/backgrounds/tiles",
++ "%%X11BASE%%/share/gnome/wallpapers",
+ NULL};
+ gchar *user_prefixes[] = {".metatheme-backgrounds",
+ ".backgrounds",
diff --git a/misc/metatheme/files/patch-ah b/misc/metatheme/files/patch-ah
new file mode 100644
index 000000000000..f076ab19267e
--- /dev/null
+++ b/misc/metatheme/files/patch-ah
@@ -0,0 +1,11 @@
+--- plugins/sawfish/sawfish-plugin.c 2000/11/26 21:31:47 1.1
++++ plugins/sawfish/sawfish-plugin.c 2000/11/26 21:35:26
+@@ -227,7 +227,7 @@
+ gchar *name, gboolean is_root)
+ {
+ gchar *root_prefixes[] = {"share/sawfish/themes", NULL};
+- gchar *pre_prefixes[] = {"/usr/", "/usr/local/", NULL};
++ gchar *pre_prefixes[] = {"%%X11BASE%%", "%%LOCALBASE%%", NULL};
+ gchar *user_prefixes[] = {".sawfish/themes", NULL};
+ gchar **arr;
+ gchar *ret;
diff --git a/misc/metatheme/pkg-comment b/misc/metatheme/pkg-comment
new file mode 100644
index 000000000000..bdf3a130402e
--- /dev/null
+++ b/misc/metatheme/pkg-comment
@@ -0,0 +1 @@
+An utility for managing "theme sets" that accomodate gtk, window manager, etc
diff --git a/misc/metatheme/pkg-descr b/misc/metatheme/pkg-descr
new file mode 100644
index 000000000000..c274d57c6423
--- /dev/null
+++ b/misc/metatheme/pkg-descr
@@ -0,0 +1,2 @@
+This is metatheme, an application for managing "theme sets" that accomodate
+gtk+, your window manager, etc etc.
diff --git a/misc/metatheme/pkg-plist b/misc/metatheme/pkg-plist
new file mode 100644
index 000000000000..4e40d234ef0c
--- /dev/null
+++ b/misc/metatheme/pkg-plist
@@ -0,0 +1,47 @@
+bin/metatheme-edit
+bin/metatheme-install
+bin/metatheme_selector_capplet
+include/mtm-ui/mtm-ext-selector.h
+include/mtm/mtm-env.h
+include/mtm/mtm-ext-handler.h
+include/mtm/mtm-ext.h
+include/mtm/mtm-handler.h
+include/mtm/mtm-init.h
+include/mtm/mtm-plugin.h
+include/mtm/mtm-stateful.h
+include/mtm/mtm-theme-ball.h
+include/mtm/mtm-theme.h
+include/mtm/mtm-util.h
+include/mtm/mtm.h
+lib/libmtm-ui.a
+lib/libmtm-ui.so
+lib/libmtm-ui.so.0
+lib/libmtm.a
+lib/libmtm.so
+lib/libmtm.so.0
+lib/metatheme/plugins/libbackground.so
+lib/metatheme/plugins/libgtk.so
+lib/metatheme/plugins/libpreview.so
+lib/metatheme/plugins/libsawfish.so
+share/gnome/apps/Applications/metatheme-edit.desktop
+share/gnome/apps/Settings/Desktop/metatheme_selector.desktop
+share/gnome/control-center/Desktop/metatheme_selector.desktop
+share/gnome/mime-info/metatheme-edit.keys
+share/gnome/mime-info/metatheme-install.keys
+share/gnome/mime-info/metatheme.keys
+share/gnome/mime-info/metatheme.mime
+share/gnome/pixmaps/gnome-application-x-metatheme.png
+share/locale/da/LC_MESSAGES/metatheme.mo
+share/locale/fr/LC_MESSAGES/metatheme.mo
+share/locale/pt_BR/LC_MESSAGES/metatheme.mo
+share/locale/tr/LC_MESSAGES/metatheme.mo
+share/metatheme-glade/metatheme-edit.glade
+share/metatheme-glade/metatheme-install.glade
+share/metatheme-glade/mtm-sel.glade
+share/metathemes/default.mtm
+@dirrm share/metathemes
+@dirrm share/metatheme-glade
+@dirrm lib/metatheme/plugins
+@dirrm lib/metatheme
+@dirrm include/mtm-ui
+@dirrm include/mtm
diff --git a/misc/metatheme2/Makefile b/misc/metatheme2/Makefile
new file mode 100644
index 000000000000..abb2047de844
--- /dev/null
+++ b/misc/metatheme2/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: metatheme
+# Date created: 25 November 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= metatheme
+PORTVERSION= 0.5.0
+CATEGORIES= misc gnome
+MASTER_SITES= ftp://ftp.helixcode.com/pub/metatheme/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= gtkhtml.5:${PORTSDIR}/www/gtkhtml \
+ gal.1:${PORTSDIR}/x11-toolkits/gal \
+ gnet.0:${PORTSDIR}/net/gnet
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+post-configure:
+.for file in gtk/gtk-plugin.c background/background-plugin.c sawfish/sawfish-plugin.c
+ @${PERL} -pi -e 's|%%GTK_CONFIG%%|${GTK_CONFIG}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g ; s|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/plugins/${file}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/misc/metatheme2/distinfo b/misc/metatheme2/distinfo
new file mode 100644
index 000000000000..bd73cd41eb19
--- /dev/null
+++ b/misc/metatheme2/distinfo
@@ -0,0 +1 @@
+MD5 (metatheme-0.5.0.tar.gz) = e3e5f9a57d58e132092b9c16b877c8ae
diff --git a/misc/metatheme2/files/patch-aa b/misc/metatheme2/files/patch-aa
new file mode 100644
index 000000000000..c12316601bc7
--- /dev/null
+++ b/misc/metatheme2/files/patch-aa
@@ -0,0 +1,11 @@
+--- mtm-ui/Makefile.in 2000/11/25 22:18:16 1.1
++++ mtm-ui/Makefile.in 2000/11/25 22:22:42
+@@ -149,7 +149,7 @@
+
+
+ test_selector_SOURCES = test-selector.c
+-test_selector_LDFLAGS = `gnome-config --libs xml gnome` `gtk-config --libs`
++test_selector_LDFLAGS = @GNOME_LIBS@ @GTK_LIBS@ @EXTRA_LIBS@
+
+
+ test_selector_LDADD = ../mtm/libmtm.la libmtm-ui.la
diff --git a/misc/metatheme2/files/patch-ab b/misc/metatheme2/files/patch-ab
new file mode 100644
index 000000000000..3535dde01329
--- /dev/null
+++ b/misc/metatheme2/files/patch-ab
@@ -0,0 +1,11 @@
+--- plugins/gtk/Makefile.in 2000/11/26 21:12:29 1.1
++++ plugins/gtk/Makefile.in 2000/11/26 21:12:58
+@@ -148,7 +148,7 @@
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+-libgtk_la_LDFLAGS =
++libgtk_la_LDFLAGS = -module -avoid-version
+ libgtk_la_LIBADD =
+ libgtk_la_OBJECTS = gtk-plugin.lo
+ CFLAGS = @CFLAGS@
diff --git a/misc/metatheme2/files/patch-ac b/misc/metatheme2/files/patch-ac
new file mode 100644
index 000000000000..b34e96ee8945
--- /dev/null
+++ b/misc/metatheme2/files/patch-ac
@@ -0,0 +1,11 @@
+--- plugins/background/Makefile.in 2000/11/26 21:12:29 1.1
++++ plugins/background/Makefile.in 2000/11/26 21:13:03
+@@ -150,7 +150,7 @@
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+-libbackground_la_LDFLAGS =
++libbackground_la_LDFLAGS = -module -avoid-version
+ libbackground_la_DEPENDENCIES =
+ libbackground_la_OBJECTS = background-plugin.lo config-io.lo \
+ bg-ext-handler.lo
diff --git a/misc/metatheme2/files/patch-ad b/misc/metatheme2/files/patch-ad
new file mode 100644
index 000000000000..015bddfcccf5
--- /dev/null
+++ b/misc/metatheme2/files/patch-ad
@@ -0,0 +1,11 @@
+--- plugins/sawfish/Makefile.in 2000/11/26 21:12:29 1.1
++++ plugins/sawfish/Makefile.in 2000/11/26 21:13:06
+@@ -148,7 +148,7 @@
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+-libsawfish_la_LDFLAGS =
++libsawfish_la_LDFLAGS = -module -avoid-version
+ libsawfish_la_LIBADD =
+ libsawfish_la_OBJECTS = sawfish-plugin.lo
+ CFLAGS = @CFLAGS@
diff --git a/misc/metatheme2/files/patch-ae b/misc/metatheme2/files/patch-ae
new file mode 100644
index 000000000000..2c014ca52fcd
--- /dev/null
+++ b/misc/metatheme2/files/patch-ae
@@ -0,0 +1,11 @@
+--- plugins/preview/Makefile.in 2000/11/26 21:12:29 1.1
++++ plugins/preview/Makefile.in 2000/11/26 21:13:09
+@@ -148,7 +148,7 @@
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+-libpreview_la_LDFLAGS =
++libpreview_la_LDFLAGS = -module -avoid-version
+ libpreview_la_LIBADD =
+ libpreview_la_OBJECTS = preview-plugin.lo
+ CFLAGS = @CFLAGS@
diff --git a/misc/metatheme2/files/patch-af b/misc/metatheme2/files/patch-af
new file mode 100644
index 000000000000..572e38b524b2
--- /dev/null
+++ b/misc/metatheme2/files/patch-af
@@ -0,0 +1,21 @@
+--- plugins/gtk/gtk-plugin.c 2000/11/26 21:25:12 1.1
++++ plugins/gtk/gtk-plugin.c 2000/11/26 21:27:39
+@@ -375,15 +375,15 @@
+
+ /* This should be more robust.
+ * Perhaps we could make this user-configurable somehow. */
+- pipe = popen ("gtk-config --prefix", "r");
++ pipe = popen ("%%GTK_CONFIG%% --prefix", "r");
+ if (pipe == NULL)
+- return g_strdup ("/usr");
++ return g_strdup ("%%X11BASE%%");
+
+ fgets (prefix, 1000, pipe);
+ pclose (pipe);
+
+ if (prefix == NULL)
+- return g_strdup ("/usr");
++ return g_strdup ("%%X11BASE%%");
+
+ return g_strchomp (g_strdup (prefix));
+ }
diff --git a/misc/metatheme2/files/patch-ag b/misc/metatheme2/files/patch-ag
new file mode 100644
index 000000000000..7e22f7655ec9
--- /dev/null
+++ b/misc/metatheme2/files/patch-ag
@@ -0,0 +1,15 @@
+--- plugins/background/background-plugin.c 2000/11/26 21:31:41 1.1
++++ plugins/background/background-plugin.c 2000/11/26 21:33:54
+@@ -227,9 +227,9 @@
+ bg_plugin_find_theme (MtmExtHandler *handler, gchar *name,
+ gboolean is_root)
+ {
+- gchar *root_prefixes[] = {"/usr/share/pixmaps/backgrounds",
+- "/usr/share/pixmaps/backgrounds/tiles",
+- "/usr/share/wallpapers",
++ gchar *root_prefixes[] = {"%%X11BASE%%/share/gnome/pixmaps/backgrounds",
++ "%%X11BASE%%/share/gnome/pixmaps/backgrounds/tiles",
++ "%%X11BASE%%/share/gnome/wallpapers",
+ NULL};
+ gchar *user_prefixes[] = {".metatheme-backgrounds",
+ ".backgrounds",
diff --git a/misc/metatheme2/files/patch-ah b/misc/metatheme2/files/patch-ah
new file mode 100644
index 000000000000..f076ab19267e
--- /dev/null
+++ b/misc/metatheme2/files/patch-ah
@@ -0,0 +1,11 @@
+--- plugins/sawfish/sawfish-plugin.c 2000/11/26 21:31:47 1.1
++++ plugins/sawfish/sawfish-plugin.c 2000/11/26 21:35:26
+@@ -227,7 +227,7 @@
+ gchar *name, gboolean is_root)
+ {
+ gchar *root_prefixes[] = {"share/sawfish/themes", NULL};
+- gchar *pre_prefixes[] = {"/usr/", "/usr/local/", NULL};
++ gchar *pre_prefixes[] = {"%%X11BASE%%", "%%LOCALBASE%%", NULL};
+ gchar *user_prefixes[] = {".sawfish/themes", NULL};
+ gchar **arr;
+ gchar *ret;
diff --git a/misc/metatheme2/pkg-comment b/misc/metatheme2/pkg-comment
new file mode 100644
index 000000000000..bdf3a130402e
--- /dev/null
+++ b/misc/metatheme2/pkg-comment
@@ -0,0 +1 @@
+An utility for managing "theme sets" that accomodate gtk, window manager, etc
diff --git a/misc/metatheme2/pkg-descr b/misc/metatheme2/pkg-descr
new file mode 100644
index 000000000000..c274d57c6423
--- /dev/null
+++ b/misc/metatheme2/pkg-descr
@@ -0,0 +1,2 @@
+This is metatheme, an application for managing "theme sets" that accomodate
+gtk+, your window manager, etc etc.
diff --git a/misc/metatheme2/pkg-plist b/misc/metatheme2/pkg-plist
new file mode 100644
index 000000000000..4e40d234ef0c
--- /dev/null
+++ b/misc/metatheme2/pkg-plist
@@ -0,0 +1,47 @@
+bin/metatheme-edit
+bin/metatheme-install
+bin/metatheme_selector_capplet
+include/mtm-ui/mtm-ext-selector.h
+include/mtm/mtm-env.h
+include/mtm/mtm-ext-handler.h
+include/mtm/mtm-ext.h
+include/mtm/mtm-handler.h
+include/mtm/mtm-init.h
+include/mtm/mtm-plugin.h
+include/mtm/mtm-stateful.h
+include/mtm/mtm-theme-ball.h
+include/mtm/mtm-theme.h
+include/mtm/mtm-util.h
+include/mtm/mtm.h
+lib/libmtm-ui.a
+lib/libmtm-ui.so
+lib/libmtm-ui.so.0
+lib/libmtm.a
+lib/libmtm.so
+lib/libmtm.so.0
+lib/metatheme/plugins/libbackground.so
+lib/metatheme/plugins/libgtk.so
+lib/metatheme/plugins/libpreview.so
+lib/metatheme/plugins/libsawfish.so
+share/gnome/apps/Applications/metatheme-edit.desktop
+share/gnome/apps/Settings/Desktop/metatheme_selector.desktop
+share/gnome/control-center/Desktop/metatheme_selector.desktop
+share/gnome/mime-info/metatheme-edit.keys
+share/gnome/mime-info/metatheme-install.keys
+share/gnome/mime-info/metatheme.keys
+share/gnome/mime-info/metatheme.mime
+share/gnome/pixmaps/gnome-application-x-metatheme.png
+share/locale/da/LC_MESSAGES/metatheme.mo
+share/locale/fr/LC_MESSAGES/metatheme.mo
+share/locale/pt_BR/LC_MESSAGES/metatheme.mo
+share/locale/tr/LC_MESSAGES/metatheme.mo
+share/metatheme-glade/metatheme-edit.glade
+share/metatheme-glade/metatheme-install.glade
+share/metatheme-glade/mtm-sel.glade
+share/metathemes/default.mtm
+@dirrm share/metathemes
+@dirrm share/metatheme-glade
+@dirrm lib/metatheme/plugins
+@dirrm lib/metatheme
+@dirrm include/mtm-ui
+@dirrm include/mtm