aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-01-01 02:24:10 +0800
committernetchild <netchild@FreeBSD.org>2005-01-01 02:24:10 +0800
commit41aa99b87f1fc1de75ee54ee38b4782ee393704b (patch)
tree377e4c9c9dd556f0b4785f3df7b930015778713f /misc
parent0a7250c8120524f20b14e530af6f7eddf2e77d1e (diff)
downloadfreebsd-ports-gnome-41aa99b87f1fc1de75ee54ee38b4782ee393704b.tar.gz
freebsd-ports-gnome-41aa99b87f1fc1de75ee54ee38b4782ee393704b.tar.zst
freebsd-ports-gnome-41aa99b87f1fc1de75ee54ee38b4782ee393704b.zip
Say hello to the linux mega patch, it consolidates our linux bits a
little bit and allows to proceed to a more recent linux_base from a stable (read as: the major bugs should be ironed out or identified and most linux ports build just fine) source. It also allows to ship 4.11 with a working linuxolator (the EOLed linux_base is marked forbidden because of a security hole). This is a major update, please read UPDATING (and CHANGES if you develop linux ports). Changes: - change the default linux_base from v7 to v8 - add a newer freetype to linux_base-8 for nicer fonts display [1] - don't let cpio use hardlinks in the linux_base-8 port to quiet some warnings in some cases [2] - fix a cut&past error in the linux_base-8 pkg-install script [3] - convert the binary knob "USE_LINUX" to a version specifier, e.g. USE_LINUX=<value> specifies a dependency upon emulators/linux_base-<value>, exceptions are a value of "7" (which does what you want and adds a dependency to linux_base) and any value without a corresponding port in PORTSDIR/emulators/linux_base-<value> (which adds a dependency to the default linux_base) - don't implicitly add USE_LINUX with the USE_LINUX_PREFIX knob, this allows us to use the USE_LINUX_PREFIX knob for linux_base and paves the way for splitting up future linux base ports into individual pieces - remove RESTRICTED from some GPL licensed ports, even when we only distribute binaries, we get them from official linux sites, so anyone can grab them there if he needs to - add a dependency upon the linux X11 bits where necessary (based upon guesswork) - don't use USE_X_PREFIX in some linux ports since it adds a dependency to the FreeBSD X11 libs, as a workaround use PREFIX?= (the clean solution would be to remove the implicit USE_XLIB from USE_X_PREFIX) - bump the portrevision of the linux ports ("better safe than sorry" algorithm) - pass maintainership of the important linux infrastructure to a mailinglist, hijack freebsd-emulation@ for this purpose (if somebody doesn't like this: tell us your bikeshed color at freebsd-emulation@, my color would be "linuxolator@" in case someone cares...) - add a pkg-install script for linux-fontconfig, but don't use it; everything should work without it (the FreeBSD fc-cache program should do all the work), but in case we need it we just need to decomment the pkg-install part in the Makefile - fix some dependencies - fix some bugs - add some static plists - unbreak the ports with dependecies to more than one linux_base This also fixes some ports which are marked BROKEN because of dependencies to v7 and v8 of linux_base at the same time. Known bugs: - the linux-mesa and linux-devtools ports install libGL*.so symlinks - some "minor" plist bugs (e.g. ld.so.{conf,cache} are modified by the linux X11 port, so linx_Base-8 moans at deinstall time) Future work (interested souls should coordinate with freebsd-emulation@): - add some kind of USE_LINUX_X11 knob to streamline the X11 dependencies, or modify the behavior of USE_XLIB in the USE_LINUX case AFAIK trevor has some patches. - make USE_XLIB and USE_X_PREFIX orthogonal to be able to get rid of the PREFIX?= workaround in some linux ports Should be discussed/coordinated on/with x11@. - move the RPM bits from x11-toolkits/linux-gtk/Makefile to PORTSDIR/Mk/ - update to a more recent linux base PR: 69997, 70539 (and maybe others) Discussed with/on: java@, x11@, trevor, portmgr Tested by: mezz, portmgr, pointyhat RPM hunted down by: Joseph Gelinas <scirocco@tasam.com> [1] Requested by: portmgr [2] Submitted by: kris [3] Approved by: portmgr
Diffstat (limited to 'misc')
-rw-r--r--misc/ftree/Makefile4
-rw-r--r--misc/linux-edonkey-tool-list/Makefile1
-rw-r--r--misc/linux-edonkey-tool-recovermet/Makefile1
-rw-r--r--misc/linux-opengroupware/Makefile4
-rw-r--r--misc/opencyc/Makefile5
5 files changed, 11 insertions, 4 deletions
diff --git a/misc/ftree/Makefile b/misc/ftree/Makefile
index 4a6fa641f69f..fdab850179a5 100644
--- a/misc/ftree/Makefile
+++ b/misc/ftree/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ftree
PORTVERSION= 1.9
+PORTREVISION= 1
CATEGORIES= misc linux
MASTER_SITES= http://www.vjet.demon.co.uk/ftree/ \
http://www.unknown.nu/ports/
@@ -16,9 +17,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= user@unknown.nu
COMMENT= An X11 genealogy program
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+
USE_LINUX= yes
USE_X_PREFIX= yes
-USE_XLIB= no
ONLY_FOR_ARCHS= i386
NO_CDROM= Non-commercial use only
diff --git a/misc/linux-edonkey-tool-list/Makefile b/misc/linux-edonkey-tool-list/Makefile
index e337adb727aa..8f208f683aa7 100644
--- a/misc/linux-edonkey-tool-list/Makefile
+++ b/misc/linux-edonkey-tool-list/Makefile
@@ -7,6 +7,7 @@
PORTNAME= edonkey
PORTVERSION= 0.0.1
+PORTREVISION= 1
CATEGORIES= misc linux
MASTER_SITES= http://users.aber.ac.uk/tpm01/ed2k_tools/
PKGNAMEPREFIX= linux-
diff --git a/misc/linux-edonkey-tool-recovermet/Makefile b/misc/linux-edonkey-tool-recovermet/Makefile
index c8ea3c79b7c3..86512d25fb75 100644
--- a/misc/linux-edonkey-tool-recovermet/Makefile
+++ b/misc/linux-edonkey-tool-recovermet/Makefile
@@ -7,6 +7,7 @@
PORTNAME= edonkey
PORTVERSION= 0.0.2
+PORTREVISION= 1
CATEGORIES= misc linux
MASTER_SITES= http://users.aber.ac.uk/tpm01/ed2k_tools/
PKGNAMEPREFIX= linux-
diff --git a/misc/linux-opengroupware/Makefile b/misc/linux-opengroupware/Makefile
index 8d85df6fb267..2cf673cf5304 100644
--- a/misc/linux-opengroupware/Makefile
+++ b/misc/linux-opengroupware/Makefile
@@ -6,7 +6,7 @@
PORTNAME= opengroupware
PORTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc www linux
MASTER_SITES= http://download.opengroupware.org/packages/freebsd/linux-opengroupware/RPMS/:ogo \
http://download.opengroupware.org/packages/freebsd/linux-opengroupware/NGOBJWEB/:ngo \
@@ -21,10 +21,10 @@ EXTRACT_ONLY= ${NGOBJWEB_ADAPTOR}
MAINTAINER= frank@opengroupware.org
COMMENT= Groupware package including mail, calendar, palm sync and much more
+EXTRACT_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm
INSTALL_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2 \
${LOCALBASE}/bin/psql:${PORTSDIR}/databases/postgresql7 \
${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash2 \
- ${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8 \
${LOCALBASE}/bin/gmake:${PORTSDIR}/devel/gmake
#BEGINSET1
diff --git a/misc/opencyc/Makefile b/misc/opencyc/Makefile
index 05cf657887be..a53d6fe1efe0 100644
--- a/misc/opencyc/Makefile
+++ b/misc/opencyc/Makefile
@@ -7,7 +7,8 @@
PORTNAME= opencyc
PORTVERSION= 0.7.0
-CATEGORIES= misc
+PORTREVISION= 1
+CATEGORIES= misc linux
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
EXTRACT_SUFX= .tgz
@@ -15,6 +16,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= alexs@snark.rinet.ru
COMMENT= General knowledge base and commonsense reasoning engine
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+
NO_BUILD= yes
USE_LINUX= yes