aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-12-14 00:47:28 +0800
committermarcus <marcus@FreeBSD.org>2006-12-14 00:47:28 +0800
commit42c064e3ac9540867598c47f72751543f93a5879 (patch)
tree8ae63d289c8498cfcc3993ddedaf45e993bf013e /misc
parenta9b4fd99ba6f0a4226084babcb8cef7b72df8284 (diff)
downloadfreebsd-ports-gnome-42c064e3ac9540867598c47f72751543f93a5879.tar.gz
freebsd-ports-gnome-42c064e3ac9540867598c47f72751543f93a5879.tar.zst
freebsd-ports-gnome-42c064e3ac9540867598c47f72751543f93a5879.zip
Fix a bug that would duplicate a path element in XDG_DATA_DIRS when
KDE_PREFIX == LOCALBASE. This triggered memory corruption in the xdgmime code used by GTK+ and gnome-vfs which led to strange crashes in GTK+ applications such as Firefox and Thunderbird. While here, add a missing XDG_DATA_DIRS entry for LOCALBASE/share/gnome. Approved by: kde (lofi)
Diffstat (limited to 'misc')
-rw-r--r--misc/kde-xdg-env/Makefile2
-rw-r--r--misc/kde-xdg-env/files/xdg-env.sh.in22
-rw-r--r--misc/kde4-xdg-env/Makefile2
-rw-r--r--misc/kde4-xdg-env/files/xdg-env.sh.in22
4 files changed, 36 insertions, 12 deletions
diff --git a/misc/kde-xdg-env/Makefile b/misc/kde-xdg-env/Makefile
index d8f33ee0df7c..f5ba6eef59df 100644
--- a/misc/kde-xdg-env/Makefile
+++ b/misc/kde-xdg-env/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xdg
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= misc kde
MASTER_SITES= # none
diff --git a/misc/kde-xdg-env/files/xdg-env.sh.in b/misc/kde-xdg-env/files/xdg-env.sh.in
index 8d48d5ff3def..394d578ae71f 100644
--- a/misc/kde-xdg-env/files/xdg-env.sh.in
+++ b/misc/kde-xdg-env/files/xdg-env.sh.in
@@ -4,12 +4,24 @@
#
# Submit missing XDG-file locations to kde@freebsd.org!
-export XDG_CONFIG_DIRS=\
+XDG_CONFIG_DIRS=\
${XDG_CONFIG_DIRS}:/etc/xdg:%%LOCALBASE%%/etc/xdg:%%X11BASE%%/etc/xdg:\
-%%LOCALBASE%%/etc/xdg/xfce4:%%KDE_PREFIX%%/etc/xdg
+%%LOCALBASE%%/etc/xdg/xfce4
-export XDG_DATA_DIRS=\
-${XDG_DATA_DIRS}:/usr/share:%%LOCALBASE%%/share:\
-%%X11BASE%%/share:%%X11BASE%%/share/gnome:%%KDE_PREFIX%%/share
+if [ %%KDE_PREFIX%% != %%LOCALBASE%% ]; then
+ XDG_CONFIG_DIRS=${XDG_CONFIG_DIRS}:%%KDE_PREFIX%%/etc/xdg
+fi
+
+export XDG_CONFIG_DIRS
+
+XDG_DATA_DIRS=\
+${XDG_DATA_DIRS}:/usr/share:%%LOCALBASE%%/share:%%LOCALBASE%%/share/gnome:\
+%%X11BASE%%/share:%%X11BASE%%/share/gnome
+
+if [ %%KDE_PREFIX%% != %%LOCALBASE%% ]; then
+ XDG_DATA_DIRS=${XDG_DATA_DIRS}:%%KDE_PREFIX%%/share
+fi
+
+export XDG_DATA_DIRS
kbuildsycoca
diff --git a/misc/kde4-xdg-env/Makefile b/misc/kde4-xdg-env/Makefile
index d8f33ee0df7c..f5ba6eef59df 100644
--- a/misc/kde4-xdg-env/Makefile
+++ b/misc/kde4-xdg-env/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xdg
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= misc kde
MASTER_SITES= # none
diff --git a/misc/kde4-xdg-env/files/xdg-env.sh.in b/misc/kde4-xdg-env/files/xdg-env.sh.in
index 8d48d5ff3def..394d578ae71f 100644
--- a/misc/kde4-xdg-env/files/xdg-env.sh.in
+++ b/misc/kde4-xdg-env/files/xdg-env.sh.in
@@ -4,12 +4,24 @@
#
# Submit missing XDG-file locations to kde@freebsd.org!
-export XDG_CONFIG_DIRS=\
+XDG_CONFIG_DIRS=\
${XDG_CONFIG_DIRS}:/etc/xdg:%%LOCALBASE%%/etc/xdg:%%X11BASE%%/etc/xdg:\
-%%LOCALBASE%%/etc/xdg/xfce4:%%KDE_PREFIX%%/etc/xdg
+%%LOCALBASE%%/etc/xdg/xfce4
-export XDG_DATA_DIRS=\
-${XDG_DATA_DIRS}:/usr/share:%%LOCALBASE%%/share:\
-%%X11BASE%%/share:%%X11BASE%%/share/gnome:%%KDE_PREFIX%%/share
+if [ %%KDE_PREFIX%% != %%LOCALBASE%% ]; then
+ XDG_CONFIG_DIRS=${XDG_CONFIG_DIRS}:%%KDE_PREFIX%%/etc/xdg
+fi
+
+export XDG_CONFIG_DIRS
+
+XDG_DATA_DIRS=\
+${XDG_DATA_DIRS}:/usr/share:%%LOCALBASE%%/share:%%LOCALBASE%%/share/gnome:\
+%%X11BASE%%/share:%%X11BASE%%/share/gnome
+
+if [ %%KDE_PREFIX%% != %%LOCALBASE%% ]; then
+ XDG_DATA_DIRS=${XDG_DATA_DIRS}:%%KDE_PREFIX%%/share
+fi
+
+export XDG_DATA_DIRS
kbuildsycoca