aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-06-26 15:01:51 +0800
committermiwi <miwi@FreeBSD.org>2011-06-26 15:01:51 +0800
commit435d4eddd8e7337d1d7bab86fe0dd83131cbfa9f (patch)
tree7e2fc6a6102f88096bd58da8584bd3828d203ddf /misc
parent20c8ae6708d255279d41eb0ee88572354bc20e34 (diff)
downloadfreebsd-ports-gnome-435d4eddd8e7337d1d7bab86fe0dd83131cbfa9f.tar.gz
freebsd-ports-gnome-435d4eddd8e7337d1d7bab86fe0dd83131cbfa9f.tar.zst
freebsd-ports-gnome-435d4eddd8e7337d1d7bab86fe0dd83131cbfa9f.zip
DigiTemp is a simple to use console application for reading values from
Dallas Semiconductor 1-wire devices. Its main use is for reading temperature sensors, but it also reads counters and understands the 1-wire hubs with devices on different branches of the network. DigiTemp now supports the following 1-wire temperature sensors: DS18S20 (and DS1820), DS18B20, DS1822, the DS2438 Smart Battery Monitor, DS2422 and DS2423 Counters, DS2409 MicroLAN Coupler (used in 1-wire hubs) and the AAG TAI-8540 humidity sensor. WWW: http://www.digitemp.com/software.shtml PR: ports/158290 Submitted by: Evaldas Auryla <ea at zaib.as>
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/digitemp/Makefile55
-rw-r--r--misc/digitemp/distinfo2
-rw-r--r--misc/digitemp/files/digitemp.conf.sample10
-rw-r--r--misc/digitemp/files/patch-digitemp.h11
-rw-r--r--misc/digitemp/pkg-descr9
-rw-r--r--misc/digitemp/pkg-message8
7 files changed, 96 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index cb6432b04a4c..088d11c1da7d 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -68,6 +68,7 @@
SUBDIR += detachtty
SUBDIR += diary-hercules
SUBDIR += diction
+ SUBDIR += digitemp
SUBDIR += display
SUBDIR += dnetc
SUBDIR += dotfile
diff --git a/misc/digitemp/Makefile b/misc/digitemp/Makefile
new file mode 100644
index 000000000000..b5f04368bc43
--- /dev/null
+++ b/misc/digitemp/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: digitemp
+# Date created: 25 June 2011
+# Whom: Evaldas Auryla <ea@zaib.as>
+#
+# $FreeBSD$
+#
+
+PORTNAME= digitemp
+PORTVERSION= 3.6.0
+CATEGORIES= misc
+MASTER_SITES= http://www.digitemp.com/software/linux/
+
+MAINTAINER= ea@zaib.as
+COMMENT= Dallas Semiconductor 1-wire device reading console application
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+USE_GMAKE= yes
+
+MAN1= digitemp.1
+PLIST_FILES= bin/digitemp_DS9097 bin/digitemp_DS9097U \
+ etc/digitemp.conf.sample
+
+PORTDOCS= ChangeLog COPYING COPYRIGHT CREDITS FAQ README TODO \
+ dthowto.txt DS9097_Schematic.gif perl python rrdb
+
+ALL_TARGET= ds9097 ds9097u
+
+pre-install:
+ ${CP} ${WRKSRC}/${MAN1} ${WRKSRC}/digitemp.1.M
+ ${CAT} ${WRKSRC}/digitemp.1.M | ${SED} -e "s/dev\/ttyS/dev\/cuau/g" > ${WRKSRC}/${MAN1}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/digitemp_DS9097 ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/digitemp_DS9097U ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/ChangeLog ${WRKSRC}/COPYING ${WRKSRC}/COPYRIGHT ${WRKSRC}/CREDITS ${WRKSRC}/FAQ \
+ ${WRKSRC}/README ${WRKSRC}/TODO ${WRKSRC}/dthowto.txt ${WRKSRC}/DS9097_Schematic.gif ${DOCSDIR}
+.for dir in perl python/gui python/mysql rrdb
+ ${INSTALL} -d ${DOCSDIR}/${dir}
+ ${FIND} ${WRKSRC}/${dir}/ -maxdepth 1 -type f -exec ${INSTALL_DATA} \{\} ${DOCSDIR}/${dir} \;
+.endfor
+.endif
+ ${CAT} ${PKGMESSAGE}
+ ${INSTALL_DATA} ${FILESDIR}/digitemp.conf.sample ${PREFIX}/etc/
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Sample config installed at ${PREFIX}/etc/digitemp.conf.sample"
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>
diff --git a/misc/digitemp/distinfo b/misc/digitemp/distinfo
new file mode 100644
index 000000000000..8c4cb9b66e69
--- /dev/null
+++ b/misc/digitemp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (digitemp-3.6.0.tar.gz) = 14cfc584cd3714fe8c9a2cdc8388be49e08b5e395d95e6bcd11d4410e2505ca2
+SIZE (digitemp-3.6.0.tar.gz) = 290107
diff --git a/misc/digitemp/files/digitemp.conf.sample b/misc/digitemp/files/digitemp.conf.sample
new file mode 100644
index 000000000000..fd2ee2e5a67e
--- /dev/null
+++ b/misc/digitemp/files/digitemp.conf.sample
@@ -0,0 +1,10 @@
+TTY /dev/cuau0
+READ_TIME 1000
+LOG_TYPE 1
+LOG_FORMAT "%b %d %H:%M:%S Sensor %s C: %.2C F: %.2F"
+CNT_FORMAT "%b %d %H:%M:%S Sensor %s #%n %C"
+HUM_FORMAT "%b %d %H:%M:%S Sensor %s C: %.2C F: %.2F H: %h%%"
+SENSORS 3
+ROM 0 0x10 0x68 0x46 0x4A 0x01 0x08 0x00 0xCA
+ROM 1 0x10 0x02 0xFF 0x4D 0x01 0x08 0x00 0xFC
+ROM 2 0x10 0x78 0x94 0x72 0x01 0x08 0x00 0x18
diff --git a/misc/digitemp/files/patch-digitemp.h b/misc/digitemp/files/patch-digitemp.h
new file mode 100644
index 000000000000..b0e1c571945a
--- /dev/null
+++ b/misc/digitemp/files/patch-digitemp.h
@@ -0,0 +1,11 @@
+--- src/digitemp.h.orig 2008-08-28 06:34:17.000000000 +0200
++++ src/digitemp.h 2011-06-25 12:52:19.000000000 +0200
+@@ -18,7 +18,7 @@
+ with this program; if not, write to the Free Software Foundation, Inc.,
+ 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ ----------------------------------------------------------------------- */
+-#define BANNER_1 "DigiTemp v3.5.0 Copyright 1996-2007 by Brian C. Lane\n"
++#define BANNER_1 "DigiTemp v3.6.0 Copyright 1996-2007 by Brian C. Lane\n"
+ #define BANNER_2 "GNU Public License v2.0 - http://www.digitemp.com\n"
+ #define BANNER_3 "Compiled for %s\n\n"
+
diff --git a/misc/digitemp/pkg-descr b/misc/digitemp/pkg-descr
new file mode 100644
index 000000000000..b0757e57da6b
--- /dev/null
+++ b/misc/digitemp/pkg-descr
@@ -0,0 +1,9 @@
+DigiTemp is a simple to use console application for reading values from
+Dallas Semiconductor 1-wire devices. Its main use is for reading temperature
+sensors, but it also reads counters and understands the 1-wire hubs with
+devices on different branches of the network. DigiTemp now supports the
+following 1-wire temperature sensors: DS18S20 (and DS1820), DS18B20, DS1822,
+the DS2438 Smart Battery Monitor, DS2422 and DS2423 Counters, DS2409
+MicroLAN Coupler (used in 1-wire hubs) and the AAG TAI-8540 humidity sensor.
+
+WWW: http://www.digitemp.com/software.shtml
diff --git a/misc/digitemp/pkg-message b/misc/digitemp/pkg-message
new file mode 100644
index 000000000000..e8ae2d1ad09e
--- /dev/null
+++ b/misc/digitemp/pkg-message
@@ -0,0 +1,8 @@
+*******************************************************************
+
+ NOTE: on FreeBSD Digitemp should use /dev/cuau* serial devices,
+ so if running as non-root user, please tune your devfs rules or
+ add running user to "dialer" group which is the default owner
+ of /dev/cuau* devices !
+
+*******************************************************************