aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-04 11:40:14 +0800
committeradamw <adamw@FreeBSD.org>2014-08-04 11:40:14 +0800
commit4eda3a9e794c7b1834eede06f4e71fe345c791d6 (patch)
tree813aa84d1ad8bd3cfafe0793f530eff6e9c6194c /misc
parent0eff41e7b9a36ea4031df2f12affda98bd0b9e61 (diff)
downloadfreebsd-ports-gnome-4eda3a9e794c7b1834eede06f4e71fe345c791d6.tar.gz
freebsd-ports-gnome-4eda3a9e794c7b1834eede06f4e71fe345c791d6.tar.zst
freebsd-ports-gnome-4eda3a9e794c7b1834eede06f4e71fe345c791d6.zip
In some straightforward cases, protect documentation behind
PORTDOCS, adding a DOCS option where needed, and a couple PORTEXAMPLES for good measure.
Diffstat (limited to 'misc')
-rw-r--r--misc/pypanda/Makefile2
-rw-r--r--misc/pypanda/pkg-plist4
-rw-r--r--misc/tpp/Makefile2
-rw-r--r--misc/tpp/pkg-plist54
4 files changed, 33 insertions, 29 deletions
diff --git a/misc/pypanda/Makefile b/misc/pypanda/Makefile
index 36eb0e242683..6b4c91c8ee85 100644
--- a/misc/pypanda/Makefile
+++ b/misc/pypanda/Makefile
@@ -14,6 +14,8 @@ RUN_DEPENDS= ${PYGAME}
USE_PYTHON= yes
+OPTIONS_DEFINE= DOCS
+
do-build:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
diff --git a/misc/pypanda/pkg-plist b/misc/pypanda/pkg-plist
index 56df0e8c0ceb..389ea814eb1f 100644
--- a/misc/pypanda/pkg-plist
+++ b/misc/pypanda/pkg-plist
@@ -1,5 +1,5 @@
bin/pypanda
-%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README
%%DATADIR%%/camdown.jpg
%%DATADIR%%/camrefresh.jpg
%%DATADIR%%/pypanda.png
@@ -7,4 +7,4 @@ bin/pypanda
%%DATADIR%%/pypanda.pyc
%%DATADIR%%/pypanda.pyo
@dirrm %%DATADIR%%
-@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/misc/tpp/Makefile b/misc/tpp/Makefile
index 620820e7a872..bb63cfdf4802 100644
--- a/misc/tpp/Makefile
+++ b/misc/tpp/Makefile
@@ -16,6 +16,8 @@ NO_BUILD= yes
USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -E -e 's,share/man,man,' \
-e 's,(DOC|INS|MAN)PATH),DESTDIR)$$(&,' \
diff --git a/misc/tpp/pkg-plist b/misc/tpp/pkg-plist
index d80d8330212b..72300cd1c6a9 100644
--- a/misc/tpp/pkg-plist
+++ b/misc/tpp/pkg-plist
@@ -1,29 +1,29 @@
bin/tpp
man/man1/tpp.1.gz
-%%DOCSDIR%%/CHANGES
-%%DOCSDIR%%/COPYING
-%%DOCSDIR%%/DESIGN
-%%DOCSDIR%%/README
-%%DOCSDIR%%/THANKS
-%%DOCSDIR%%/contrib/tpp-mode.el
-%%DOCSDIR%%/contrib/tpp.vim
-%%DOCSDIR%%/examples/ac-am.tpp
-%%DOCSDIR%%/examples/align-footer.tpp
-%%DOCSDIR%%/examples/bold.tpp
-%%DOCSDIR%%/examples/colors.tpp
-%%DOCSDIR%%/examples/colors2.tpp
-%%DOCSDIR%%/examples/debian-packaging.tpp
-%%DOCSDIR%%/examples/exec.tpp
-%%DOCSDIR%%/examples/horline.tpp
-%%DOCSDIR%%/examples/huge.tpp
-%%DOCSDIR%%/examples/list.tpp
-%%DOCSDIR%%/examples/manyslides.tpp
-%%DOCSDIR%%/examples/shell.tpp
-%%DOCSDIR%%/examples/slidein.tpp
-%%DOCSDIR%%/examples/source.tpp
-%%DOCSDIR%%/examples/test.tpp
-%%DOCSDIR%%/examples/tpp-features.tpp
-%%DOCSDIR%%/examples/wrap.tpp
-@dirrm %%DOCSDIR%%/contrib
-@dirrm %%DOCSDIR%%/examples
-@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/DESIGN
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/contrib/tpp-mode.el
+%%PORTDOCS%%%%DOCSDIR%%/contrib/tpp.vim
+%%PORTDOCS%%%%DOCSDIR%%/examples/ac-am.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/align-footer.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/bold.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/colors.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/colors2.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/debian-packaging.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/exec.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/horline.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/huge.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/list.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/manyslides.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/shell.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/slidein.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/source.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/test.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/tpp-features.tpp
+%%PORTDOCS%%%%DOCSDIR%%/examples/wrap.tpp
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/contrib
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples
+%%PORTDOCS%%@dirrm %%DOCSDIR%%