aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-07-24 03:53:11 +0800
committerrakuco <rakuco@FreeBSD.org>2014-07-24 03:53:11 +0800
commit687ba4a375fe31d76ecfcfde0d4cac07d37ecd5b (patch)
tree4e541e979a7f5bac477f1b27f24bd820268cd256 /misc
parentbc7c6637ec10444b00d1f6e95659ee1c5aa7d610 (diff)
downloadfreebsd-ports-gnome-687ba4a375fe31d76ecfcfde0d4cac07d37ecd5b.tar.gz
freebsd-ports-gnome-687ba4a375fe31d76ecfcfde0d4cac07d37ecd5b.tar.zst
freebsd-ports-gnome-687ba4a375fe31d76ecfcfde0d4cac07d37ecd5b.zip
Update PyQt to 4.11.1, QScintilla to 2.8.3 and SIP to 4.16.2.
... And bump PORTREVISION on ports that depend on devel/qscintilla2 due to the shlib version change. This is brought to you by the KDE on FreeBSD team. Besides updating to newer upstream releases, this commit also contains a lot of under-the-hood changes to the PyQt/QScintilla/SIP ports. Their Makefiles had accumulated a lot of cruft over time, so it was time for some summer cleaning: - General, belated changes: * Use OPTIONS helpers wherever possible, stop including <bsd.port.options.mk> when not necessary, stop checking for ${PORT_OPTIONS:MDOCS} and ${PORT_OPTIONS:MEXAMPLES} when not necessary, add options such as DOCS and/or DEBUG where they were only checked for. - QScintilla ports: * Drop the API option from py-qt4-qscintilla2. It had been broken ever since staging support was added, and its existence does not make much sense: QScintilla is a hard dependency regardless of the state of this option anyway, they all come from the same tarball and the configuration script assumes the .api file will always be installed. - PyQt ports: * The configure.py patch shared by all PyQt ports has been trimmed down to the minimum. Changes for Qt3 compatibility or for things that are just not needed anymore have been removed. * Several post-configure targets in the PyQt ports have been removed, as they had no effect on the way the ports were built whatsoever. * In some cases, instead of calling Python's py_compile.py on `ls *.py */*.py */*/*.py` to generate .pyc and .pyo files, we just call compileall.py, which is made for this kind of task. * The patch + sed hack to build py-qt4-dbussupport has been replaced by only extracting the dbus/ directory for that port and excluding it from all others. * Move the bulk of the code in all Makefiles to bsd.pyqt.mk, like the non-Python Qt ports do with bsd.qt.mk and the QT_DIST variable. A large portion of all PyQt Makefiles were very similar and contained a lot of boilerplate code that can be shared among all of them since they all come from the same tarball. bsd.pyqt.mk now has a PYQT4_DIST variable that, when set, automatically sets several common variables and the do-configure target for a port. This allows us to considerably reduce the size of all the py-qt4-* Makefiles. * To make the above possible and also to allow us to use as many OPTIONS helpers as possible, the ARGS variable is now called CONFIGURE_ARGS. That's what it was used for anyway. PR: 191990
Diffstat (limited to 'misc')
-rw-r--r--misc/py-qt4-demo/Makefile9
-rw-r--r--misc/py-qt4-demo/pkg-plist23
2 files changed, 8 insertions, 24 deletions
diff --git a/misc/py-qt4-demo/Makefile b/misc/py-qt4-demo/Makefile
index 7951e053680c..29f09a2e3ac6 100644
--- a/misc/py-qt4-demo/Makefile
+++ b/misc/py-qt4-demo/Makefile
@@ -17,15 +17,18 @@ USE_PYTHON= yes
EXAMPLESDIR= ${PREFIX}/share/examples/py-qt4
-OPTIONS_DEFINE= PYQT4
-PYQT4_DESC= Install all PyQt4 components
-
.include "${.CURDIR}/../../devel/py-qt4/bsd.pyqt.mk"
.for component in ${PYQT4_COMPONENTS:Ndemo}
PYQT4_RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}qt4-${component}>=0:${PORTSDIR}/${${component}_PORT}
.endfor
+# Remove some empty __pycache__/ directories that are wrongly part of the
+# tarball and cause check-plist failures.
+post-patch:
+ ${RMDIR} ${WRKSRC}/examples/opengl/textures/__pycache__
+ ${RMDIR} ${WRKSRC}/examples/widgets/stylesheet/__pycache__
+
do-build:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/examples
diff --git a/misc/py-qt4-demo/pkg-plist b/misc/py-qt4-demo/pkg-plist
index 70b32a87a948..035fc9f2e91d 100644
--- a/misc/py-qt4-demo/pkg-plist
+++ b/misc/py-qt4-demo/pkg-plist
@@ -101,7 +101,6 @@
%%EXAMPLESDIR%%/dbus/remotecontrolledcar/controller/controller.ui
%%EXAMPLESDIR%%/dbus/remotecontrolledcar/controller/ui_controller.py
%%EXAMPLESDIR%%/dbus/remotecontrolledcar/controller/ui_controller.pyc
-%%EXAMPLESDIR%%/declarative/modelviews/objectlistmodel/__pycache__/objectlistmodel_rc3.cpython-33.pyc
%%EXAMPLESDIR%%/declarative/modelviews/objectlistmodel/objectlistmodel.py
%%EXAMPLESDIR%%/declarative/modelviews/objectlistmodel/objectlistmodel.pyc
%%EXAMPLESDIR%%/declarative/modelviews/objectlistmodel/objectlistmodel.qrc
@@ -236,26 +235,6 @@
%%EXAMPLESDIR%%/demos/embeddeddialogs/embeddeddialogs_rc2.pyc
%%EXAMPLESDIR%%/demos/embeddeddialogs/embeddeddialogs_rc3.py
%%EXAMPLESDIR%%/demos/embeddeddialogs/embeddeddialogs_rc3.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/colors.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/demoitem.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/demoitemanimation.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/demoscene.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/demotextitem.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/examplecontent.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/guide.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/guidecircle.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/guideline.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/headingitem.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/imageitem.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/itemcircleanimation.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/letteritem.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/mainwindow.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/menucontent.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/menumanager.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/qtdemo_rc3.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/scanitem.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/score.cpython-33.pyc
-%%EXAMPLESDIR%%/demos/qtdemo/__pycache__/textbutton.cpython-33.pyc
%%EXAMPLESDIR%%/demos/qtdemo/colors.py
%%EXAMPLESDIR%%/demos/qtdemo/colors.pyc
%%EXAMPLESDIR%%/demos/qtdemo/demoitem.py
@@ -957,6 +936,8 @@
%%EXAMPLESDIR%%/webkit/simpleselector/ui_window.py
%%EXAMPLESDIR%%/webkit/simpleselector/ui_window.pyc
%%EXAMPLESDIR%%/webkit/simpleselector/window.ui
+%%EXAMPLESDIR%%/webkit/webftpclient.py
+%%EXAMPLESDIR%%/webkit/webftpclient.pyc
%%EXAMPLESDIR%%/widgets/README
%%EXAMPLESDIR%%/widgets/analogclock.py
%%EXAMPLESDIR%%/widgets/analogclock.pyc