aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-08-09 15:21:36 +0800
committerstas <stas@FreeBSD.org>2009-08-09 15:21:36 +0800
commitaf129acc6b61ab01b548f1c89d770a303c1f83ba (patch)
tree1b908145266c49dfa28414b5ebd7b7762b286047 /misc
parentb05267d1ed7005348b18c62818c258875ed911dd (diff)
downloadfreebsd-ports-gnome-af129acc6b61ab01b548f1c89d770a303c1f83ba.tar.gz
freebsd-ports-gnome-af129acc6b61ab01b548f1c89d770a303c1f83ba.tar.zst
freebsd-ports-gnome-af129acc6b61ab01b548f1c89d770a303c1f83ba.zip
- Fix on HEAD.
Diffstat (limited to 'misc')
-rw-r--r--misc/ftdi-eeprom/Makefile8
-rw-r--r--misc/ftdi-eeprom/files/patch-ftdi-eeprom.c10
2 files changed, 11 insertions, 7 deletions
diff --git a/misc/ftdi-eeprom/Makefile b/misc/ftdi-eeprom/Makefile
index fd02996a7cf7..02eb5a746395 100644
--- a/misc/ftdi-eeprom/Makefile
+++ b/misc/ftdi-eeprom/Makefile
@@ -20,10 +20,4 @@ PLIST_FILES= sbin/ftdi-eeprom
MAN8= ftdi-eeprom.8
MANCOMPRESSED= maybe
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800064
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/ftdi-eeprom/files/patch-ftdi-eeprom.c b/misc/ftdi-eeprom/files/patch-ftdi-eeprom.c
new file mode 100644
index 000000000000..e1e2958300b8
--- /dev/null
+++ b/misc/ftdi-eeprom/files/patch-ftdi-eeprom.c
@@ -0,0 +1,10 @@
+--- ftdi-eeprom.c.orig 2009-08-09 11:21:23.000000000 +0400
++++ ftdi-eeprom.c 2009-08-09 11:21:37.000000000 +0400
+@@ -44,6 +44,7 @@
+ #include <string.h>
+ #include <limits.h>
+ #include <dev/usb/usb.h>
++#include <dev/usb/usb_ioctl.h>
+
+ #include "ftdi-eeprom.h"
+