aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2011-05-21 15:45:16 +0800
committerkuriyama <kuriyama@FreeBSD.org>2011-05-21 15:45:16 +0800
commitc1c74d0ec1dd68453526393d8e36dec4121378f2 (patch)
treefce47abf69e69bc19f1ccac07f80cf715fbcc230 /misc
parentaa26b50b50fa820936f03df0eb003a2d03025baa (diff)
downloadfreebsd-ports-gnome-c1c74d0ec1dd68453526393d8e36dec4121378f2.tar.gz
freebsd-ports-gnome-c1c74d0ec1dd68453526393d8e36dec4121378f2.tar.zst
freebsd-ports-gnome-c1c74d0ec1dd68453526393d8e36dec4121378f2.zip
- Upgrade to 3.2.2.
- Add hidden option to disable snapshot dump for testing.
Diffstat (limited to 'misc')
-rw-r--r--misc/amanda-server/Makefile5
-rw-r--r--misc/amanda-server/distinfo4
-rw-r--r--misc/amanda-server/files/extra-patch-application-src::amzfs-sendrecv.pl52
-rw-r--r--misc/amanda-server/files/extra-patch-sendbackup-dump.c23
-rw-r--r--misc/amanda-server/files/patch-client-src::sendbackup-dump.c11
-rw-r--r--misc/amanda32-server/Makefile5
-rw-r--r--misc/amanda32-server/distinfo4
-rw-r--r--misc/amanda32-server/files/extra-patch-application-src::amzfs-sendrecv.pl52
-rw-r--r--misc/amanda32-server/files/extra-patch-sendbackup-dump.c23
-rw-r--r--misc/amanda32-server/files/patch-client-src::sendbackup-dump.c11
10 files changed, 34 insertions, 156 deletions
diff --git a/misc/amanda-server/Makefile b/misc/amanda-server/Makefile
index 4b9a3979689c..ec7963bdbb54 100644
--- a/misc/amanda-server/Makefile
+++ b/misc/amanda-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= amanda
-PORTVERSION= 3.2.1
+PORTVERSION= 3.2.2
PORTEPOCH= 1
CATEGORIES= misc
MASTER_SITES= SF/amanda/amanda%20-%20stable/${PORTVERSION}
@@ -189,6 +189,9 @@ pre-fetch:
CONFLICTS= amanda-client-2.5.* amanda-client-2.6.*
CONFIGURE_ARGS+=--without-server --with-amandates=${AMANDA_DATES}
+.if defined(AMANDA_NO_SNAPSHOT_DUMP)
+CFLAGS= -DFreeBSD_NO_SNAPSHOT_DUMP=t
+.endif
MAN5= amanda-archive-format.5 \
amanda-client.conf.5 \
diff --git a/misc/amanda-server/distinfo b/misc/amanda-server/distinfo
index 7776e7c4bf8d..5db6f282e614 100644
--- a/misc/amanda-server/distinfo
+++ b/misc/amanda-server/distinfo
@@ -1,2 +1,2 @@
-SHA256 (amanda-3.2.1.tar.gz) = 187b4ccc32af03b4ca6a9658f2d6a7884a934c7864730b0bb5bc5e82457b486f
-SIZE (amanda-3.2.1.tar.gz) = 4116514
+SHA256 (amanda-3.2.2.tar.gz) = 6bf8e3e39a55e877d8cbe75b927b985b9316654af26a3bd47022a2a2c99b3bac
+SIZE (amanda-3.2.2.tar.gz) = 4120254
diff --git a/misc/amanda-server/files/extra-patch-application-src::amzfs-sendrecv.pl b/misc/amanda-server/files/extra-patch-application-src::amzfs-sendrecv.pl
deleted file mode 100644
index 0a19153747d9..000000000000
--- a/misc/amanda-server/files/extra-patch-application-src::amzfs-sendrecv.pl
+++ /dev/null
@@ -1,52 +0,0 @@
---- application-src/amzfs-sendrecv.pl.orig 2009-01-22 02:35:38.000000000 +0100
-+++ application-src/amzfs-sendrecv.pl 2009-01-31 10:37:59.495534563 +0100
-@@ -235,13 +235,48 @@
- } elsif (defined $errmsg) {
- $self->print_to_server_and_die($action, $errmsg, $Amanda::Script_App::ERROR);
- } else {
-- $self->print_to_server_and_die($action, "cannot estimate snapshot '$self->{snapshot}\@$self->{snapshot}': unknown reason", $Amanda::Script_App::ERROR);
-+ $self->print_to_server_and_die($action, "cannot estimate snapshot '$self->{snapshot}\@$self->{snapshot}': unknown reason", $Amanda::Script_App::ERROR);
- }
- }
-+ if ($level == 0) {
-+ my $compratio = $self->get_compratio();
-+ $msg *= int $compratio;
-+ }
-
- return $msg;
- }
-
-+sub get_compratio
-+{
-+ my $self = shift;
-+ my $action = shift;
-+
-+ my $cmd;
-+ $cmd = "$self->{pfexec_cmd} $self->{zfs_path} get -Hp -o value compressratio $self->{filesystem}\@$self->{snapshot}";
-+ debug "running (get-compression): $cmd";
-+ my($wtr, $rdr, $err, $pid);
-+ $err = Symbol::gensym;
-+ $pid = open3($wtr, $rdr, $err, $cmd);
-+ close $wtr;
-+ my ($msg) = <$rdr>;
-+ my ($errmsg) = <$err>;
-+ waitpid $pid, 0;
-+ close $rdr;
-+ close $err;
-+ if ($? != 0) {
-+ if (defined $msg && defined $errmsg) {
-+ $self->print_to_server_and_die($action, "$msg, $errmsg", $Amanda::Script_App::ERROR);
-+ } elsif (defined $msg) {
-+ $self->print_to_server_and_die($action, $msg, $Amanda::Script_App::ERROR);
-+ } elsif (defined $errmsg) {
-+ $self->print_to_server_and_die($action, $errmsg, $Amanda::Script_App::ERROR);
-+ } else {
-+ $self->print_to_server_and_die($action, "cannot read compression ratio '$self->{snapshot}\@$self->{snapshot}': unknown reason", $Amanda::Script_App::ERROR);
-+ }
-+ }
-+ return $msg
-+}
-+
- sub command_index_from_output {
- }
-
diff --git a/misc/amanda-server/files/extra-patch-sendbackup-dump.c b/misc/amanda-server/files/extra-patch-sendbackup-dump.c
deleted file mode 100644
index 3a232d1a8f25..000000000000
--- a/misc/amanda-server/files/extra-patch-sendbackup-dump.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- client-src/sendbackup-dump.c.orig 2008-12-13 04:18:11.000000000 +0900
-+++ client-src/sendbackup-dump.c 2009-01-27 07:30:40.000000000 +0900
-@@ -35,6 +35,10 @@
- #include "clock.h"
- #include "version.h"
-
-+#ifdef __FreeBSD__
-+#include <sys/param.h>
-+#endif
-+
- #define LEAF_AND_DIRS "sed -e \'\ns/^leaf[ \t]*[0-9]*[ \t]*\\.//\nt\n/^dir[ \t]/ {\ns/^dir[ \t]*[0-9]*[ \t]*\\.//\ns%$%/%\nt\n}\nd\n\'"
-
- static amregex_t re_table[] = {
-@@ -310,6 +314,9 @@
- cmdX, config,
- "vxdump",
- dumpkeys,
-+#ifdef __FreeBSD__
-+ "64",
-+#endif
- "1048576",
- "-",
- device,
diff --git a/misc/amanda-server/files/patch-client-src::sendbackup-dump.c b/misc/amanda-server/files/patch-client-src::sendbackup-dump.c
new file mode 100644
index 000000000000..5df8dc8b57e8
--- /dev/null
+++ b/misc/amanda-server/files/patch-client-src::sendbackup-dump.c
@@ -0,0 +1,11 @@
+--- client-src/sendbackup-dump.c.orig 2011-04-24 16:41:40.874642189 +0900
++++ client-src/sendbackup-dump.c 2011-04-24 16:42:28.215501968 +0900
+@@ -377,7 +377,7 @@
+ #endif
+
+ #ifdef __FreeBSD__
+-# if defined(__FreeBSD_version) && (__FreeBSD_version >= 500043)
++# if defined(__FreeBSD_version) && (__FreeBSD_version >= 500043) && !defined(FreeBSD_NO_SNAPSHOT_DUMP)
+ # define FREEBSD_EXTRA_KEYS "bL"
+ # else
+ # define FREEBSD_EXTRA_KEYS "b"
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index 4b9a3979689c..ec7963bdbb54 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= amanda
-PORTVERSION= 3.2.1
+PORTVERSION= 3.2.2
PORTEPOCH= 1
CATEGORIES= misc
MASTER_SITES= SF/amanda/amanda%20-%20stable/${PORTVERSION}
@@ -189,6 +189,9 @@ pre-fetch:
CONFLICTS= amanda-client-2.5.* amanda-client-2.6.*
CONFIGURE_ARGS+=--without-server --with-amandates=${AMANDA_DATES}
+.if defined(AMANDA_NO_SNAPSHOT_DUMP)
+CFLAGS= -DFreeBSD_NO_SNAPSHOT_DUMP=t
+.endif
MAN5= amanda-archive-format.5 \
amanda-client.conf.5 \
diff --git a/misc/amanda32-server/distinfo b/misc/amanda32-server/distinfo
index 7776e7c4bf8d..5db6f282e614 100644
--- a/misc/amanda32-server/distinfo
+++ b/misc/amanda32-server/distinfo
@@ -1,2 +1,2 @@
-SHA256 (amanda-3.2.1.tar.gz) = 187b4ccc32af03b4ca6a9658f2d6a7884a934c7864730b0bb5bc5e82457b486f
-SIZE (amanda-3.2.1.tar.gz) = 4116514
+SHA256 (amanda-3.2.2.tar.gz) = 6bf8e3e39a55e877d8cbe75b927b985b9316654af26a3bd47022a2a2c99b3bac
+SIZE (amanda-3.2.2.tar.gz) = 4120254
diff --git a/misc/amanda32-server/files/extra-patch-application-src::amzfs-sendrecv.pl b/misc/amanda32-server/files/extra-patch-application-src::amzfs-sendrecv.pl
deleted file mode 100644
index 0a19153747d9..000000000000
--- a/misc/amanda32-server/files/extra-patch-application-src::amzfs-sendrecv.pl
+++ /dev/null
@@ -1,52 +0,0 @@
---- application-src/amzfs-sendrecv.pl.orig 2009-01-22 02:35:38.000000000 +0100
-+++ application-src/amzfs-sendrecv.pl 2009-01-31 10:37:59.495534563 +0100
-@@ -235,13 +235,48 @@
- } elsif (defined $errmsg) {
- $self->print_to_server_and_die($action, $errmsg, $Amanda::Script_App::ERROR);
- } else {
-- $self->print_to_server_and_die($action, "cannot estimate snapshot '$self->{snapshot}\@$self->{snapshot}': unknown reason", $Amanda::Script_App::ERROR);
-+ $self->print_to_server_and_die($action, "cannot estimate snapshot '$self->{snapshot}\@$self->{snapshot}': unknown reason", $Amanda::Script_App::ERROR);
- }
- }
-+ if ($level == 0) {
-+ my $compratio = $self->get_compratio();
-+ $msg *= int $compratio;
-+ }
-
- return $msg;
- }
-
-+sub get_compratio
-+{
-+ my $self = shift;
-+ my $action = shift;
-+
-+ my $cmd;
-+ $cmd = "$self->{pfexec_cmd} $self->{zfs_path} get -Hp -o value compressratio $self->{filesystem}\@$self->{snapshot}";
-+ debug "running (get-compression): $cmd";
-+ my($wtr, $rdr, $err, $pid);
-+ $err = Symbol::gensym;
-+ $pid = open3($wtr, $rdr, $err, $cmd);
-+ close $wtr;
-+ my ($msg) = <$rdr>;
-+ my ($errmsg) = <$err>;
-+ waitpid $pid, 0;
-+ close $rdr;
-+ close $err;
-+ if ($? != 0) {
-+ if (defined $msg && defined $errmsg) {
-+ $self->print_to_server_and_die($action, "$msg, $errmsg", $Amanda::Script_App::ERROR);
-+ } elsif (defined $msg) {
-+ $self->print_to_server_and_die($action, $msg, $Amanda::Script_App::ERROR);
-+ } elsif (defined $errmsg) {
-+ $self->print_to_server_and_die($action, $errmsg, $Amanda::Script_App::ERROR);
-+ } else {
-+ $self->print_to_server_and_die($action, "cannot read compression ratio '$self->{snapshot}\@$self->{snapshot}': unknown reason", $Amanda::Script_App::ERROR);
-+ }
-+ }
-+ return $msg
-+}
-+
- sub command_index_from_output {
- }
-
diff --git a/misc/amanda32-server/files/extra-patch-sendbackup-dump.c b/misc/amanda32-server/files/extra-patch-sendbackup-dump.c
deleted file mode 100644
index 3a232d1a8f25..000000000000
--- a/misc/amanda32-server/files/extra-patch-sendbackup-dump.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- client-src/sendbackup-dump.c.orig 2008-12-13 04:18:11.000000000 +0900
-+++ client-src/sendbackup-dump.c 2009-01-27 07:30:40.000000000 +0900
-@@ -35,6 +35,10 @@
- #include "clock.h"
- #include "version.h"
-
-+#ifdef __FreeBSD__
-+#include <sys/param.h>
-+#endif
-+
- #define LEAF_AND_DIRS "sed -e \'\ns/^leaf[ \t]*[0-9]*[ \t]*\\.//\nt\n/^dir[ \t]/ {\ns/^dir[ \t]*[0-9]*[ \t]*\\.//\ns%$%/%\nt\n}\nd\n\'"
-
- static amregex_t re_table[] = {
-@@ -310,6 +314,9 @@
- cmdX, config,
- "vxdump",
- dumpkeys,
-+#ifdef __FreeBSD__
-+ "64",
-+#endif
- "1048576",
- "-",
- device,
diff --git a/misc/amanda32-server/files/patch-client-src::sendbackup-dump.c b/misc/amanda32-server/files/patch-client-src::sendbackup-dump.c
new file mode 100644
index 000000000000..5df8dc8b57e8
--- /dev/null
+++ b/misc/amanda32-server/files/patch-client-src::sendbackup-dump.c
@@ -0,0 +1,11 @@
+--- client-src/sendbackup-dump.c.orig 2011-04-24 16:41:40.874642189 +0900
++++ client-src/sendbackup-dump.c 2011-04-24 16:42:28.215501968 +0900
+@@ -377,7 +377,7 @@
+ #endif
+
+ #ifdef __FreeBSD__
+-# if defined(__FreeBSD_version) && (__FreeBSD_version >= 500043)
++# if defined(__FreeBSD_version) && (__FreeBSD_version >= 500043) && !defined(FreeBSD_NO_SNAPSHOT_DUMP)
+ # define FREEBSD_EXTRA_KEYS "bL"
+ # else
+ # define FREEBSD_EXTRA_KEYS "b"