aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-12-09 21:24:51 +0800
committerdanilo <danilo@FreeBSD.org>2013-12-09 21:24:51 +0800
commitc23f1e7fbeea9257cd2d115f2c0244aa5a499194 (patch)
tree3104311ad94fcbae93d704bc1c15932f728bb845 /misc
parentf27f339ac0d38a6db2fde927201f527304b7ffae (diff)
downloadfreebsd-ports-gnome-c23f1e7fbeea9257cd2d115f2c0244aa5a499194.tar.gz
freebsd-ports-gnome-c23f1e7fbeea9257cd2d115f2c0244aa5a499194.tar.zst
freebsd-ports-gnome-c23f1e7fbeea9257cd2d115f2c0244aa5a499194.zip
- Add stage support
- Simplify the Makefile
Diffstat (limited to 'misc')
-rw-r--r--misc/cwish/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/misc/cwish/Makefile b/misc/cwish/Makefile
index 3f4dc7289c59..a0305c4d2e81 100644
--- a/misc/cwish/Makefile
+++ b/misc/cwish/Makefile
@@ -12,18 +12,14 @@ COMMENT= Curses based user friendly windowing shell
NO_WRKSUBDIR= yes
ALL_TARGET= cwish
-MAN1= cwish.1
-PLIST_FILES= bin/cwish
+PLIST_FILES= bin/cwish man/man1/cwish.1.gz
+MAKEFILE= Makefile.FreeBSD
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 65d ${WRKSRC}/cwish.h
-pre-configure:
- ${CP} ${WRKSRC}/Makefile.FreeBSD ${WRKSRC}/Makefile
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cwish ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/cwish.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/cwish ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/cwish.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>