aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-10-25 17:01:33 +0800
committergarga <garga@FreeBSD.org>2005-10-25 17:01:33 +0800
commitdab50f527da176849d0101ba7f67942e80723e7b (patch)
tree341aa24f3a3e579ceb531c5d2f33e1ef55820712 /misc
parent5e6eacb0b68714da7d415f21f0e7f508b4632e5a (diff)
downloadfreebsd-ports-gnome-dab50f527da176849d0101ba7f67942e80723e7b.tar.gz
freebsd-ports-gnome-dab50f527da176849d0101ba7f67942e80723e7b.tar.zst
freebsd-ports-gnome-dab50f527da176849d0101ba7f67942e80723e7b.zip
- Honor X11BASE [1]
- Use DATADIR macro - Respect NOPORTDOCS - Use PORTDOCS PR: ports/87901 [1] Submitted by: maintainer [1] Requested by: kris [1]
Diffstat (limited to 'misc')
-rw-r--r--misc/qbrew/Makefile15
-rw-r--r--misc/qbrew/pkg-plist46
2 files changed, 24 insertions, 37 deletions
diff --git a/misc/qbrew/Makefile b/misc/qbrew/Makefile
index 51a55a49a579..82c5c67d4a9d 100644
--- a/misc/qbrew/Makefile
+++ b/misc/qbrew/Makefile
@@ -13,12 +13,25 @@ MASTER_SITES= http://www.usermode.org/code/
MAINTAINER= david@usermode.org
COMMENT= A homebrewer's recipe calculator
+USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_QT_VER= 3
+PORTDOCS= *
QT_NONSTANDARD= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --x-includes=${X11BASE}/include \
+ --x-libraries=${X11BASE}/lib
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -E 's,^(SUBDIRS = .*) docs,\1,' \
+ ${WRKSRC}/Makefile.in
+.endif
post-install:
${STRIP_CMD} ${PREFIX}/bin/qbrew
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/qbrew/pkg-plist b/misc/qbrew/pkg-plist
index 04186c54117e..fa85ef84afaf 100644
--- a/misc/qbrew/pkg-plist
+++ b/misc/qbrew/pkg-plist
@@ -1,37 +1,11 @@
bin/qbrew
-share/doc/qbrew/en/primer-design.html
-share/doc/qbrew/en/primer-equipment.html
-share/doc/qbrew/en/primer-firstbrew.html
-share/doc/qbrew/en/primer-glossary.html
-share/doc/qbrew/en/primer-mashing.html
-share/doc/qbrew/en/primer-recipes.html
-share/doc/qbrew/en/primer.html
-share/doc/qbrew/en/qbrew-changes.html
-share/doc/qbrew/en/qbrew-commandline.html
-share/doc/qbrew/en/qbrew-configuration.html
-share/doc/qbrew/en/qbrew-copyright.html
-share/doc/qbrew/en/qbrew-credits.html
-share/doc/qbrew/en/qbrew-faq.html
-share/doc/qbrew/en/qbrew-handbook.html
-share/doc/qbrew/en/qbrew-hop.html
-share/doc/qbrew/en/qbrew-install.html
-share/doc/qbrew/en/qbrew-intro.html
-share/doc/qbrew/en/qbrew-misc.html
-share/doc/qbrew/en/qbrew-notes.html
-share/doc/qbrew/en/qbrew-reference.html
-share/doc/qbrew/en/qbrew-using.html
-share/doc/qbrew/en/qbrew.docbook
-share/doc/qbrew/en/qbrew.xsl
-share/doc/qbrew/en/sqa.html
-share/qbrew/ChangeLog
-share/qbrew/LICENSE
-share/qbrew/README
-share/qbrew/paleale.qbrew
-share/qbrew/qbrew.png
-share/qbrew/qbrew.svg
-share/qbrew/qbrewdata
-share/qbrew/splash.png
-share/qbrew/stout.qbrew
-@dirrm share/qbrew
-@dirrm share/doc/qbrew/en
-@dirrm share/doc/qbrew
+%%DATADIR%%/ChangeLog
+%%DATADIR%%/LICENSE
+%%DATADIR%%/README
+%%DATADIR%%/paleale.qbrew
+%%DATADIR%%/qbrew.png
+%%DATADIR%%/qbrew.svg
+%%DATADIR%%/qbrewdata
+%%DATADIR%%/splash.png
+%%DATADIR%%/stout.qbrew
+@dirrm %%DATADIR%%