aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2003-05-23 08:21:11 +0800
committerdes <des@FreeBSD.org>2003-05-23 08:21:11 +0800
commit1264a811c0337c1944b7a84b7683cf0123407c7d (patch)
tree626711e01ab3532a95f7a130269608fad7290696 /misc
parent3c8debccf69dd51c48051cab58d8785ee618202c (diff)
downloadfreebsd-ports-gnome-1264a811c0337c1944b7a84b7683cf0123407c7d.tar.gz
freebsd-ports-gnome-1264a811c0337c1944b7a84b7683cf0123407c7d.tar.zst
freebsd-ports-gnome-1264a811c0337c1944b7a84b7683cf0123407c7d.zip
Fix a bug in the version number comparison code caused by careless use
of the magic variabled $a and $b. Also fix a markup nit in the man page.
Diffstat (limited to 'misc')
-rw-r--r--misc/porteasy/Makefile2
-rw-r--r--misc/porteasy/src/porteasy.84
-rw-r--r--misc/porteasy/src/porteasy.pl15
3 files changed, 9 insertions, 12 deletions
diff --git a/misc/porteasy/Makefile b/misc/porteasy/Makefile
index 2872db96fd32..38731390b3a1 100644
--- a/misc/porteasy/Makefile
+++ b/misc/porteasy/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= porteasy
-PORTVERSION= 2.7.6
+PORTVERSION= 2.7.7
CATEGORIES= misc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/misc/porteasy/src/porteasy.8 b/misc/porteasy/src/porteasy.8
index 1fd24d022ce5..844342259339 100644
--- a/misc/porteasy/src/porteasy.8
+++ b/misc/porteasy/src/porteasy.8
@@ -27,14 +27,14 @@
.\"
.\" $FreeBSD$
.\"
-.Dd June 9, 2001
+.Dd May 23, 2003
.Dt PORTEASY 8
.Os
.Sh NAME
.Nm porteasy
.Nd fetch and build ports
.Sh SYNOPSIS
-.Nm porteasy
+.Nm
.Op Fl abCceFfhIikLlsuVvw
.Op Fl D Ar date
.Op Fl d Ar dir
diff --git a/misc/porteasy/src/porteasy.pl b/misc/porteasy/src/porteasy.pl
index 0c947dffc176..6bbba53e75ce 100644
--- a/misc/porteasy/src/porteasy.pl
+++ b/misc/porteasy/src/porteasy.pl
@@ -33,7 +33,7 @@ use strict;
use Fcntl;
use Getopt::Long;
-my $VERSION = "2.7.6";
+my $VERSION = "2.7.7";
my $COPYRIGHT = "Copyright (c) 2000-2003 Dag-Erling Smørgrav. " .
"All rights reserved.";
@@ -849,16 +849,13 @@ sub cmp_version($$) {
}
# Compare port epochs
+ my ($inst_epoch, $tree_epoch) = (0, 0);
$inst =~ s/,(\d+)$//
- and $a = $1;
+ and $inst_epoch = $1;
$tree =~ s/,(\d+)$//
- and $b = $1;
- if (defined($a) || defined($b)) {
- $a = int($a || 0);
- $b = int($b || 0);
- if ($a != $b) {
- return ($a > $b) ? '>' : '<';
- }
+ and $tree_epoch = $1;
+ if ($inst_epoch != $tree_epoch) {
+ return ($inst_epoch > $tree_epoch) ? '>' : '<';
}
# Split it into components