aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorphilip <philip@FreeBSD.org>2005-10-21 22:24:02 +0800
committerphilip <philip@FreeBSD.org>2005-10-21 22:24:02 +0800
commit1a79a1a85477bab7d4d296333a81e99e00ee5111 (patch)
treee722ebef4c028e449e543a7f374fd2ecca8c487b /misc
parent38ad86ed52473cf767b1c4cb31227105b78a4b43 (diff)
downloadfreebsd-ports-gnome-1a79a1a85477bab7d4d296333a81e99e00ee5111.tar.gz
freebsd-ports-gnome-1a79a1a85477bab7d4d296333a81e99e00ee5111.tar.zst
freebsd-ports-gnome-1a79a1a85477bab7d4d296333a81e99e00ee5111.zip
Fix handling of utmp entries on sparc64.
Approved by: cy (maintainer) Obtained from: NetBSD
Diffstat (limited to 'misc')
-rw-r--r--misc/screen/Makefile2
-rw-r--r--misc/screen/files/patch-utmp.c17
2 files changed, 18 insertions, 1 deletions
diff --git a/misc/screen/Makefile b/misc/screen/Makefile
index 64db128c44a2..883b99a9f814 100644
--- a/misc/screen/Makefile
+++ b/misc/screen/Makefile
@@ -7,7 +7,7 @@
PORTNAME= screen
PORTVERSION= 4.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc
MASTER_SITES= ftp://ftp.uni-erlangen.de/pub/utilities/screen/ \
${MASTER_SITE_GNU}
diff --git a/misc/screen/files/patch-utmp.c b/misc/screen/files/patch-utmp.c
new file mode 100644
index 000000000000..caedb6c1ec50
--- /dev/null
+++ b/misc/screen/files/patch-utmp.c
@@ -0,0 +1,17 @@
+--- utmp.c.orig Mon Sep 8 16:27:17 2003
++++ utmp.c Wed Oct 19 14:58:40 2005
+@@ -726,9 +728,12 @@
+ char *line, *user;
+ int pid;
+ {
++ time_t temp;
++
+ strncpy(u->ut_line, line, sizeof(u->ut_line));
+ strncpy(u->ut_name, user, sizeof(u->ut_name));
+- (void)time((time_t *)&u->ut_time);
++ (void)time(&temp);
++ u->ut_time = temp;
+ }
+
+ static slot_t
+